[xterm] add better charclass map

Bug #17601 reported by Anthony Edwards on 2005-05-29
10
Affects Status Importance Assigned to Milestone
xterm (Debian)
New
Unknown
xterm (Ubuntu)
Wishlist
Unassigned

Bug Description

Standard xterm configuration in other distributions (e.g. SuSE) permits
automatic highlighting (for cut and pasting purposes) of both IP addresses and
email addresses by doubleclicking, controlled by the following line in their
equivalent of /etc/X11/app-defaults/XTerm:

*charClass: 33:48,37:48,43:48,45-47:48,64:48,126:48,95:48

This would be a useful enhancement for Ubuntu I think. Most users coming to
Ubuntu from other distributions will expect this to be the default xterm
behaviour, and may not be able to find out how to configure it themselves.

Related branches

Matt Zimmerman (mdz) wrote :

gnome-terminal already handles this sort of thing in a nicer way

Daniel Stone (daniels) wrote :

yes

Apologies for the delay in responding to this. My concern is that leaving the
bug unfixed simply due to the fact that use of another terminal application
offers a workaround is not within the spirit of the open source software
community. If Ubuntu are saying "You *must* use Gnome, and you *must* use Gnome
Terminal" that's fine, but it should be more clearly spelled out in the Ubuntu
documentation, and/or on the Ubuntu web site, that instance I believe. I like
xterms. I am used to using xterms. A significant number of those migrating to
Ubuntu will no doubt feel the same. Since the simple and easy fix that I
recommended will resolve what I believe to be an annoying issue for many
(perhaps most) xterm users, why not apply it? That Gnome Terminal handles such
things well is good. However, not everyone wants to use Gnome Terminal, and
leaving xterm in a slightly crippled state compared to its packaging in other
distributions seems a somewhat odd decision, given that the fix is so simple and
involves the addition of one line to one configuration file, which most users
will be unable to find and apply for themselves.

Stephan Ruegamer (sadig) wrote :

Hi Anthony,

actually, I'm not a SuSE user ;) but can you do me a favour and send me SuSE
Xterms app-defaults then?
Can't promise if any enhancements are making it into Breezy but let's see :)

Thx,

\sh

Stephan Ruegamer (sadig) wrote :

with the next upload this should be fixed.
upload is already in the queue...will be pulled after preview.

Anthony Edwards (anthony-yoyo) wrote :

I have recently upgraded to 7.10 (Gutsy Gibbon), and the xterm package for this latest version has reverted to the old, pre-fix configuration. Can this be again fixed in the xterm package for 7.10 please?

Changed in xterm:
status: Fix Released → New
Stephan Ruegamer (sadig) on 2008-01-19
Changed in xterm:
assignee: shermann → nobody
Stephan Ruegamer (sadig) wrote :

Hi,

I've applied the patch which sadly disappeared from this package.

I'll subscribe core sponsors for this.

Changed in xterm:
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Bryce: does this look OK?

Bryce Harrington (bryce) wrote :

Yes this looks fine. I notice the pattern in the patch above differs slightly from what is shown commented in /etc/X11/app-defaults/XTerm; I assume the version in this patch is better for some reason. But either charclass map looks good to upload.

On Mon, Jan 28, 2008 at 01:20:49PM -0000, Bryce Harrington wrote:
> Yes this looks fine. I notice the pattern in the patch above differs
> slightly from what is shown commented in /etc/X11/app-defaults/XTerm; I
> assume the version in this patch is better for some reason. But either
> charclass map looks good to upload.
>
> --
> [xterm] add better charclass map
> https://bugs.launchpad.net/bugs/17601
> You received this bug notification because you are a direct subscriber
> of the bug.

Hi Bruce

In fact I am now using, currently as a line in ~/.Xdefaults :

*charClass: 33:48,35:48,37-38:48,43-47:48,58:48,61:48,63-64:48,126:48

That has the advantage over the charClass entry in the bug as it
appears on Launchpad that it not only facilitates double click
highlighting of email addresses, but full URLs also.

It might be a better choice.

Kind regards

Anthony Edwards

--
Anthony Edwards
<email address hidden>

Daniel Holbach (dholbach) wrote :

Can somebody update the patch according to the discussion?

Daniel Holbach (dholbach) wrote :

Unsubscribing Ubuntu Sponsors for main from this bug for now.

Tormod Volden (tormodvolden) wrote :

The line suggested (but commented out) in the upstream version is the same as the one Anthony is using, with the addition of _ (underscore). It would make sense to just uncomment this one then, IMHO.

Changed in xterm:
status: Unknown → New
Daniel Holbach (dholbach) wrote :

Bryce: can you take a look at this one?

Bryce Harrington (bryce) wrote :

Looks great, +1 for upload from me. (And let me know if you need me to upload it).

Bryce Harrington (bryce) wrote :

There was a small typo in the Maintainer field address (which I've corrected), but otherwise looked ok so I'll uploaded.

Changed in xterm:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xterm - 229-1ubuntu1

---------------
xterm (229-1ubuntu1) hardy; urgency=low

  [ Stephan Hermann ]
  * debian/rules:
    - changed rm -f to rm -rf .pc patches, fixes a bug when .pc is a directory
  * Updated maintainer field

  [ Tormod Volden ]
  * debian/patches/950_ubuntu_charclass_highlight.diff:
    - enable URL highlighting (LP: #17601)

 -- Tormod Volden <email address hidden> Wed, 06 Feb 2008 20:11:29 +0100

Changed in xterm:
status: Fix Committed → Fix Released
George B (george-berger) wrote :

This "improvement" to the charclass definition is not better in my estimation. I just spent several hours figuring out how to get the default xterm behavior back. I find it's very easy to expand a selection after double-clicking -- simply right-click at the end of the desired area -- but trying to select a subset of a string is much more cumbersome.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.