Demote xterm to universe

Bug #1720482 reported by Jeremy Bicha on 2017-09-30
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tk8.6 (Ubuntu)
Undecided
Unassigned
xinit (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned
xterm (Ubuntu)
Undecided
Unassigned

Bug Description

Now that xterm is no longer included in the default Ubuntu install, we should be able to demote it to universe and let gnome-terminal fulfill the x-terminal-emulator virtual package dependency.

$ reverse-depends -c main xterm
Reverse-Recommends
==================
* tk8.6
* xinit

Reverse-Depends
===============
* xorg

tk8.6
Recommends: xterm | x-terminal-emulator

xinit
Recommends: xterm | x-session-manager | x-window-manager | x-terminal-emulator

xorg
Depends: xterm | x-terminal-emulator

gnome-terminal
Provides: x-terminal-emulator

Didier Roche (didrocks) wrote :

$ ./change-override -c universe -S xterm
Override component to universe
xterm 324-2ubuntu1 in artful: main/x11 -> universe
xterm 324-2ubuntu1 in artful amd64: main/x11/optional/100% -> universe
xterm 324-2ubuntu1 in artful arm64: main/x11/optional/100% -> universe
xterm 324-2ubuntu1 in artful armhf: main/x11/optional/100% -> universe
xterm 324-2ubuntu1 in artful i386: main/x11/optional/100% -> universe
xterm 324-2ubuntu1 in artful ppc64el: main/x11/optional/100% -> universe
xterm 324-2ubuntu1 in artful s390x: main/x11/optional/100% -> universe
Override [y|N]? y
7 publications overridden.

Changed in xterm (Ubuntu):
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

Laney pointed out that we should check that gnome-terminal doesn't get accidentally seeded somewhere.

$ seeded-in-ubuntu gnome-terminal
gnome-terminal (from gnome-terminal) is seeded in:
  ubuntu-gnome: daily-live
  ubuntu: daily-live
gnome-terminal-data (from gnome-terminal) is seeded in:
  ubuntu-gnome: daily-live
  ubuntu: daily-live

$ seeded-in-ubuntu xterm
xterm (from xterm) is seeded in:
  ubuntu-gnome: daily-live
  ubuntu-mate: daily-live
  ubuntukylin: daily-live
  ubuntustudio: dvd
  xubuntu: daily-live

We should run these commands tomorrow to make sure things look right.

Jeremy Bicha (jbicha) wrote :

xterm showed up on component-mismatches to promote it back to main because of the tk8.6 recommends (see original bug report). Maybe we should add gnome-terminal as an explicit alternate recommends? We might need to do that to xorg and xinit too.

Meanwhile, someone re-promoted xterm back to main.

Changed in xterm (Ubuntu):
status: Fix Released → New
Didier Roche (didrocks) wrote :

I don't think if you are going to repromote it that we want to do an universe -> main -> universe dance. Do you mind fixing adding the alternate rather?

Jeremy Bicha (jbicha) wrote :

I'm trying tk8.6 first and then we'll see what germinate comes up with once that's published.

http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/all

Changed in tk8.6 (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xterm (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tk8.6 - 8.6.7-1ubuntu1

---------------
tk8.6 (8.6.7-1ubuntu1) artful; urgency=medium

  * Add gnome-terminal as alternate Recommends (LP: #1720482)

 -- Jeremy Bicha <email address hidden> Wed, 04 Oct 2017 11:10:56 -0400

Changed in tk8.6 (Ubuntu):
status: In Progress → Fix Released
Timo Aaltonen (tjaalton) wrote :

so was the change to tk8.6 enough?

Jeremy Bicha (jbicha) on 2017-10-12
Changed in xorg (Ubuntu):
status: New → Fix Committed
Changed in xinit (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg - 1:7.7+19ubuntu3

---------------
xorg (1:7.7+19ubuntu3) artful; urgency=medium

  * Add alternate dependency on gnome-terminal (LP: #1720482)

 -- Jeremy Bicha <email address hidden> Thu, 12 Oct 2017 10:25:30 -0400

Changed in xorg (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-02-26
Changed in xterm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers