xterm terminfo file uses wrong mode by default

Bug #148866 reported by Alex Mauer on 2007-10-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ncurses (Ubuntu)
Undecided
Unassigned
xterm (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ncurses-base

To take an example, the default xterm terminfo data used by Ubuntu has kf13(shift+f1)=\EO2P, which corresponds to xterm with the resource modifyFunctionkeys=0 (terminfo definition xterm+pcf0 from the terminfo file provided with xterm).

 However, it would appear that xterm defaults to modifyFunctionkeys=2 (xterm+pcf2 from the terminfo provided with xterm). ( This can be seen by using cat to show that F13(shift+f1) produces ^[[1;2P).

Ubuntu should use the right terminfo data, at least for the default configuraiton.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 RC or later?

Changed in xterm:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xterm:
status: Incomplete → Invalid
Bryce Harrington (bryce) wrote :

Apologies; script misfired and accidentally closed this bug. Ignore the last response

Changed in xterm:
status: Invalid → Incomplete
Alex Mauer (hawke) wrote :

Yes, this is still a problem in Intrepid.

Bryce Harrington (bryce) on 2008-10-31
Changed in xterm:
importance: Undecided → Medium
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers