Please mark xterm as "Multi-arch: foreign"

Bug #1054344 reported by Mark Russell on 2012-09-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xterm (Ubuntu)
Undecided
Timo Aaltonen
Precise
Undecided
Unassigned
Quantal
Undecided
Timo Aaltonen

Bug Description

[Impact]
Marking xterm "Multi-arch: foreign" will allow 32-bit packages to depend on xterm and install successfully on 64-bit releases of Ubuntu from 11.04 onward.

Some 3rd party apps, such as Lotus Sametime, use xterm to display messages.

[Test Case]
Build and install i386 packages on amd64 and attempt to depend on xterm.

[Regression Potential]
Minimal as this packaging change only means that pulling in the 64-bit xterm can satisfy the dependency of a 32-bit application.

Can we make this change for precise?

Mark Russell (marrusl) on 2012-09-21
tags: added: precise quantal
Micah Gersten (micahg) on 2012-09-21
tags: added: multiarch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xterm (Ubuntu):
status: New → Confirmed
Mark Russell (marrusl) wrote :

debdiff for quantal.

Mark Russell (marrusl) wrote :

debdiff for precise

The attachment "xterm.quantal.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Timo Aaltonen (tjaalton) on 2012-09-28
Changed in xterm (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Confirmed → In Progress
Didier Roche (didrocks) wrote :

ok, sponsored into quantal (changing ubuntu1.1 to ubuntu2).

Please you should ask to nominate for release for getting it into precise and subscribe the SRU team. I've done it for you :) Thanks!

Didier Roche (didrocks) wrote :

also, you needed to change precise to precise-proposed in the changelog. Done!

Timo Aaltonen (tjaalton) wrote :

uploaded to both quantal and precise-proposed, thanks!

Changed in xterm (Ubuntu Precise):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xterm - 278-1ubuntu2

---------------
xterm (278-1ubuntu2) quantal; urgency=low

  * Mark xterm Multi-Arch: foreign (LP: #1054344)
 -- Mark Russell <email address hidden> Thu, 27 Sep 2012 17:45:12 -0400

Changed in xterm (Ubuntu Quantal):
status: In Progress → Fix Released
Mark Russell (marrusl) wrote :

Thanks @didrocks and @tjaalton for the tips!

Hello Mark, or anyone else affected,

Accepted xterm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xterm/271-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xterm (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Cláudio Carvalho (clavalho) wrote :

The package in precise-proposed works for me.
I built a i386 test package on amd64 and put it to depend on xterm. If I attempt to install the test package, so the xterm amd64 is installed. Thanks

Robert Hooker (sarvatt) on 2012-10-09
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xterm - 271-1ubuntu2.1

---------------
xterm (271-1ubuntu2.1) precise-proposed; urgency=low

  * control: Mark xterm Multi-Arch: foreign. (LP: #1054344)
 -- Mark Russell <email address hidden> Thu, 27 Sep 2012 17:26:18 -0400

Changed in xterm (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers