Ubuntu

[FTBFS] Source xsplash 0.8.5-0ubuntu2 in natty

Reported by Mahyuddin Susanto on 2011-01-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xsplash (Ubuntu)
Undecided
Andres Rodriguez

Bug Description

Binary package hint: xsplash

/usr/bin/ld: note: 'XCompositeReleaseOverlayWindow' is defined in DSO /usr/lib/libXcomposite.so.1 so try adding it to the linker command line
/usr/lib/libXcomposite.so.1: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[4]: *** [xsplash] Error 1
make[4]: Leaving directory `/build/user-xsplash_0.8.5-0ubuntu2-i386-Jvgeyt/xsplash-0.8.5/src'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/build/user-xsplash_0.8.5-0ubuntu2-i386-Jvgeyt/xsplash-0.8.5/src'
make[2]: *** [all-recursive] Error 1
make[1]: *** [all] Error 2
make[2]: Leaving directory `/build/user-xsplash_0.8.5-0ubuntu2-i386-Jvgeyt/xsplash-0.8.5'
make[1]: Leaving directory `/build/user-xsplash_0.8.5-0ubuntu2-i386-Jvgeyt/xsplash-0.8.5'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Related branches

Changed in xsplash (Ubuntu):
assignee: nobody → Mahyuddin Susanto (udienz)
status: New → In Progress
Mahyuddin Susanto (udienz) wrote :
Changed in xsplash (Ubuntu):
status: In Progress → New
assignee: Mahyuddin Susanto (udienz) → nobody
Bhavani Shankar (bhavi) wrote :

Hello Mahyuddin

I ll look at this one but I have a question did you test out the patch on a karmic system and/or did you confirm with the other reporters there if the patch works on karmic? Did you confirm just in case as to the same symptom does not exist on newer ubuntu versions posing a regression potential?

I ll process this one once above question is answered

regards

Bhavani Shankar (bhavi) on 2011-01-16
Changed in xsplash (Ubuntu):
status: New → Confirmed

Hello Bhavi

On 01/16/2011 02:21 PM, Bhavani Shankar wrote:
> Hello Mahyuddin
>
> I ll look at this one but I have a question did you test out the patch
> on a karmic system and/or did you confirm with the other reporters there
> if the patch works on karmic? Did you confirm just in case as to the
> same symptom does not exist on newer ubuntu versions posing a regression
> potential?

i will confirm with origin reporter at bug 458027. btw, we have two
choice, building without dual-screen patch or only fix ftbfs. what your
suggestion?
in my opinion, maybe we will wait ~one/two weeks to confirm dual-screen
patch works well

Bhavani Shankar (bhavi) wrote :

yes but if it has a regression then it will be fixed in natty but if the problem is fixed with newer versions we need to drop the patch I guess

Unsubscribing sponsors as I m going to take care of this

regards

tags: added: patch
Andres Rodriguez (andreserl) wrote :

Hi Mahyuddin,

Thank you for this bug fixing the FTBFS.Since it's been over 2 months of last comment from Bhavani, I'm gonna review the patch that fixes FTBFS and uploaded if everything looks good.

Cheers,

Changed in xsplash (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsplash - 0.8.5-0ubuntu3

---------------
xsplash (0.8.5-0ubuntu3) natty; urgency=low

  * debian/patches/fix_ftbfs_binutils_gold.patch: Fix FTBFS binutils-gold
    by adding Xcomposite library to src/Makefile.* (LP: #703477)
 -- Mahyuddin Susanto <email address hidden> Sun, 16 Jan 2011 13:22:39 +0700

Changed in xsplash (Ubuntu):
status: In Progress → Fix Released
Andres Rodriguez (andreserl) wrote :

Uploaded! Thank you for your contribution!

Changed in xsplash (Ubuntu):
status: Fix Released → Fix Committed
Changed in xsplash (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers