boot and gdm "wallpaper" is not dithered

Bug #441210 reported by Jaroslav Šmíd on 2009-10-03
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xsplash
Low
Cody Russell
Baltix
Undecided
Unassigned
gdm (Ubuntu)
Low
Unassigned
Karmic
Low
Unassigned
xsplash (Ubuntu)
Low
Ken VanDine
Karmic
Low
Ken VanDine

Bug Description

"wallpaper" in xsplash and gdm is too "low color". Those gradients have too visible steps - not only on my laptop with TN display, but on my S-PVA monitor as well. It doesn't look too nice ... I would even dare to say it looks ugly. I hope it is not final version for karmic.

affects: ubuntu → xsplash (Ubuntu)
Daniel Lee (longinus00) wrote :

There are two possible reasons for this. The first is that you're running at 16bpp and have hit this bug 423632, another is that you're using cheap LCD's which only support 18bit color http://en.wikipedia.org/wiki/Color_depth#LCD_displays .

The bug is not a gdm one it's just using the image shipped with xsplash

summary: - [karmic] boot and gdm "wallpaper" is too low color
+ boot and gdm "wallpaper" is too low color
Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid

If you read my bug report once again, you will see, that my second display is S-PVA - it is definitely not cheap and uses 10bits per color channel (total 30bit) internaly. On that panel overything is seen as it is. Even on that cheap TN panel in laptop it is visible.

Display is not set to 16bpp. Please unmark the duplicate.

Mat Tomaszewski (mat.t.) wrote :

@ Jaroslav

Could you please take a photo of a problem and attach it to the bug report?

Thanks!

I only have low-res webcam so no, I can't take a photo. But you can see by yourself, just log yourself off and see that background image. I can only mark the "steps" in gimp so you can ask more people if they see the same thing as me.

When I uploaded the wallpaper at abclinuxu.cz (http://www.abclinuxu.cz/desktopy/jardik-20091008) (czech language, sorry), most users confirmed that the "steps" are really there (even one with CRT display). Only two of them seem to be blind as they don't see it (I would say they are lying because they do not like me). Some of them told me that I'm idi*t reporting bug like this, but it is important that new user doesn't spot such an ugly-rendered wallpaper - it would make him think that ubuntu is not worth trying anymore, make him think that when the wallpaper is ugly, the system itself will be like incomplete puzzle.

Unmarked duplicate

Cody Russell (bratsche) wrote :

Okay, if that image you linked to is a screenshot of the problem you're having then I agree that it's not a duplicate to bug #423632. Instead I'm simply marking as Invalid because I don't see a problem with the image you linked to.

Changed in xsplash (Ubuntu):
status: New → Invalid
Changed in xsplash (Ubuntu):
status: Invalid → Confirmed
Mat Tomaszewski (mat.t.) wrote :

I can see the issue with the image you uploaded, but I don't think this is the original asset. Have you re-saved the image? Attached is the original for you to compare.

Mat Tomaszewski (mat.t.) wrote :

Until we answer the above, the bug remains valid.

Changed in xsplash (Ubuntu):
assignee: nobody → Mat Tomaszewski (mat.t.)

God, you're kidding right? If you don't see the problem, it doesn't mean it is not there. Why are you so stubborn. I'm just trying to help to enhance user experience with ubuntu. Just ask someone else. Today I looked at that image on my old 15" CRT I had in my "old-stuff room" and it looks the same way as on my S-PVA monitor - it has clearly visible steps in the gradients. Note that they are not much visible with low brightness set. I will enlarge the image and you really must see it then or you should really see a doctor to look at your eyes.

Mat Tomaszewski: My comment above was to Cody Russell, your comment was not there when I started to write it.

> but I don't think this is the original asset

It is. I've extracted it directly from ubuntu-xsplash-artwork_0.8.2-0ubuntu2_amd64.deb/data.tar.gz/usr/share/images/xsplash in Windows (I didn't want to boot ubuntu to find it). It is not re-saved. The two images seem to be the same.

Jaroslav Šmíd wrote:
> Mat Tomaszewski: My comment above was to Cody Russell, your comment was
> not there when I started to write it.
>
>
>> but I don't think this is the original asset
>>
>
> It is. I've extracted it directly from ubuntu-xsplash-
> artwork_0.8.2-0ubuntu2_amd64.deb/data.tar.gz/usr/share/images/xsplash in
> Windows (I didn't want to boot ubuntu to find it). It is not re-saved.
> The two images seem to be the same.
>
>
Yes I see the problem now. Please remember that the quality of rendering
is app-dependent, some apps deal better with dithering fine gradients
than others. We may not be able to solve that in xsplash, but it is
still a problem and I'll keep trying to resolve it.

I would say that JPEG compression has partly an impact on the image quality as well. Maybe if there were PNG file instead of JPG, it would be (at least a bit) better...
Another problem is that GDM uses the same image as xsplash and suffers from this as well. I think that "fixing" xsplash itself is not a solution, that image re-rendering would be better choice. Are there any "sources" available (svg, xcf or sth like that)?

Cody Russell (bratsche) wrote :

Mat, after doing some profiling this week I learned that loading both pixbuf loaders is taking about 1/5 second longer than necessary (on David's really terrible netbook though, which means way less on real hardware) when xsplash first loads, so I was thinking to ask you if you could convert the bg images to PNG if it doesn't have a negative impact on the quality of the images.

godhika (godhika) wrote :

I must say it looks for me also like in the link posted above. And this are some really ugly gradients.

Mat Tomaszewski (mat.t.) on 2009-10-18
summary: - boot and gdm "wallpaper" is too low color
+ boot and gdm "wallpaper" is not dithered
Mat Tomaszewski (mat.t.) wrote :

There are two issues, both are not related to color depth. One problem is that the image does not use dithering, second is the jpeg compression. Xsplash renderer seems not to deal with either very well. To resolve this problem, two things can be done: image should have dithered colors and the compression should be lower (ideally none). The latter isn't really possible, due to the limited space on a CD (non-compressed png is about 2.5MB). Attached is the new version, with slightly lower compression and dithering. Please test and report the results!

Cheers,

Mat

Changed in xsplash (Ubuntu):
status: Confirmed → In Progress
assignee: Mat Tomaszewski (mat.t.) → Cody Russell (bratsche)
Martin Pitt (pitti) on 2009-10-20
Changed in gdm (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody

Mat Tomaszewski:
Looks much better then previous one, but it is still not perfect :-) But I understand that space on CD is limited. Could you upload png file somewhere so that I can use it instead of default one? :-)

Cody Russell (bratsche) on 2009-10-22
Changed in xsplash:
assignee: nobody → Cody Russell (bratsche)
status: New → In Progress
status: In Progress → Fix Committed
Changed in xsplash (Ubuntu):
status: In Progress → Fix Committed
Ken VanDine (ken-vandine) wrote :
Changed in xsplash (Ubuntu):
status: Fix Committed → New
assignee: Cody Russell (bratsche) → Ken VanDine (ken-vandine)
Changed in xsplash (Ubuntu):
milestone: none → ubuntu-9.10
Martin Pitt (pitti) on 2009-10-26
Changed in xsplash (Ubuntu Karmic):
milestone: ubuntu-9.10 → none
importance: Undecided → Low
status: New → Fix Committed
Ken VanDine (ken-vandine) wrote :

This change seems very unlikely to cause a regression, and it does make the boot experience look much better for more users. The change consists of switching from multiple compressed images (one per resolution) to a single uncompressed image. The end result is actually a 75K savings in package size.

stealthbanana (stealth-banana) wrote :

I too have the jaggies on the xsplash background on my main desktop, perfect on all other computers. Looking at the contents of 'ubuntu-xsplash-artwork' I see the various screensizes, however not the native resolution of the size on the monitor, 1920*1080, therefore I assume that the default (800*600?) is being upscaled and causing the ugliness.

Vish (vish) wrote :

@stealthbanana :
No , scalling is not done. In you case the1920×1200 image will be used and centered.
https://wiki.ubuntu.com/DesktopExperienceTeam/KarmicBootExperienceDesignSpec#Layout%20Rules

In my case the image banding is seen even when i view the images using EOG , but the latest image uploaded in comment 18 shows no banding.

@Ken VanDine :
Maybe the wiki needs to be updated too , regarding the image size change.

Martin Pitt (pitti) wrote :

This is really borderline, but I know that we traditionally made some concessions for "polishing" SRUs right after release.

Will accept after karmic is released.

Martin Pitt (pitti) wrote :

Accepted xsplash into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Mat Tomaszewski (mat.t.) wrote :

Tested on a Dell netbook (1024x600) and a Macbook Pro (1920x1200). Seems to work very well on both, some minor jpeg compression artifacts are still visible, but to much lesser extent than previously. Overall, the background is much smoother.

Would be good if someone could also test it at 16bpp and compare with the previous version.

Vish (vish) wrote :

Matt , The update solves the issue in my system[Acer laptop]. None of the banding problems i was mentioning earlier.

For 16bpp , maybe users from Bug #423632 could be asked to test it out.

Martin Pitt (pitti) wrote :

I have used the new version for a while, and it looks fine on 1280x1024.

stealthbanana (stealth-banana) wrote :

Much, much better than before, Only banding noticeable is when you actively look for it, and then only on larger resolution screens, looks perfect on a netbook and laptop (800x600 & 1280 x 800). Opened up the image in a viewer, and it is the same when magnified, so unavoidable unless the base image is of a stupidly huge size. Perhaps a separate package for hires version for those that do not mind an extra few milisecond boot up times?

I still easily see banding, especially on left/ride sides in the middle. It can be even more visible if you bump digital vibrance (for example in nvidia-settings),but I see it without vibrance. I have to zoom out the picture to ~20% of original size to make it unnoticeable. My monitor is Samsung 2443BW 1920x1200. My friend says that he also clearly see it on 22'' 1680x1050, but this image look good on some cheap 19'' 1280x1024 office monitor. That says this bug don't bother me much, because I made my xsplash background completely black and I like it better(it fits to usplash, break between usplash and xsplash, and to desktop loading where there is black background before the wallpaper and icons loads up)

Martin Pitt (pitti) on 2009-11-02
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsplash - 0.8.5-0ubuntu1

---------------
xsplash (0.8.5-0ubuntu1) karmic-proposed; urgency=low

  * New upstream version
    - boot and gdm "wallpaper" is not dithered (LP: #441210)

 -- Ken VanDine <email address hidden> Tue, 27 Oct 2009 20:52:12 +0100

Changed in xsplash (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied karmic-proposed to lucid.

Changed in xsplash (Ubuntu):
status: Fix Committed → Fix Released
Changed in xsplash (Ubuntu Karmic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsplash - 0.8.5-0ubuntu1

---------------
xsplash (0.8.5-0ubuntu1) karmic-proposed; urgency=low

  * New upstream version
    - boot and gdm "wallpaper" is not dithered (LP: #441210)

 -- Ken VanDine <email address hidden> Tue, 27 Oct 2009 20:52:12 +0100

Changed in xsplash (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in xsplash:
importance: Undecided → Low
Cody Russell (bratsche) on 2010-03-10
Changed in xsplash:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers