bottom gnome-panel bar sometime on top of xsplash

Bug #427511 reported by Sebastien Bacher on 2009-09-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xsplash
Medium
Cody Russell
xsplash (Ubuntu)
Medium
Cody Russell

Bug Description

Binary package hint: xsplash

Using xsplash 0.7 on karmic and compiz on intel and a stock session (the gdm guest session option) often the gnome-panel bottom bar is displayed on top of the xsplash screen

Nicolò Chieffo (yelo3) wrote :

This happens to me with the top panel bar, instead of the bottom one, which is correctly hidden.

Changed in xsplash (Ubuntu):
status: New → Confirmed
Changed in xsplash:
status: New → Confirmed
Changed in xsplash:
milestone: none → ubuntu-9.10-beta-freeze
importance: Undecided → Medium
Nicolò Chieffo (yelo3) wrote :

Today I also got a notify-osd popped over xsplash

Cody Russell (bratsche) on 2009-09-14
Changed in xsplash:
assignee: nobody → Cody Russell (bratsche)
Changed in xsplash (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Medium
Cody Russell (bratsche) on 2009-09-14
Changed in xsplash:
status: Confirmed → In Progress

I've also noticed that if I click on the panel, it immediately goes
behind xsplash.
I hope this information helps you in fixing this bug

Cody Russell (bratsche) on 2009-09-17
Changed in xsplash:
status: In Progress → Confirmed
Cody Russell (bratsche) on 2009-09-17
Changed in xsplash:
status: Confirmed → In Progress
Cody Russell (bratsche) wrote :

Thank you Nicolò. I've got a branch ready that appears to fix the problem, but I'm afraid it wasn't done in time for tomorrow's release. It should be available in next week's release though.

Cody Russell (bratsche) on 2009-09-17
Changed in xsplash:
status: In Progress → Fix Committed
Cody Russell (bratsche) wrote :

I think I was wrong. Looks like we will get this into the release later today, thanks to our resident superhero Ken van Dine!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsplash - 0.8.1-0ubuntu1

---------------
xsplash (0.8.1-0ubuntu1) karmic; urgency=low

  * New upstream version (LP: #430881)
    - add timeout cmd line option
    - fix xsplash_add_signal() so it can parse --add-signal multiple times
    - add --daemon option (LP: #429602)
    - Updated artwork
    - fixed bug where gnome-panel would sometimes appear on top of
      xsplash (LP: #427511)
  * debian/control:
    - split artwork out into ubuntu-xsplash-artwork (LP: #430162)
    - Added Provides/Conflicts/Replaces for xsplash-artwork
    - Made xsplash depend on xsplash-artwork or ubuntu-xsplash-artwork
    - Made ubuntu-xsplash-artwork Conflict/Replaces xsplash (<< 0.8)
  * debian/ubuntu-xsplash-artwork.copyright:
    - Update to CC-BY-SA 3.0 as per Canonical Ltd.'s (the copyright holder)
      decision. Add some explanatory text about the trademark policy.

 -- Ken VanDine <email address hidden> Wed, 16 Sep 2009 11:08:03 -0400

Changed in xsplash (Ubuntu):
status: Confirmed → Fix Released
Nicolò Chieffo (yelo3) wrote :

This issue is still present randomly in 0.8.1-0ubuntu1

tags: added: ubuntu-boot
David Barth (dbarth) on 2009-09-25
Changed in xsplash:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers