New splash looks wrong on dual-screen setup

Bug #420225 reported by Alan Pope 🍺🐧🐱 🦄 on 2009-08-27
78
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xsplash
Medium
Cody Russell
xsplash (Ubuntu)
Medium
Cody Russell
Karmic
Medium
Cody Russell

Bug Description

Binary package hint: xsplash

I hope this is the right package, sorry.

I have a desktop with an nvidia card in "twinview" mode on two screens. Pretty standard fare I'd guess. When xsplash runs it fills over both screens, so the logo and the throbber and cut in half - its easier to see if you look at the photo attached.

Pre-gdm I get xsplash over both screens
GDM presents the greeter/login thing on one screen only (primary display - the one the panels subsequently appear on)
Post-logon, pre-desktop, xsplash comes back spread across both screens.

This looks sub-optimal, and would be a regression given the old usplash (or whatever we used in 9.04) would show a throbber on both screens (one on each).

ProblemType: Bug
Architecture: amd64
Date: Fri Aug 28 00:30:00 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: xsplash 0.6-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-7.27-generic
SourcePackage: xsplash
Uname: Linux 2.6.31-7-generic x86_64

Related branches

Martin Meredith (mez) wrote :

I'll have a look at work on Tuesday and try and confirm this. Please poke me to remind me though!

Bob Hazard (junkbit) on 2009-08-28
Changed in xsplash (Ubuntu):
status: New → Confirmed
Cody Russell (bratsche) wrote :

I have two monitors and an nvidia card. I'll test this out as soon as I have time to setup the TwinView fu again.

Changed in xsplash (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Low
Cody Russell (bratsche) on 2009-08-31
Changed in xsplash:
importance: Undecided → Low
assignee: nobody → Cody Russell (bratsche)
Ruben Verweij (ruben-verweij) wrote :

I am also having this problem with a TwinView setup.
Only there seems to be more to it: there isn't really a throbber on my screen, it is just a static image of a throbber moving upward and then starting down again. If anyone could tell me how to make a screenshot of xsplash (if possible) I will most happily attach it.

Martin Meredith (mez) on 2009-09-02
Changed in xsplash (Ubuntu):
milestone: none → ubuntu-9.10
importance: Low → Medium
Ruben Verweij (ruben-verweij) wrote :

I've noticed with the new update it is positioned slightly higher than before, otherwise everything is still the same.

Matt Wheeler (funkyhat) wrote :

This bug appears to be caused by #234082

Matt Wheeler (funkyhat) wrote :

Or perhaps #300870
I didn't think to check the status of the bug (or the project it was reported against). This one looks a little better, though still not really a complete bug...

Michael B. Trausch (mtrausch) wrote :

Took this with my cell phone to show the problem.

From a user experience standpoint, having xsplash and GDM be aware that there are two screens is a good thing, in my opinion. The actual issue is that the important information of the screen ( the throbber) is being cut is two. A much better proposal would be to have the throbber centered on one screen, while having the image behind the throbber covering both screens.

Just my two cents.

Ruben Verweij (ruben-verweij) wrote :

I agree with you, only I think it would look strange if the ubuntu logo is cut in two and the throbber isn't.
There are two more options I think we have: only show xsplash on one screen or mirror it on both screens.
I have attached an image of how it looks now on 2560x1024 Twinview. (can't see no throbber at all ;)

On Mon, 2009-09-21 at 16:01 +0000, Ruben Verweij wrote:
> There are two more options I think we have: only show xsplash on one
> screen or mirror it on both screens.

Absolutely.

 --- Mike

--
Blog: http://mike.trausch.us/blog/
Misc. Software: http://mike.trausch.us/software/

“The greater danger for most of us lies not in setting our aim too
high and falling short; but in setting our aim too low, and achieving
our mark.” —Michelangelo

@Ruben - Sorry about that... I was considering the logo to be part of the throbber. I agree, the logo shouldn't be split.

With regards to the other two options, they are certainly a way to get things done, but would be sub-optimal from a user experience perspective(IMHO).

Cody Russell (bratsche) wrote :

I think what we'll probably do is to put xsplash on the primary display only, and have the second one be black.

Mat Tomaszewski (mat.t.) wrote :

Proposed solution: Xsplash should be displayed on primary screen only. The other display should be filled with black until the user's session is ready.

Ruben Verweij (ruben-verweij) wrote :

I agree. This way the logo and throbber would be visible and no
additional dual-screen artwork has to be created.

Daniel Lee (longinus00) wrote :

Can it play on both screens? Sometimes it's not exactly obvious which monitor is "primary" or not to the user. gnome-display-properties doesn't even number the screens so the only way you'd know is if you ran xrandr from the terminal.

Cody Russell (bratsche) on 2009-09-29
Changed in xsplash:
importance: Low → Medium
milestone: none → ubuntu-9.10
status: New → In Progress
Cody Russell (bratsche) wrote :

This is partially fixed in trunk now. It should display xsplash on monitor #0 only.

Before I close this I need to find out if that's always the primary monitor, or if it's not then how to determine what the primary monitor is.

Daniel Lee (longinus00) wrote :

Do you mean like this?

$ xrandr
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 1600 x 1600
DVI-1 connected 1600x1200+0+0 (normal left inverted right x axis y axis) 408mm x 306mm
   1600x1200 60.0*+
   1280x1024 75.0 60.0
   1280x960 60.0
   1152x864 75.0
   1024x768 75.0 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 75.0 72.8 66.7 59.9
   720x400 70.1
DVI-0 disconnected (normal left inverted right x axis y axis)

@Cody, that's not going to fix this bug. With nVidia in twinview you have one big screen so only one screen 0, no screen 1 at all. As a result when you restrict xsplash to screen 0, you get it spanning over both screens. So for me nothing looks to have changed at all.

Screen 0: minimum 3360 x 1050, current 3360 x 1050, maximum 3360 x 1050
default connected 3360x1050+0+0 0mm x 0mm
   3360x1050 50.0* 51.0

This is two ViewSonic 1680x1050 screens hanging off one nVidia 7900GT card. xorg.conf attached.

I don't know how gnome-panel determines how many physical screens there are, but it might be worth a look at the code because my gnome-panels only occupy one of the two screens, along the top and bottom. They don't span both displays as xsplash does.

Cody Russell (bratsche) on 2009-09-30
Changed in xsplash:
status: In Progress → Fix Committed
Cody Russell (bratsche) wrote :

I tested on an nvidia with TwinView enabled, 3200x1600, and it seemed to look fine. I switched from using gdk_screen_get_width() to gdk_screen_get_monitor_geometry(). This seemed to work for me.

Cody Russell (bratsche) on 2009-10-02
Changed in xsplash:
status: Fix Committed → Fix Released
Changed in xsplash (Ubuntu Karmic):
status: Confirmed → Fix Released
rbott (rb-megabit) wrote :

Hey folks,

for me the problem still exists. I'm using TwinView with two differently sized screens (1280x1024 and 1920x1200). The widescreen is my main screen and the basic Ubuntu loading-splash is only displayed on this one.
However, xsplash seems to be confused by the setup. The size of the animation-window seems to be 1920x1200 but it gets displayed partially on the smaller screen (1280x1024), which is left of the widescreen. Im not able to provide a picture right now but I might add this later on. The remaining part of the animation-window is displayed on the widescreen while the remaing part of the widescreen shows the standard background gradient.

My system is a ThinkPad T61 with a docking station:
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 140M (rev a1)

rbott (rb-megabit) wrote :

OK additionally heres the relevant part from my xorg.conf (written by nvidia-settings):

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "DFP-1"
    Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP-1: 1920x1200 +1280+0"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

SabreWolfy (sabrewolfy) wrote :

Confirmed as regression on upgrade from Jaunty to Karmic with NVidia Twinview. Jaunty showed the splash/throbber/login on primary display only. Karmic shows login on primary display, but splash/throbber (before and after login) appears split arbitrarily over both displays.

SabreWolfy (sabrewolfy) wrote :

PS: Also using two differently (but closely) sized screens: 1680 x 1050 and 1920 x 1080 (primary) attached by DVI. Using NVidia driver 185.18.36.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers