asp.net with apache does not seem to work on trusty

Bug #1292567 reported by Peder Chr. Nørgaard on 2014-03-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xsp (Ubuntu)
Undecided
Unassigned

Bug Description

I have filed this bug against asp.net-examples, but I don't really think, that this specific package is in error - it is just a good example of a generic error that has stopped me cold in testing my company's ASP.NET application on the Beta 1 of "trusty tahr".

Of course I cannot upload our entire application in a bug report, so I was kind of relieved to observe, that the problem could be reproduced by means of asp.net-examples.

When I install asp.net-examples on "saucy salamander", it presents a nice, simple web page demonstrating certain ASP.NET mechanisms.

When I do the same thing on a pristine installation of "trusty tahr", I get this exception:

System.Web.Compilation.CompilationException
: Unhandled Exception:

Description: Error compiling a resource required to service this request. Review your source file and modify it to fix this error.
Details: : Unhandled Exception:
Error origin: Compiler
Error source file:
Exception stack trace:
  at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath, System.CodeDom.Compiler.CompilerParameters options) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.CodeDom.Compiler.CompilerParameters options) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.AppCodeAssembly.Build (System.String[] binAssemblies) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.AppCodeCompiler.Compile () [0x00000] in <filename unknown>:0
  at System.Web.HttpApplicationFactory.InitType (System.Web.HttpContext context) [0x00000] in <filename unknown>:0

I have the same bug on my company's larger ASP.NET application, and I have reproduced the bug both on a server version of trusty, and a kubuntu trusty desktop - exactly the same performance.

It is pretty obvious to me that the bug is not in asp.net-examples; most likely it is related to the fact that the basic mono distribution takes a great version hop between saucy and trusty - from 2.10.8.1 to 3.2.8. Some feature is simply not working! To be absolutely certain I rebuilt a fresh version of the xsp source package (source package for asp.net-examples) and installed that instead of the official trusty version - made no difference, the bug is still there.

The asp.net-examples package is using mono-apache-server2, by ways of its post-installation script. I have of course also tried mono-apache-server4, but that fails in an entirely different way that will be reported in a separate launchpad bug.

This report is not made from the "trusty" installation, that one is a test installation without access to the net, so you don't get all the stuff that apport would collect to you. Honestly, you don't need it to reproduce, just grab a pristine trusty installation and try it!

However, a few important package versions:

libapache2-mod-mono: 2.11+git20130708.6b73e85-4ubuntu1
mono-complete: 3.2.8+dfsg-4ubuntu1
mono-apache-server2: 3.0.11-1

I am willing to offer any possible kind of assistance in fixing this problem - my company had looked forward to upgrade to "trusty". But, to be honest, I don't think you really need my help - the problem is so trivial to reproduce, it ought to be pretty trivial to fix if you know the ropes.

best regards

Peder Chr. Nørgaard

tags: added: xsp
Peder Chr. Nørgaard (pcn-2) wrote :

I have now added a bug on how there is a just as critical bug when one is using ASP.NET 4.0. I have reported two bugs because the behaviour of the two bugs is quite different. The other bug is here: https://bugs.launchpad.net/ubuntu/+source/xsp/+bug/1293481

best regards
Peder Chr. Nørgaard

shahid khan (shahid-mrd) wrote :
Download full text (4.6 KiB)

@Peder chr.Norgaard

I ran your application from bug #1293481 page, Although i have fixed the bug #1293481 in my installation, it gave me the following exception

System.Web.Compilation.ParseException
The file '~/controls/MonoSamplesHeader.ascx' does not exist

Description: Error parsing a resource required to service this request. Review your source file and modify it to fix this error.
Details: The file '~/controls/MonoSamplesHeader.ascx' does not exist
Error origin: Parser
Error source file: /var/www/html/app/index.aspx
Exception stack trace:

at System.Web.UI.BaseParser.ThrowParseException (System.String message, System.Object[] parms) [0x00000] in <filename unknown>:0
  at System.Web.UI.BaseParser.ThrowParseFileNotFound (System.String path, System.Object[] parms) [0x00000] in <filename unknown>:0
  at System.Web.UI.TemplateParser.RegisterCustomControl (System.String tagPrefix, System.String tagName, System.String src) [0x00000] in <filename unknown>:0
  at System.Web.UI.TemplateControlParser.AddDirective (System.String directive, IDictionary atts) [0x00000] in <filename unknown>:0
  at System.Web.UI.PageParser.AddDirective (System.String directive, IDictionary atts) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.AspGenerator.TagParsed (ILocation location, TagType tagtype, System.String tagid, System.Web.Compilation.TagAttributes attributes) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.AspParser.OnTagParsed (TagType tagtype, System.String id, System.Web.Compilation.TagAttributes attributes) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.AspParser.Parse () [0x00000] in <filename unknown>:0
  at System.Web.Compilation.AspGenerator.Parse (System.IO.TextReader reader, System.String filename, Boolean doInitParser) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.GenericBuildProvider`1[System.Web.UI.TemplateParser].Parse () [0x00000] in <filename unknown>:0
  at System.Web.Compilation.GenericBuildProvider`1[System.Web.UI.TemplateParser].get_LanguageName () [0x00000] in <filename unknown>:0
  at System.Web.Compilation.TemplateBuildProvider.get_LanguageName () [0x00000] in <filename unknown>:0
  at System.Web.Compilation.GenericBuildProvider`1[System.Web.UI.TemplateParser].get_CodeCompilerType () [0x00000] in <filename unknown>:0
  at System.Web.Compilation.BuildManagerDirectoryBuilder.GetBuildProviderCodeDomType (System.Web.Compilation.BuildProvider bp) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.BuildManagerDirectoryBuilder.AssignToGroup (System.Web.Compilation.BuildProvider buildProvider, System.Collections.Generic.List`1 groups) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.BuildManagerDirectoryBuilder.Build (Boolean single) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.BuildManager.BuildInner (System.Web.VirtualPath vp, Boolean debug) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.BuildManager.Build (System.Web.VirtualPath vp) [0x00000] in <filename unknown>:0
  at System.Web.Compilation.BuildManager.GetCompiledType (System.Web.VirtualPath virtualPath) [0x00000] in <filename unknown>:0
  at System.W...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xsp (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers