mono-server-update ignores vhost when creating host conf file

Bug #1137992 reported by Kyle Strickland
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xsp (Ubuntu)
Undecided
Unassigned

Bug Description

Application line should be formatted as "[[hostname:]port:]VPath:realpath" according to ApplicationServer.cs, but the mono-server-update scripts ignore the hostname and port sections, creating a conflict when you try to configure two virtual hosts with the same vpath.

Attached is a patch to include the vhost and port in the application line when generating the host conf file.

Revision history for this message
Kyle Strickland (jkstrick) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Patch fixing missing vhost in generated host conf file." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers