xsm dependencies will remove most of gnome

Bug #22626 reported by Thomas Templin on 2005-09-27
10
Affects Status Importance Assigned to Milestone
xsm (Ubuntu)
Medium
Unassigned

Bug Description

Distribution: Breezy
Package: xbase-clients
Version: 6.8.2-53 and up
depends on
Package: xsm

sudo apt-get -s install xsm
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
  fast-user-switch-applet flashplayer-mozilla gcm
  gnome-applets gnome-applets-data gnome-control-center
  gnome-core gnome-network gnome-office gnome-panel
  gnome-session gnome-swallow-applet gnome-terminal
  gnome-velocity gtk-engines-gtkstep libgcm0 medusa
  nautilus xfdeskmenu4 xlibs xmovie

The following NEW packages will be installed:
  xsm
0 upgraded, 1 newly installed, 22 to remove and 4 not upgraded.
Remv fast-user-switch-applet [0.2.4-0ubuntu2]
Remv flashplayer-mozilla [7.0.25-woody0.0]
Remv gcm [2.1.0+20031016.1-4]
Remv gnome-office [1:2.10.1.1ubuntu1]
Remv gnome-core [1:2.10.1.1ubuntu1]
Remv gnome-applets [2.12.0-0ubuntu1] [gnome-applets-data ]
Remv gnome-applets-data [2.12.0-0ubuntu1]
Remv nautilus [2.12.0-0ubuntu2]
Remv gnome-terminal [2.12.0-0ubuntu2]
Remv gnome-session [2.12.0-0ubuntu1]
Remv gnome-swallow-applet [1.2-1.1]
Remv gnome-panel [2.12.0-0ubuntu3]
Remv gnome-control-center [1:2.12.0-0ubuntu5]
Remv gnome-network [1.99.5-2]
Remv gnome-velocity [0.1.0beta-1]
Remv gtk-engines-gtkstep [2.2-1.1]
Remv libgcm0 [2.1.0+20031016.1-4]
Remv medusa [0.5.1-4]
Remv xfdeskmenu4 [4.0.0+cvs.20021222-2]
Remv xmovie [1.9-3]
Remv xlibs [6.8.2.dfsg.1-1]
Inst xsm (0.99.0-1 Ubuntu:5.10/breezy)
Conf xsm (0.99.0-1 Ubuntu:5.10/breezy)

Matt Zimmerman (mdz) wrote :

That's odd. I have xsm installed here as part of the standard desktop install,
which includes GNOME.

Show us your /etc/apt/sources.list

Thomas Templin (coastgnu) wrote :

---8<--- /etc/apt/sources.list ---8<---
deb ftp://ftp.nerim.net/debian-marillat/ sarge main
deb ftp://ftp.nerim.net/debian-marillat/ etch main
deb ftp://ftp.nerim.net/debian-marillat/ sid main #Marillat
deb ftp://bolugftp.uni-bonn.de/pub/kde/unstable/3.5-beta1/kubuntu breezy main
deb ftp://archive.ubuntu.com/ubuntu/ hoary main restricted universe multiverse
deb ftp://archive.ubuntu.com/ubuntu/ hoary-updates main restricted universe
multiverse
deb ftp://security.ubuntu.com/ubuntu/ hoary-security main restricted universe
multiverse
deb ftp://archive.ubuntu.com/ubuntu/ breezy main restricted universe multiverse
deb http://debian.scribus.net/debian/ breezy main restricted
---8<--- /etc/apt/sources.list ---8<---

apt-cache show xsm
Package: xsm
Priority: optional
Section: x11
Installed-Size: 160
Maintainer: Fabio M. Di Nitto <email address hidden>
Architecture: i386
Version: 0.99.0-1
Replaces: xbase-clients (<< 6.8.2-38)
Depends: libc6 (>= 2.3.4-1), libice6, libsm6, libx11-6, libxaw7, libxext6,
libxmu6, libxpm4, libxt6
Filename: pool/main/x/xsm/xsm_0.99.0-1_i386.deb
Size: 39966
MD5sum: f4b3301c7dc0f6d6a4614d62cfd7ea31
Description: X client - xsm
 xsm is a small tool that was part of xbase-clients.
 .
 More information about X.Org can be found at:
 <URL:http://xorg.freedesktop.org>
 <URL:http://lists.freedesktop.org/mailman/listinfo/xorg>
 .
 This module can be found as the module 'app/xsm' at
 :pserver:<email address hidden>:/cvs/xorg
Bugs: mailto:<email address hidden>
Origin: Ubuntu
Task: edubuntu-desktop

Matt Zimmerman (mdz) wrote :

You're mixing hoary and breezy packages; choose one and stay with it and this
shouldn't be a problem.

Thomas Templin (coastgnu) wrote :

Removing Hoary don't change anything...

deb ftp://ftp.nerim.net/debian-marillat/ sarge main
deb ftp://ftp.nerim.net/debian-marillat/ etch main
deb ftp://ftp.nerim.net/debian-marillat/ sid main #Marillat
deb ftp://bolugftp.uni-bonn.de/pub/kde/unstable/3.5-beta1/kubuntu breezy main #
kde-3.5beta1
deb ftp://archive.ubuntu.com/ubuntu/ breezy main restricted universe multiverse
deb http://debian.scribus.net/debian/ breezy main restricted #Scribus Ubuntu Breezy

apt-get -s installl xsm
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
  fast-user-switch-applet flashplayer-mozilla gcm
  gnome-applets gnome-applets-data gnome-control-center
  gnome-core gnome-network gnome-office gnome-panel
  gnome-session gnome-swallow-applet gnome-terminal
  gnome-velocity gtk-engines-gtkstep libgcm0 medusa
  nautilus xfdeskmenu4 xlibs xmovie
The following NEW packages will be installed:
  xsm

Thomas Templin (coastgnu) wrote :

SOLVED

There was an old xlib which was responsible for this odd problem

---8<---
dpkg - Warnung: deaktualisiere xlibs von 6.8.2.dfsg.1-1 zu 6.8.2-69
---8<---

After installing xlib 6.8.2-69 xsm I was able to install xsm

Matt Zimmerman (mdz) wrote :

It doesn't happen with Hoary, and it doesn't happen with Breezy. You've
installed packages from other sources and otherwise diverged from the supported
system; unless you can demonstrate the problem using a supported configuration I
can't consider it a bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.