X server crashes on resolution change

Bug #91591 reported by David Balažic on 2007-03-12
2
Affects Status Importance Assigned to Milestone
xserver-xorg-video-vesa (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

(as suggested in bug 90175 comment 6, I report this issue as a new bug)

I tried to change screen from 1280x1024 to 1024x768 (with VESA driver) and got an X crash, see the log.

[backtrace](II) VESA(0): VBESetVBEMode failed...Tried again without customized values.

Backtrace:
0: /usr/X11R6/bin/X(xf86SigHandler+0x81) [0x80c5d81]
1: [0xb7f85420]
2: /usr/lib/xorg/modules//libfb.so(fbCopyNtoN+0x19f) [0xb7b0cd8f]
3: /usr/lib/xorg/modules//libfb.so(fbCopyRegion+0x95) [0xb7b0bd25]
4: /usr/lib/xorg/modules//libfb.so(fbDoCopy+0x46f) [0xb7b0c34f]
5: /usr/lib/xorg/modules//libfb.so(fbCopyArea+0x78) [0xb7b0c518]
6: /usr/X11R6/bin/X [0x81620c9]
7: /usr/X11R6/bin/X [0x815e155]
8: /usr/X11R6/bin/X [0x8110014]
9: /usr/X11R6/bin/X [0x81217a1]
10: /usr/X11R6/bin/X [0x815befb]
11: /usr/X11R6/bin/X [0x815c2f5]
12: /usr/X11R6/bin/X(compPaintWindowBackground+0x6d) [0x80f60fd]
13: /usr/X11R6/bin/X(miWindowExposures+0xfa) [0x8111ada]
14: /usr/X11R6/bin/X(miHandleValidateExposures+0x78) [0x8129418]
15: /usr/X11R6/bin/X [0x80d27d8]
16: /usr/lib/xorg/modules/drivers//vesa_drv.so [0xb7bf5204]
17: /usr/X11R6/bin/X [0x80cdfe3]
18: /usr/X11R6/bin/X(xf86SwitchMode+0xce) [0x80c2cfe]
19: /usr/X11R6/bin/X [0x80e5ce2]
20: /usr/X11R6/bin/X [0x80e5fda]
21: /usr/X11R6/bin/X [0x8159506]
22: /usr/X11R6/bin/X [0x814254e]
23: /usr/X11R6/bin/X(Dispatch+0x19f) [0x808c62f]
24: /usr/X11R6/bin/X(main+0x495) [0x8074785]
25: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xdc) [0xb7d95ebc]
26: /usr/X11R6/bin/X(FontFileCompleteXLFD+0x1e1) [0x8073ab1]

Fatal server error:
Caught signal 11. Server aborting

(EE) VESA(0): vm86() syscall generated signal 4.

[lspci]
00:00.0 Host bridge [0600]: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge [1106:3189]
     Subsystem: Giga-byte Technology GA-7VAX Mainboard [1458:5000]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc R300 AD [Radeon 9500 Pro] [1002:4144] (prog-if 00 [VGA])
     Subsystem: Giga-byte Technology Unknown device [1458:4016]

David Balažic (xerces8) wrote :

More data:
 - this was on herd 5 live boot CD environment
 - gfx card : radeon 9500
 - what I did : chagned resoltuion with the System / Preferences menu gadget

David Balažic (xerces8) wrote :
David Balažic (xerces8) wrote :
Luke Townsley (townsley) wrote :

Does changing the resolution as you described always produce a crash, sometimes produce a crash or always produce a crash?

David Balažic (xerces8) wrote :

I tried two times and it crashed in both cases.

I wanted to try it on my latop too, but it does not offer any resolution besidese the used 1280x1024.

David Balažic (xerces8) wrote :

I tried it now under VirtualBox and VirtualBox crashed when I tried to change the resolution ;-)

David Balažic (xerces8) wrote :

I tried it again on the same hardware as in the first report and it crashed again, so yes, it crashes always.

Timo Aaltonen (tjaalton) wrote :

fedora has a patch which is said to fix a randr-related crash. I'll put a new deb for you available.

ps. why don't you use the radeon-driver?

Changed in xorg:
assignee: nobody → tepsipakki
Timo Aaltonen (tjaalton) wrote :

ok, deb here:

http://users.tkk.fi/~tjaalton/xorg72/new/xserver-xorg-video-vesa_1.3.0-1ubuntu3_i386.deb

also, do you notice any change in performance, like when moving windows around?

Changed in xserver-xorg-video-vesa:
status: Unconfirmed → Needs Info
Timo Aaltonen (tjaalton) wrote :

ok, noticed that other bug about radeon :)

David Balažic (xerces8) wrote :

Tried the 1.3.0 driver:
 - still crashes on resolution change, tried inside virtualbox 1.3.8 on windows and on a PC native
 - on the PC the performance appears to be better

I attach the X log from the real PC crash.

Timo Aaltonen (tjaalton) wrote :

but did you use the one that I linked here?

David Balažic (xerces8) wrote :

yes

David Balažic (xerces8) wrote :

let me rephrase that : the performance is gazillion times better ;-)
(with the new vesa driver on a HP Compaq nw8440 laptop)

Timo Aaltonen (tjaalton) wrote :

That's good news :)

I need to look for another fix for the crasher.

David Balažic (xerces8) wrote :

Tried the beta.
It still crashes.

Before, with Herd5 :
 - strange picture (old video memory content shown, distorted), then X restarts with the previous resolution and shows the login screen
Now, with beta :
- strange picture (old video memory content shown, distorted), no restart of X. Input hung up, I can only reset the PC by the reset button.

Timo Aaltonen (tjaalton) wrote :

Ok, please test the latest version, since the previous ones did not have the patch applied.. there was a bug in packaging.

David Balažic (xerces8) wrote :

Where is the new version available ?

Timo Aaltonen (tjaalton) wrote :

In feisty since Tuesday.

David Balažic (xerces8) wrote :

As in here , for example ?
http://cdimage.ubuntu.com/daily-live/

Timo Aaltonen (tjaalton) wrote :

Oh, right.. you are the same guy as in the other vesa bug :) Yes, please test the next daily-live when it is usable (ie. not oversized). Thanks!

David Balažic (xerces8) wrote :

:)

Can I just (over)burn it? Or use a 800 MB CD ?
Or burn it to a DVD ?

(are there DVD images too ?)

Timo Aaltonen (tjaalton) wrote :

Overburning could work, it's not that much over 700MB. DVD's are a bit out-of-date.

David Balažic (xerces8) wrote :

I tried the http://cdimage.ubuntu.com/daily-live/20070402/feisty-desktop-i386.iso image.

HW : radeon 9500

First it booted with the radeon driver. Then I changed the resolution from 1280x1024 to 800x600.

Then I changed xorg.conf to use the vesa driver.

I restarted X and :
 - login screen appeared
 - then desktop appeared distorted

I gues what happened is :
 - login screen appeared at some resolution
 - the desktop tried to switch to the "remembered" 800x600 and that borked the vesa driver

Conclusion : changing resolution with vesa driver is still broken (at least on my HW).

Timo Aaltonen (tjaalton) wrote :

David: have you tried using a Gutsy prerelease?

David Balažic (xerces8) wrote :

Not (yet).

Timo Aaltonen (tjaalton) wrote :

David: how about trying out the final release? :)

David Balažic (xerces8) wrote :

I tried 7.10 desktop (final) inside VirtualBox.
It uses the vesa driver.
The resolution changes made by the "Screen Resolution" applet are ignored.
It offers 1024x768, 800x600 and 640x480, nut the screen always uses 1024x768.
(a bug with the "Screen Resolution" applet ?)

David Balažic (xerces8) wrote :

For the record, I reported the "Screen Resolution" issue as bug 159750

Bryce Harrington (bryce) on 2009-01-17
description: updated
Bryce Harrington (bryce) on 2009-03-24
description: updated
Timo Aaltonen (tjaalton) on 2010-03-05
Changed in xserver-xorg-video-vesa (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi David,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 91591

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 91591 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/91591

Changed in xserver-xorg-video-vesa (Ubuntu):
status: Incomplete → New
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-vesa (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers