Via KM400 : no matching mode for vesa

Bug #258764 reported by Djainette
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Xorg Xserver VESA
Undecided
Unassigned
xserver-xorg-video-openchrome (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by yoshiki2
Nominated for Lucid by yoshiki2
xserver-xorg-video-vesa (Ubuntu)
High
Unassigned
Nominated for Karmic by yoshiki2
Nominated for Lucid by yoshiki2

Bug Description

Since Feisty, no LiveCD is usable with a KM400 video card and vesa. Same problem when switching to vesa on an installed distro, I get the classic
(EE) VESA(0): No matching modes
(EE) Screen(s) found, but none have a usable configuration.

The only way to use the LiveCDs is to replace the xorg.conf file with one configured for the 'via' driver (which requires some technicals skills, and a previous xorg.conf file).

The problem still exists with xubuntu 8.04.1

Revision history for this message
Nico Timeo (n-timeo) wrote :

I can't run Ubuntu 8.04.1 LiveCD on my Acer Aspire 1350 with VIA VT8378 [S3 UniChrome] Integrated Video.
I also get:

(EE) CHROME(0): No valid modes found
(EE) Screen(s) found, but none have a usable configuration

In Windows XP my Video Card is detected as: VIA/S3G KM400/KN400

Revision history for this message
Djainette (djainette) wrote :
Revision history for this message
Nico Timeo (n-timeo) wrote :

It is incredible but the problem still exists with Ubuntu Intrepid Ibex 8.10 RC !!!
If I want to use Linux with my Acer notebook I must switch to OpenSuse 11 or Mandriva 2009...

Revision history for this message
Djainette (djainette) wrote :

Still buggy with the 11/16/08 xubuntu 8.10 daily live.

Revision history for this message
williamts99 (williamts99) wrote :

I can confirm that this is still true on the 8.10 live CD. I had to install with the alternative CD and then modify /etc/X11/xorg.conf on my Averatec 3200. I used the following in my xorg.conf and it is now working fine:

Section "Device"
Identifier "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
Driver "openchrome"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"

Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Bryce Harrington (bryce)
Changed in xorg:
importance: Undecided → High
status: Incomplete → Confirmed
Revision history for this message
Raphael Geissert (atomo64) wrote : Re: [Bug 258764] [NEW] Via KM400 : no matching mode for vesa

Hi,

[...]
> Since Feisty, no LiveCD is usable with a KM400 video card and vesa. Same problem when switching to vesa on an installed distro, I get the classic
[...]

I fail to see how this is related to -openchrome, am I missing something?

Revision history for this message
Djainette (djainette) wrote :

No, it seems to be a vesa bug. I'm not the one who attached it to openchrome.

This bugs has been annoying for so long I had time to change my 4 years old PC and get another card. Won't be able to help anymore.

Revision history for this message
Mobilitas (mobilitas) wrote :

Since Feisty, I have same problem.
Ubuntu 8.10 only works if I add "Option NoAccel" on xorg.conf
It's openchrome bug, I think.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

This is actually about the vesa driver being buggy. All the others are seeing another bug, so please file a new one if you still see it with a daily jaunty livecd (or alpha3 which should be out next week).

Revision history for this message
Nico Timeo (n-timeo) wrote :

I tried the solution by williamts99 and worked fine with Ubuntu 8.10.
With Ubuntu Jaunty 9.04 aplha6 I get the No Matching modes error again!!

Revision history for this message
pinzia (pinzia) wrote :

I have same problem after upgrade a jaunty

Revision history for this message
modemlamer (mod-rooties) wrote :

found on:
http://ubuntuforums.org/showpost.php?p=7150137&postcount=39

and modified (4-a1)

Installing 9.04 on Acer Aspire 1350 - not running desktop - how to fix Now Jaunty works for my Acer Aspire 1350 (1355LC) notebook!!!

I followed these steps:

1) getting the latest openchrome source code

2) decompressing the code

3) entering the newly created directory

4) compiling the source code

5) restarting the x-server

6) using Ubuntu 9.04 (Jaunty Jackalope)!

These are the commands I wrote:

1) wget http://www.openchrome.org/releases/xf86-video-openchrome-0.2.903.tar.gz

2) tar xvzf xf86-video-openchrome-0.2.903.tar.gz

3) cd xf86-video-openchrome-0.2.903

4) sudo ./configure --prefix=/usr

... in this step I got an error concerning some missing libraries (xorg-server, xproto, xvmc, fontsproto, libdrm)... I solved these problems typing:

4-a) sudo apt-get build-dep xserver-xorg-core

!!NEW!!4-a1)sudo apt-get build-dep xserver-xorg-video-openchrome!!NEW!!

4-b) sudo apt-get -f install

4-c) sudo apt-get install libxvmc-dev

5) sudo make

6) sudo make install

7) sudo /etc/init.d/gdm restart

then the X Desktop appeared!!!

should solve this for 9.04

Revision history for this message
Robert Moerland (veel-mail) wrote :

I'm posting a comment here, because I want to confirm that I also cannot get any working modes with the VESA driver on a VIA KM400, Ubuntu Jaunty. In my opinion, this bug report is not a duplicate of bug #293326, which has the same symptoms but deals with the openchrome driver. I ran into this problem as I've been asked to try to reproduce a bug, explicitly using the vesa driver.

Revision history for this message
Bartosz Kosiorek (gang65) wrote :

Please request this bug to:
https://bugs.freedesktop.org

and add link to this bug.

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: New → Invalid
Changed in xserver-xorg-video-vesa (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-vesa (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Robert Moerland (veel-mail) wrote :

I have upgraded my jaunty machine to karmic alpha 6 + latest updates, and I still can't get any graphics on screen with the vesa driver. Version of the installed xserver-xorg-video-vesa package is 1:2.2.1-1, failure reason still is (according to X server) 'no matching modes'. What else do you need to be able to report is bug upstream? Happy to help if I can.

Revision history for this message
Robert Moerland (veel-mail) wrote :

This bug has been reported as well at bugs.freedesktop.org: https://bugs.freedesktop.org/show_bug.cgi?id=24348

Changed in xserver-xorg-driver-vesa:
status: New → Invalid
Changed in xserver-xorg-video-vesa (Ubuntu):
status: Invalid → Confirmed
Changed in xserver-xorg-driver-vesa:
status: Invalid → Confirmed
Revision history for this message
MicRos (michele-roscelli) wrote :

Just to let people know:
i've got an ACER ASPIRE 1350
used metod reported by modemlamer, with some different steps, just follow commands down here.

first of all, manually configure your network address (lots of guides on the web, basically ifconfig stuff)

then type

sudo nano /etc/X11/xorg.conf

and add those lines (deleting previous device, monitor and screen sections)
-------------------------------------------------------------------------------------------------
Section "Device"
Identifier "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
Driver "openchrome"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
-----------------------------------------------------------------
then type:

1) wget http://www.openchrome.org/releases/xf86-video-openchrome-0.2.903.tar.gz

2) tar xvzf xf86-video-openchrome-0.2.903.tar.gz

3) cd xf86-video-openchrome-0.2.903

4) sudo apt-get build-dep xserver-xorg-core

5)sudo apt-get build-dep xserver-xorg-video-openchrome

6) sudo apt-get -f install

7) sudo ./configure --prefix=/usr

8) sudo make

9) sudo make install

10) sudo /etc/init.d/gdm restart

jaunty jackalope working fine!

Revision history for this message
mistseeker@gmail.com (mistseeker) wrote :

I can corfirm MicRos's solution works with my Aspire 1350 on Karmic, negating my serious video playback problems!
The only difference is I used 0.2.904 version of openchrome, instead of the 0.2.903 one.

Thanks!!!

Revision history for this message
Robert Moerland (veel-mail) wrote :

@MicRos, mistseeker: please note that this bug is about the VESA driver failing with a KM400 chipset, not the openchrome driver. The openchrome driver, whatever issues it might have, works allright on my machine as well. The VESA driver fails miserably.

Cheers,
Robert

Bryce Harrington (bryce)
tags: added: xubuntu
Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Djainette,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 258764

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 258764 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/258764

Changed in xserver-xorg-video-vesa (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Revision history for this message
Robert Moerland (veel-mail) wrote :

The original reported won't be able to help anymore:

"This bugs has been annoying for so long I had time to change my 4 years old PC and get another card. Won't be able to help anymore."

I still can reproduce this bug on my 10.04 install. Same error message:

(EE) VESA(0): No matching modes
(EE) Screen(s) found, but none have a usable configuration.

If it's really necessary I'll open an additional bug report, but I feel that everything that can be said about this bug has been said here and has been reported at bugs.freedesktop.org.

Revision history for this message
Robert Moerland (veel-mail) wrote :

In response to the tag needs-retested-on-lucid-by-june: it's nearly june and I've retested this issue on 10.04. Should the bug still be listed as incomplete?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.