Default video driver should not use AIGLX

Bug #152715 reported by Maxime Lorrillere on 2007-10-14
10
Affects Status Importance Assigned to Milestone
xserver-xorg-video-vesa (Ubuntu)
High
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Hardy
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-all

I don't know if the title of this problem is explicit...

With an ATI x1600pro, when I boot on the live CD, I have a black screen, I need to install xorg-driver-fglrx package in a shell before login with ubuntu user.

After installing, same issue, I need to install xorg-driver-fglrx in a shell if I want a screen, because the default driver doesn't work.

I don't know why, but in Xorg.0.log I can see:

(EE) AIGLX: Screen 0 is not DRI capable

All users should be able to start on the live-cd and install ubuntu without going to a shell related to graphics driver.

I will attach Xorg.0.log

Bryce Harrington (bryce) wrote :

Looks like it tried to load with the -vesa driver but that didn't work with your hardware.

Changed in xorg:
importance: Undecided → High
status: New → Triaged
Daniel Stoyanov (dankh) wrote :

I confirm this bug on laptop HP nc6400 with ATI X1300 , live CD fails to start X (as expected without fglrx) and worst fails to switch to vesa. I had to download the alternate CD to start the installation. I didn't noticed this in gutsy with the same laptop.

jc1985 (jc1985) wrote :

I confirm this bug on laptop Vaio CR21Z/R with ATI Radeon Mobility X2300 with either Gutsy or last daily builds of Hardy.
Please fix that for hardy !!

Confirmed with hardy alpha four on Dell Inspiron 9400 with ATI Mobility Radeon X1400. X fails to load on the live CD without installing fglrx from repositories. Must use alternate CD to install. This is largely the same behavior with the final release of feisty.

It seems to be fixed with the 20080313 daily build, I didn't reproduce that when booting to the live cd (with the same hardware than the original comment) and when booting on a new install.

Bryce Harrington (bryce) wrote :

Max, thanks for confirming the fix for this. I'll go ahead and close it, but Daniel, Jean-Christophe, Alex, or others who have seen this issue, if you find the issue has not gone away as of Hardy Beta, please reopen and please attach the output of `lspci -vvnn`.

Changed in xserver-xorg-video-vesa:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers