please remove xserver-xorg-video-sunbw2 from the archive

Bug #314539 reported by Timo Aaltonen
2
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned
xserver-xorg-video-sunbw2 (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-sunbw2

This driver is obsolete, since it cannot be built against xserver 1.6. The reason is that the needed headers have been removed from the source. It was discussed (briefly) on #debian-x as well:

23:16 < tjaalton> if I'm not mistaken, -sunbw2 will fail to build against 1.6 since the header
                  it needs has been removed (xf1bpp.h)
23:17 < jcristau> yeah sunbw2 is dead i think

and I doubt no-one is running ubuntu on a sparc workstation that _needs_ monochrome..

Related branches

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

it'll be removed from -video-all [sparc] too.

Changed in xorg:
importance: Undecided → Medium
status: New → Confirmed
Changed in xserver-xorg-video-sunbw2:
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

2009-01-12 11:59:38 INFO Removing candidates:
2009-01-12 11:59:38 INFO xserver-xorg-video-sunbw2 1:1.1.0-5ubuntu3 in jaunty
2009-01-12 11:59:38 INFO Removed-by: Steve Langasek
2009-01-12 11:59:38 INFO Comment: Obsolete driver not compatible with xserver 1.6; LP: #314539
2009-01-12 11:59:38 INFO 1 package successfully removed.
2009-01-12 11:59:38 INFO Transaction committed.
2009-01-12 11:59:38 INFO The archive will be updated in the next publishing cycle.

Changed in xserver-xorg-video-sunbw2:
status: Confirmed → Fix Released
Revision history for this message
Bryce Harrington (bryce) wrote :

Checked fix into xorg git.

Changed in xorg:
status: Confirmed → Fix Committed
Revision history for this message
Colin Watson (cjwatson) wrote :

I've unsubscribed ubuntu-archive from this bug, since there appears to be no more action for us to take here. Please resubscribe us if you need further action.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg - 1:7.4~5ubuntu11

---------------
xorg (1:7.4~5ubuntu11) jaunty; urgency=low

  [ Bryce Harrington ]
  * apport/source_xorg.py:
    - Adding system environment items recommended at
      http://intellinuxgraphics.org/how_to_report_bug.html
    - Add lshal
    - Add debug test code
    - Drop use of intel_reg_dumper since it requires root (LP: #311560)
  * scripts/vars.sparc: Drop sunbw2. It's dead jim. (LP: #314539)

  [ Timo Aaltonen ]
  * Merge with Debian experimental.
  * debian/control: xserver-xorg doesn't need to depend on mdetect
    anymore.
  * x11-common.links: Don't install the symlink to rgb.txt (LP: #300935)

 -- Bryce Harrington <email address hidden> Fri, 30 Jan 2009 13:42:37 -0800

Changed in xorg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers