Doesn't allow to use high resolutions

Bug #809482 reported by jjd on 2011-07-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-sis (Ubuntu)
Undecided
Unassigned

Bug Description

Fujitsu Siemens ESPRIMO-Mobile-V5535, SiS, Ubuntu 10.10,

I had 9.10 and the extra driver and it worked fine, but of course that's no more. I now have 10.10 and am stuck with 800x600. I've tried the forums and can just about follow some of it until I come to xorg.conf which on my system doesn't even exist in x11.

My knowledge of software and systems doesn't amount to that much, but it seems strange to me that Puppy Linux (from experience) and Mandriva (so I've heard) can both drive this screen "out of the box" but a big popular user friendly system like Ubuntu has problems.

Can you help, please?

Sam attempted to help but his suggestion unfortunately did not work.
The console interaction when I tried his suggestion follows;

-jjd@jjd-ESPRIMO-Mobile-V5535:~$ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
   800x600 61.0*
   640x480 60.0

jjd@jjd-ESPRIMO-Mobile-V5535:~$ xrandr --output default --mode 1024x768
xrandr: cannot find mode 1024x768
jjd@jjd-ESPRIMO-Mobile-V5535:~$ xrandr --addmode default 1360x768
xrandr: Failed to get size of gamma for output default
xrandr: cannot find mode "1360x768"
jjd@jjd-ESPRIMO-Mobile-V5535:~$ cvt 1360 768
# 1360x768 59.80 Hz (CVT) hsync: 47.72 kHz; pclk: 84.75 MHz
Modeline "1360x768_60.00" 84.75 1360 1432 1568 1776 768 771 781 798 -hsync +vsync
jjd@jjd-ESPRIMO-Mobile-V5535:~$ xrandr --newmode "1360x768_60.00" 84.75 1360 1432 1568 1776 768 771 781 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default
jjd@jjd-ESPRIMO-Mobile-V5535:~$ xrandr --addmode default 1360x768
xrandr: Failed to get size of gamma for output default
xrandr: cannot find mode "1360x768"
jjd@jjd-ESPRIMO-Mobile-V5535:~$ sudo lshw -C display
[sudo] password for jjd:
  *-display UNCLAIMED
       description: VGA compatible controller
       product: 771/671 PCIE VGA Display Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 10
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller cap_list
       configuration: latency=0
       resources: memory:c0000000-cfffffff memory:d4000000-d401ffff ioport:9000(size=128)
jjd@jjd-ESPRIMO-Mobile-V5535:~$

papukaija (papukaija) on 2012-05-02
summary: - Widescreen with 10.10
+ Doesn't allow to use high resolutions
tags: added: maverick
papukaija (papukaija) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please run the command 'apport-collect 809482' which will attach necessary information for debugging this as an Xorg problem. Thanks in advance.

Changed in xserver-xorg-video-sis (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since there has not been a response from the original reporter. However, the issue still exists please feel free to reopen with the requested information. If you're not the original reporter, we'd prefer you file a new bug report.

Some tips:

  * Report X.org bugs via the command: `ubuntu-bug xorg`

  * Test against the latest development Ubuntu. http://cdimage.ubuntu.com/daily-live/
    Bugs marked as affecting the development version tend to get priority attention.

  * The `xdiagnose` utility has functionality for enabling debugging and
    analyzing a few common X problems.

  * Tag your bugs with the Ubuntu versions you have reproduced the issue in.

  * See https://wiki.ubuntu.com/X/Reporting for tips on writing good bug reports.

Changed in xserver-xorg-video-sis (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions