kdm does not restart on LOGOUT

Bug #295743 reported by Brian Harkness on 2008-11-08
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-sis (Ubuntu)
Undecided
Unassigned

Bug Description

Acer Aspire Laptop 3005 LCi

All options for leaving kde4 in Intrepid work except LOGOUT. When RESTART or SHUTDOWN options are chosen, kdm is stopped, the exit usplash comes up and the machine responds appropriately. Right before the usplash comes up, "checking battery state" is seen and a message regarding kdm stopping is seen. Using terminal, the "checking battery state" is the last thing seen before kdm loads on a normal start so it is not the perceived problem.

LOGOUT causes the machine to "freeze" at the terminal and only "checking battery state" is seen. ctrl-alt-F1 causes the screen to flicker and a console login is possible.

Once logged in 'sudo /etc/init.d/kdm restart shows a message that kdm is not running, it then starts and graphical login is possible. Frequently, I just issue 'sudo init 1' as when I log out, it is usually to reset the X server if I attach a projector. This also works, except the exit usplash is activated and is "on top of" the options of resume, dpkg, enter root, fix x server. I discovered this by chance and it is perhaps another "bug." If I hit "enter" after the exit usplash stalls, the screen flickers and I can see the blue screen whith red highlighting "resume" that is available in "recovery mode."

This situation occurred after an upgrade from Hardy (LOGOUT working) to Intrepid (LOGOUT not working).

I had a spare disk and so installed the down-loadable version of the latest i386 live CD, installed it cleanly and the issue still happens.

It seems very obvious then that this is indeed a bug with my particular hardware and Intrepid.

Same results if gdm or xdm is installed and used as the display manager.

Hardware:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
00:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
00:0b.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

thieme (thieme-reis) wrote :

I have a acer laptop with sis chipset and the same problem: Logout not restart kdm

My lscpi:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:05.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
00:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

My Xorg.0.log:

(II) SIS(0): Restoring by setting old mode 0x03
(WW) SIS(0): xf86UnMapVidMem: cannot find region for [0xb78d0000,0x10000]
(WW) SIS(0): xf86UnMapVidMem: cannot find region for [0xb58d0000,0x2000000]
(II) Open ACPI successful (/var/run/acpid.socket)
(II) APM registered successfully
(EE) SIS(0): Unable to map IO aperture. Invalid argument (22)
(EE) SIS(0): **************************************************
(EE) SIS(0): ERROR:
(EE) SIS(0): Could not map MMIO area
(EE) SIS(0): END OF MESSAGE
(EE) SIS(0): **************************************************
(EE) SIS(0): **************************************************
(EE) SIS(0): ERROR:
(EE) SIS(0): SiSMapMem() failed
(EE) SIS(0): END OF MESSAGE
(EE) SIS(0): **************************************************

attached my /etc/X11/xorg.conf

thieme (thieme-reis) wrote :

Complement: kubuntu 8.10 with all updates

Brian Harkness (maestro-bwh) wrote :

Ditto here... all updates have been installed.

As noted in case it is missed, this also works from a "fresh install" as well as an upgrade on the same computer.

Brian Harkness (maestro-bwh) wrote :

Mis phrased "this also works" should be "this also happens." It doesn't work in other words:-)

thieme (thieme-reis) wrote :

Excuse me, i do not speak english, i speak portuguese.

PS: A minha lingua eu escrevo e falo corretamente.

Brian Harkness (maestro-bwh) wrote :

I was referring to a mistake I made in my own grammar;-) I apparently don't even know how to use my own language.

Tried driver "vesa" in xorg.conf and it would not wake from suspend so that made it worse.

philippe44 (pgu-9online) wrote :

Same on my acer with 8.10 but found a workaround : force the X server to truly restart, not only reset. So add this line in your kdmrc file in the stanza [X-:*-Core]
TerminateServer=true

Brian Harkness (maestro-bwh) wrote :

Got a black screen without kdm restarting by un-commenting

TerminateServer=true

in /etc/kde4/kdm/kdmrc

only ctrl alt f1 would bring me back up to a terminal. Not a fix for me.

Brian Harkness (maestro-bwh) wrote :

and a small @ would flash in the upper left corner. The screen is completely black... as in the backlight is turned off.

I still have to ctrl-alt-F1, then sudo init 1 then hit enter after the usplash stalls. It brings me back up to the kdm greeter, and an external monitor/projector can be used if it is connected before resuming from init 1.

Still ugly way to have to do this. For some reason xrandr can't pick up the projector. I even tried adding xorg lines for this.

Brian Harkness (maestro-bwh) wrote :

Correction: I needed to do a hard reboot. I tried this again when I had time to fiddle with it. The first time, I just ran "init 1" and it didn't work.

I also ran dpkg-reconfigure -phigh xserver-xorg to give me a "clean" xorg file.

Works now. Thanks!

Bryce Harrington (bryce) wrote :

Hi maestro-bwh,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log (or Xorg.0.log.old) from after reproducing the issue?

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in xserver-xorg-video-sis (Ubuntu):
status: New → Incomplete

I also have this problem in Kubuntu 9.04 alpha 6 with all updates in March 26th 2009.

alan@chinelinho:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:05.0 RAID bus controller: Silicon Integrated Systems [SiS] RAID bus controller 180 SATA/PATA [SiS] (rev 01)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter.

Adding /var/log/Xorg.0.lod.old after reprocuding the problem:

tags: removed: needs-xorglog
Changed in xserver-xorg-video-sis (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-09-02
tags: added: kubuntu
7oby (tobias-hain) wrote :

Looks like SiS X-Server crashed upon logout:
[ 1096.753217] (EE) SIS(0): Unable to map IO aperture. Invalid argument (22)
[ 1096.753255] (EE) SIS(0): **************************************************
[ 1096.753276] (EE) SIS(0): ERROR:
[ 1096.753299] (EE) SIS(0): Could not map MMIO area
[ 1096.753319] (EE) SIS(0): END OF MESSAGE
[ 1096.753339] (EE) SIS(0): **************************************************
[ 1096.753360] (EE) SIS(0): **************************************************
[ 1096.753380] (EE) SIS(0): ERROR:
[ 1096.753399] (EE) SIS(0): SiSMapMem() failed
[ 1096.753418] (EE) SIS(0): END OF MESSAGE
[ 1096.753437] (EE) SIS(0): **************************************************

Respawning kdm as requested here might fix the problem:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/432521

Or find the reason for SiS driver crash and fix it in the first place.

Mörgæs (moergaes) wrote :

Closing due to age.
If a similar bug appears in 14.04, which contains an important fix for SIS cards, please open a new report.

Changed in xserver-xorg-video-sis (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers