ASUS A6000 / SIS M760GX grainy graphic display

Bug #287475 reported by Doug Bates on 2008-10-22
96
This bug affects 17 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Critical
xserver-xorg-video-sis (Debian)
Fix Released
Unknown
xserver-xorg-video-sis (Ubuntu)
High
Unassigned

Bug Description

I am running Hardy 8.04 fine on my Asus A6B00U laptop with SIS M760 GX graphics I believe.

Yet on Intrepid I get full screen resolution (1280x800) but what seems to be about 4 colours (CYMK?) and massive dithering on all displays (windows (small 'w'!), pictures etc).

I notice that a 'screen shot' looks fine (when viewed on another machine) but the display does not, so I attach a camera photo for your interest.

Just once it booted 'right' and looked great, but after a load more updates it's all messed up again.

Sorry I can't get more technical. Your efforts are much appreciated!

Doug

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
Package: firefox-3.0 3.0.3+nobinonly-0ubuntu2
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-7-generic x86_64

Doug Bates (coloneldare) wrote :

I'm having problems with colors when using the SiS driver with XOrg 7.4. Before the update everything worked fine. More info with the screenshots is here:
http://bugs.archlinux.org/task/12365
Right now I'm using a VESA driver, but it has smaller resolution. Besides, there's a problem with VESA: when I log out of X and then press Alt-F7 the system hangs.

I didn't get an answer so far... Could someone fix this problem? It is quite annoying.

batteryfast (batteryfast2001) wrote :

I have this type of laptop. Now, the laptop battery last only half a hour so I got a battery from http://www.batterygoshop.co.uk/asus/a6000-series-battery.htm . I hope it can help you.

*** Bug 19104 has been marked as a duplicate of this bug. ***

OK, You opened this bug 2 days before I did it, so I marked my instance as a
duplicate. ;)

Just to keep order - bug report in launchpad, widely commented, is here:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-sis/+bug/264769

Please, comment if You have any significant remark.

The problem with logging out is not general, I didn't have it with vesa - I think You should fill another bug and this one should be only about not working sis driver.

As for the vesa resolution - although, unfortunately, 1280x800 is impossible to get with vesa, 1280x768 is available if You put it explicite in Your xorg.conf, so it's "quite" ok. Performance is not very good, though.

That is why I keep to Hardy 8.04 LTS edition that sticks to X.org 7.3 and that will be supported till 2011. At least until 2011 I can use sis driver...

I'll attach my intrepid's xorg.conf with proper vesa entries, maybe it'll help.

One remark - those "Modeline" entries can be obtained by using the command:
gtf <h-resolution> <v-resolution> <refresh rate>
(see man gtf)

Created an attachment (id=21977)
xorg.conf for intrepid with vesa driver, configured for 1280x800 resolution

> configured for 1280x800 resolution
Pardon, I meant 1280x768. Although those 1280x800 entries exist in the attached xorg.conf, they were not used and X server was automatically switching to 1280x768. So 1280x800 can be ommited (but You have to put 1280x768 in the first place in "Modes" line)

I'm using openSUSE-11.1 and have the same issue.

I made the system load sisfb module on boot and put Option "UseFBDev" "true" in the Device section in xorg.conf which seems to be a successful (1280x800) workaround. I had to reboot though, doing modprobe sisfb and restarting xorg didn't work.

> I'm using openSUSE-11.1 and have the same issue.
I tried openSUSE-11.1 LiveCD and I can confirm these problems.

> I made the system load sisfb module on boot and put Option "UseFBDev" "true" in
> the Device section in xorg.conf which seems to be a successful (1280x800)
> workaround.
I'm pretty sure I tried it and it didn't help. It seems, though, that it helped some people, so it can depend on some specific issues. It's always worth to try, though...

I prefer to stick to Hardy as long as I can.

I've changed my computer recently and now I've GeForce card so I won't be able to report on this problem anymore.

Fernando Pereira proposed a configured version of xorg.conf which works for me
perfectly in Ubuntu Intrepid (with sisfb module loaded). Here is a permalink:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-sis/+bug/264769/comments/60

It seems that for me adding sisfb to /etc/modules works (after a reboot).

NOTE: sisfb module *MUST* be loaded at start. It means that it's not enough to load it using 'modprobe sisfb' and restarting X server. It *MUST* be added to /etc/modules, after a reboot it starts to work.

One more: for me adding "UseFBDev" option to xorg.conf wasn't necessary. I must have omitted something when I was trying the solution last time as it works perfectly now...

Hello,
I experience the same problem with a sis 760 (GM or GX i think, lspci doesn't give much information), under fedora 10.
Problem is, sisfb is not included in this distribution (so i cannot use your trick), and i cannot get the old version of the sis driver (9.4) to compile (seems to be because of changes in the xorg api).
10.0 and 10.1 do compile, but they both produce odd colors (after "startx" it's not that weird, but it gets worse with the time).
Is there an easy way to convert the old driver to the new api?

Btw, it seems Thomas Winischhofer has stopped working on this driver since 2005, so maybe we should reassign the bug, but i don't know who to reassign it to.
According to http://cgit.freedesktop.org/xorg/driver/xf86-video-sis/ , Dave Airlie, Adam Jackson or Julien Cristau are active, but i don't know their email.

I'm a little noob here, but isn't xf86-video-sis team working at XFree86 version of the driver, not the X.org one?

Dan Trevino (dantrevino) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

DT> Thank you for taking the time to report this bug and helping to make
Ubuntu better.

I'm pleased to be able to help - I love my U8.04 but 8.10 is still
unusable. I have kept it fully patched (currently running as
2.6.27-generic with Gnome 2.24.1) but it still mostly fails to boot the
video properly - then sometimes it does, maybe 3 or 4 times in a row, &
I think 'Yeeee' they've fixed it - then not and I go back to 8.04 (dual
boot)).

Sorry I can't offer the skills to fix it myself, but if you need me to
run any tests (simple instructions please!) I happily will.

One final clue(?) is it some sort of hardware race or timing issue (?)
because, even when it does boot right, if I watch a Youtube or video I
notice little white 'sparks' at the screen of the scan (ie LHS) jiggling
up and down the screen. In 8.04 everything is rock-solid and stable.

Many thanks for all your (plural) help.

Cheers,

Doug

ps I haven't tried 9.04 beta yet. Should I? - though I'll need to wipe 8.10 (no worries).

-------------------------------

Dan Trevino wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering if this is still an issue
> for you. Can you try with the latest Ubuntu release? Thanks in advance.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
>

Doug Bates (coloneldare) wrote :

DT> We were wondering if this is still an issue for you. Can you try
with the latest Ubuntu release?

Yes - I have just tried 9.04 (i386) and the grainy 4 colour display
still renders it useless. I guess I'm stuck with 8.04 (lovely, v.
stable) until the video gets sorted.

Thanks,

Doug

Dan Trevino wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering if this is still an issue
> for you. Can you try with the latest Ubuntu release? Thanks in advance.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
>

Malthe Sunesen (malthe-s) wrote :

I can inform that this bug is also present on my Acer Aspire 5003wlmi, same graphics. The last three versions of Ubuntu have had this problem (yes - even 8.04). I would describe the screen kinda 70's - like someone from the 70's went in and poured a bucket of '70's essence' over the computer. The screen flickers a bit, and the most dominant colour is pink or shades of pink. I have tried to find a solution (pulling the battery out, holding the power button, shutting down and letting the laptop stay for some time), but nothing seems to work - not even starting the Windows XP partition seems to help, and Windows XP displays colours the right way no matter what.

Another thing is this: the boot graphics (the Ubuntu logo and the loading bar) shows the true colours, just like Windows XP.

Last note: I can happilæy shut down the laptop and turn it on when the colours are the way they are meant to be, but as soon as the colours are funky, it just wont change, not matter how many reboots.

David Tangye (davidtangye) wrote :

Here is my xorg.conf. It shows the sis driver and all its possible options. Perhaps one of them would fix the problem. However, as also shown, I switched out the sis driver and switched in the vesa driver, to make the laptop's graphics work properly.

David Tangye (davidtangye) wrote :

The problem must be in this driver/package.

affects: ubuntu → xserver-xorg-video-sis (Ubuntu)
Changed in xserver-xorg-video-sis (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid

The latest fix from kendatsuba, provided at launchpad, solves the problem for me. See comments:
https://bugs.launchpad.net/bugs/264769

Could this fix be applied upstream?

kaspin (kaspin) wrote :

I gave up Ubuntu when this happened to me (ASUS a6000) when updating to (or from - not sure, it was a while ago) 8.04. With the arrival of 9.10 I expected that the problem would have been resolved. But no - just as Malthe describes above. So the problem has been around for a year or so - is there a solution? Kaspin
PS I had a problem with wireless connection as well which was solved by installing a driver through Synaptics. Must stop now as the flickering screen is making my eyes water..................

Jan Vlnas (jnv) wrote :

Friend of mine has a simmilar problem recently with Karmic (ironically, not with Jaunty) on Asus A6000, SIS M760GX. See how the problem looked like: http://www.youtube.com/watch?v=yRXVb4F6g6g (wait for the X server start).

What helped him was the newest SIS driver which you can get in this ppa: https://launchpad.net/~xorg-edgers/+archive/drivers-only

You can add the repository and update by
sudo add-apt-repository ppa:xorg-edgers/drivers-only && sudo apt-get update && sudo apt-get upgrade
or you can install only the related package: https://launchpad.net/~xorg-edgers/+archive/drivers-only/+sourcepub/777647/+listing-archive-extra

Further to your email (22 Feb - I did reply at the time), I still
cannot use even the latest (9.10) version as about 50% of boot-ups fail
resulting in four(?) colour grainy graphics. Repeated hard resets/cold
starts often don't fix it - then the next day maybe it boots fine.

8.4 LTS still works perfectly, but I would like to move up to 9.10 and
on, as i have with my other 3 machines.

Hoping for a fix.

Regards,

Doug

Dan Trevino wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering if this is still an issue
> for you. Can you try with the latest Ubuntu release? Thanks in advance.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
>

Doug Bates (coloneldare) wrote :

I recently applied the update (c/o what syntax wrote on 2009-12-07 above) and my 9.10 worked fine at last :-).

But now we are back to where we were.
See https://launchpad.net/~xorg-edgers/+archive/drivers-only/+sourcepub/777647/+listing-archive-extra.

And thanks Tormod Volden it worked a treat - but now can we have it in 10.04 please?

Doug

for me, debian sid with SIS 661 i resolved the problem using the patch found above adding case SIS_661 to the list- still using sis driver and adding sisfb to /etc/modules

this patch is not applied in xserver-xorg-video-sis 1:0.10.2-1

for using dual head i just use this xorg.conf file :

Section "Device"
Identifier "SIS 661"
Driver "sis"
        BusID "PCI:1:00:0"
        Option "MergedFBAuto" "on"
        Option "UseSSE" "yes"
EndSection

======================== patch found ===============================
http://<email address hidden>/msg02767.html

 src/sis_driver.c | 2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/src/sis_driver.c b/src/sis_driver.c
index 994b02d..b19e7a9 100644
--- a/src/sis_driver.c
+++ b/src/sis_driver.c
@@ -4099,6 +4099,8 @@ SISPreInit(ScrnInfoPtr pScrn, int flags)
             case SIS_315H:
             case SIS_330:
             case SIS_340:
+ case SIS_650:
+ case SIS_760:
             case XGI_40: readpci = TRUE;
                              break;
             case XGI_20: readpci = TRUE;
--
1.6.3.3
==================================================================

Doug Bates (coloneldare) wrote :

It's still broken in 10.04 Beta 1 ***AND*** the fix by net/~xorg-edgers/+archive/drivers-only/+sourcepub/777647/+listing-archive-extra (above) now doesn't work - as it was in 9.10.

PLEASE SOMEONE - HELP....

Doug

Tormod Volden (tormodvolden) wrote :
Changed in xorg-server:
status: Unknown → Fix Released
Tormod Volden (tormodvolden) wrote :

Will be fixed in 0.10.2-2 to be released real soon now.

Doug Bates (coloneldare) wrote :

Brill - I just wish it didn't make me feel so geriatric. I can see the probs, but don't have the skills to fix them.

So Tormod, thanks for your help/interest.

Doug

Wider comment: I love how how Lucid looks/feels, I'm amazed how well Beta1 works already. Promising! Thanks.

tags: added: patch
Tormod Volden (tormodvolden) wrote :

I have filed a separate sync request in bug 544904 to have this fixed.

Bryce Harrington (bryce) wrote :

The debdiff looks fine to me, we can take it if for any reason the sync doesn't go through. But I'd prefer seeing it taken up via the sync from debian.

Changed in xserver-xorg-video-sis (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-sis - 1:0.10.2-2

---------------
xserver-xorg-video-sis (1:0.10.2-2) unstable; urgency=high

  * High urgency upload for RC bug fix.

  [ Julien Cristau ]
  * Rename the build directory to not include DEB_BUILD_GNU_TYPE for no
    good reason. Thanks, Colin Watson!
  * Remove myself from Uploaders

  [ Tormod Volden ]
  * Cherry-pick 8370499d4035ec7a5c8e1f1b04d5a6c404883442
    Fix BIOS read on 650 and 760. (#19070) Closes: #546714. LP: #287475
 -- Timo Aaltonen <email address hidden> Mon, 22 Mar 2010 23:27:06 +0100

Changed in xserver-xorg-video-sis (Ubuntu):
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-sis (Debian):
status: Unknown → Fix Released
Changed in xorg-server:
importance: Unknown → Critical
Changed in xorg-server:
importance: Critical → Unknown
Changed in xorg-server:
importance: Unknown → Critical
onny (onny) wrote :
onny (onny) wrote :

I've got still the same problem in Ubuntu 11.04 Alpha 3 with the xserver-xorg-video-sis 1:0.10.3-2ubuntu2 driver version :(

onny (onny) wrote :

Well, this comment solved the problem https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video
-sis/+bug/264769/comments/60

Tormod Volden (tormodvolden) wrote :

Onny, please file a new bug using "ubuntu-bug xserver-xorg-video-sis". It should work out of the box without any xorg.conf or module blocking.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.