[Ubuntu 12.04.1 LTS 32-bit] Several SiS 661GX / 761GX (SiS Mirage 1 integrated graphics) issues

Bug #1075511 reported by fpgahardwareengineer on 2012-11-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-sis (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I will like to report that SiS 661GX's integrated graphics (Real256E graphics) has number of issues (bugs) under Ubuntu 12.04 LTS 32-bit.

1) Ubuntu logo doesn't get displayed until the last moment, and it is at a low screen resolution

In a typical system, during boot, Ubuntu displays its graphical logo with red dots flashing on the screen.
In a SiS 661GX-based system, the screen will have a dark purple background pretty much throughout the boot up, and Ubuntu graphical logo will not get displayed until just right before the login screen gets displayed.

2) The graphics starts out in interlaced mode if I use Gateway EV700 CRT monitor with it

I often use this computer (see System Configuration 1) with Gateway EV700 CRT monitor.
Unfortunately, Ubuntu will choose interlaced mode for the screen (87 Hz Interlaced).
Since Ubuntu 12.04 doesn't have a direct way to alter the screen refresh rate from its control panel like menu, the screen quality will be quite poor.
Since the monitor itself it capable of 1024 X 768 @ 75 Hz Non-Interlaced, shouldn't this behavior (starting out in interlaced mode) be considered a bug?

3) Mouse cursor disappears if there is rendering happening underneath it

I don't know if the SiS x.org display device driver uses hardware cursor feature of SiS graphics (I am assuming that SiS graphics supports hardware cursor.), but I notice that it disappears when there is some rendering happening underneath it.
Particularly noticable in Firefox.
I didn't observe this with NVIDIA or ATI Technologies graphics so I assume this is a bug.

4) Screen horizontal and/or vertical frequency goes nuts during restart or shut down

When I try to restart or shut down this computer, the monitor's horizontal and/or vertical frequency goes out of range.
I don't know which one goes out of range, and I have no way of knowing this.
I will say that this is potentially dangerous since it can damage a monitor, although if I am correct, most monitors have ways to detect this kind of condition, and will display a warning message to prevent damage to the monitor.
Regardless, it is not a desirable condition, and I believe this should be considered a bug.

Overall, these issues mentioned here didn't exist in Ubuntu 10.04 LTS 32-bit.
All of them appeared in Ubuntu 12.04 LTS 32-bit.
        Regarding this SiS Real256E integrated graphics, I have another mainboard called ECS 761GX-M754 (SiS 761GX/964 chipset).
The integrated graphics inside SiS 761GX is identical to SiS 661GX.
SiS 761GX also exhibits issues similar to what was described here.

System Configuration 1:

- Intel Pentium 4 2.8 GHz
   * 800 MHz FSB
    * 130 nm device (Northwood)
    * Hyperthreading enabled
- ASUS P4S8X-MX mainboard
    * SiS 661GX northbridge
    * SiS 964 southbridge
    * BIOS Revision 0808 (last release)
- 1 GB DDR SDRAM
- SiS Real256E integrated graphics
   * Using 16MB for graphics
- Hitachi IC35L060AVV207-0 60GB PATA hard drive
- Hitachi-LG Data Storage GCC-4481B PATA CD-RW/DVD-ROM drive
- USB multi-card reader
- USB keyboard
- USB mouse
- Gateway EV700 CRT monitor

System Configuration 2:

- AMD Sempron 2800+
- ECS 761GX-M754 mainboard
  * SiS 761GX Northbridge
  * SiS 964 Southbridge
  * BIOS Version 070227
- 1 GB DDR SDRAM
- SiS Real256E integrated graphics
   * Using 32 MB for graphics
- Emprex 1008IM PATA DVD-RW drive
- USB multi-card reader
- PS/2 keyboard
- PS/2 mouse
- Gateway EV700 CRT monitor

Regards,

fpgahardwareengineer

Hi,

I submitted this bug report without running ubuntu-bug from the terminal because this computer's hard drive has had issues running ubuntu-bug.
For more details, refer to this bug report I have already submitted.

https://bugs.launchpad.net/ubuntu/+source/ubuntu/+bug/1073079

Anyway, I tried running apport-collect to collect various log files, but I get the following error message.

Updating problem repot
No additional information collected.

What other options do I have to collect he necessary log files?
I do not wish to collect the log files manually.

Regards,

fpgahardwareengineer

summary: - [Ubuntu 12.04.1 LTS 32-bit] Several SiS 661GX / 761GX (Real 256E
+ [Ubuntu 12.04.1 LTS 32-bit] Several SiS 661GX / 761GX (Real256E
graphics) issues
description: updated

Hi,

I tried running apport-collect in a following manner.

$ apport-collect 1073079

I got the following error messages.

Package pidgin not installed and no hook available, ignoring
Package ubuntu not installed and no hook available, ignoring

This computer's hard drive used to have Linux 3.7-rc2 kernel installed for testing purposes (Refer to launchpad bug # 1068393 for more details.), and it looks like that messed up the hard drive.

Regards,

fpgahardwareengineer

affects: xserver-xorg-video-sis → xorg-server
affects: xorg-server → xserver-xorg-video-sis

Hi,

I ran my own script that collects all relevant log files.
I just uploaded them manually.

Regards,

fpgahardwareengineer

Book 'em Dano (heymrdjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in xserver-xorg-video-sis.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: xserver-xorg-video-sis → xserver-xorg-video-sis (Ubuntu)
summary: - [Ubuntu 12.04.1 LTS 32-bit] Several SiS 661GX / 761GX (Real256E
- graphics) issues
+ [Ubuntu 12.04.1 LTS 32-bit] Several SiS 661GX / 761GX (SiS Mirage 1
+ integrated graphics) issues
Changed in ubuntu:
status: New → Invalid

Hi,

I have an update on this bug.
For Bug (2) (See bug description: The graphics starts out in interlaced mode if I use Gateway EV700 CRT monitor with it), I will report that this is a regression.
When I tested SiS 661GX integrated graphcis (SiS Mirage 1 integrated graphics) with Ubuntu 11.10, the screen did not go into interlaced mode.
But it will display the screen in interlaced mode in Ubuntu 12.04 LTS.
This regression was observed on ASUS P4S8X-MX mainboard.

Regards,

fpgahardwareengineer

tags: added: regression-release
tags: added: i386 running-unity ubuntu
Daniel van Vugt (vanvugt) wrote :

No longer affects Unity. All the problems described seem more related to xserver-xorg-video-sis.

no longer affects: ubuntu
no longer affects: unity

(In reply to Fabio Marconi)

Hi,

I believe this should be categorized as Ubuntu bug because the x.org display device driver can display the screen at 1024 X 768 75 Hz NiFF in Ubuntu 11.10.
Please read Comment #10.
Also, if I am correct, SiS/XGI x.org display device driver hasn't been updated since 2008 or so if I am correct so I don't think you can blame the problem on xserver-xorg-video-sis package.

Regards,

fpgahardwareengineer

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-sis (Ubuntu):
status: New → Confirmed
Martin (ub71-martin) wrote :

about the item : 3) Mouse cursor disappears if there is rendering happening underneath it
May it could be the same issue as https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-vesa/+bug/1098862 ?

Also I've made a video of what I observe : http://youtu.be/NmRP9S744rk

Timo Aaltonen (tjaalton) on 2014-01-11
no longer affects: ubuntu (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers