SiS video driver circles round login screen

Bug #1034812 reported by SteVe Cook on 2012-08-09
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-sis (Ubuntu)
Undecided
Unassigned

Bug Description

Login screen just flicks on screen then screen goes blank before login screen flickers back on and of for ever more. Can be a problem getting to a TTY as well, this seems to be a matter of hitting Alt+Ctrl+Fn at just the right time.

Hardware: VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter (prog-if 00 [VGA controller])

SteVe Cook (yorvyk) wrote :

Attach Xorg log

SteVe Cook (yorvyk) wrote :

Attach Apport report

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-sis (Ubuntu):
status: New → Confirmed
helpfulboy02 (helpfulboy02) wrote :

will the updated fix be Back ported to 12.10?

The same behavior is happening with an integrated ATI Rage Pro (AGP 2X and 4M memory) graphic card in a Dell OptiPlex GX1 using Lubuntu 12.10 Quantal Quetzal. After upgrading from 12.04, it doesn't enter in the X system, and the system tries to change to the graphic mode unsuccessfully in a loop indefinitely. Previous this upgrade the system was working fine.

I don't attach the xorg.log because it wasn't present in the system and this computer doesn't make use of xorg.conf. However I've attached the dmesg and lspci. It is using the latest Lubuntu kernel.

I appreciate any help given in this subject and thank you for the time and effort solving this issue.

Best regards,

-Andrey

SteVe Cook (yorvyk) wrote :

Audrey,

It's probably best if you raise a separate bug against xserver-xorg.-video-ati for this. Although I believe the cause is the same, the removal of xaa support, The solution for each driver may not be the same.

Quax Eros (quaxeros) wrote :

I have the same problem but my hardware is a SiS76x chip.

Hardware: VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

SteVe Cook (yorvyk) wrote :

That's to be expected as it's still a Series 315 chip.

The bug is with 315 series (SiS 315/E/PRO, 550, [M]650, 651, 740, [M]661[FMG]X,[M]741[GX]) chips.

See https://wiki.ubuntu.com/QuantalQuetzal/ReleaseNotes/CommonInfrastructure at the bottom for a workaround.

Quax Eros (quaxeros) wrote :

According to http://www.winischhofer.net/linuxsispart1.shtml (the maintainer of the Xorg sis driver) the SiS76x is a 330 series chip.
Adding "blacklist sis" to /etc/modprobe.d/blacklist.conf (stated as workaround) does not resolve the problem. Blank screen + mouse cursor keeps popping on and off ....
Xrandr not usable... "can't open display"
I'm stuck on how to proceed after blacklisting.

SteVe Cook (yorvyk) wrote :

Quax, you're correct, I miss-read it as 67.
As for blacklisting, I never tried it myself untill now and it really doesn't seem to work with video drivers. although a friend seems to have managed with a different OS.
I just uninstalled xserver-xorg-video-sis, this also removes xserver-xorg-video-all which is just a meta package, and worked from there.

Quax Eros (quaxeros) wrote :

@SteVe
"sudo apt-get remove xserver-xorg-video-sis" worked for getting me into GUI with 1024x768 (not 1280x800)

now trying to work xrandr to get wxga on my laptop panel.
thnx

Thank you Steve, I did it so as you suggested and opened the new bug in here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1071564

Thank you for the prompt reply and assistance.

Parmentier (alparmentier2) wrote :

For a sis 741 , I installed lubuntu from a MinimalCD without xserver-xorg-video-sis.

I downgraded xorg:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade

as in http://www.ubuntugeek.com/how-to-install-amd-catalyst-legacy-drivers-in-ubuntu-12-10-quantal.html

then

sudo apt-get install xserver-xorg-video-sis
sudo reboot

bratherlui (bratherlui) wrote :

Is there any way to have not 100% CPU-usage all the time?

Quax Eros (quaxeros) wrote :

Thanks @Parmentier,

Uninstalled xserver-xorg-video-sis
Downgraded xorg as proposed by Parmentier (2 comments above)
Installed xserver-xorg-video-sis

SiS76x chip working fine now.
Good work-around, Thanks!

Moiz Rafay (m-rafay31) wrote :

Also appears for SIS661 chip in my Acer Aspire 3630. Going to try to fix now...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers