S3 driver displays pink banner when viewing HD videos

Bug #99255 reported by Eugenia Loli-Queru on 2007-03-31
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Medium
xserver-xorg-video-savage (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-savage

It seems that the S3 savage driver for Xorg has a hardcoded limitation regarding its Xv functionality. If a video is wider than 800 pixels wide, then the rest of the screen has a pink color. For example, my 480p video that is 853x480, has 53 pixels rendered as pink color on the right side of the screen, resulting in a vertical pink banner. Same happens no matter what media player I use, as it's an Xv driver bug, not a media player one. Some facts:
1. It only happens when Xv is used. Other transports work without this bug, but without Xv you don't want to watch HD video anyway because it is too slow without acceleration.
2. When I grab a screenshot from the framebuffer, the pink banner is not there. It only renders the pink vertical banner in the screen, not in the framebuffer.
3. DRI driver is loaded, but not working (bug #99251)

Section "Device"
        Identifier "S3 Inc. SuperSavage IX/C SDR"
        Driver "savage"
        Option "VBERestore" "true"
        Option "hwcursor" "1"
        Option "DPMS" "on"
        Option "backingstore"
Option "BusType" "AGP"
Option "DmaType" "AGP"
Option "DmaMode" "None"
Option "AGPMode" "4"
Option "AGPSize" "16"
EndSection

Eugenia Loli-Queru (eloli) wrote :

Picture of the problem, see the pink banner here:
http://www.osnews.com/img/17627/ibm-t23-1.jpg
The video is over 800 pixels wide (480p is 853x480).

It seems that the S3 savage driver for Xorg has a hardcoded limitation regarding its Xv functionality. If a video is wider than 800 pixels wide, then the rest of the screen has a pink color. For example, my 480p video that is 853x480, has 53 pixels rendered as pink color on the right side of the screen, resulting in a vertical pink banner. Same happens no matter what media player I use, as it's an Xv driver bug, not a media player one. Some facts:
1. It only happens when Xv is used. Other transports work without this bug, but without Xv you don't want to watch HD video anyway because it is too slow without acceleration.
2. DRI driver is loaded.

Section "Device"
        Identifier "S3 Inc. SuperSavage IX/C SDR"
        Driver "savage"
        Option "VBERestore" "true"
        Option "hwcursor" "1"
        Option "DPMS" "on"
        Option "backingstore"
Option "BusType" "AGP"
Option "DmaType" "AGP"
Option "DmaMode" "None"
Option "AGPMode" "4"
Option "AGPSize" "16"
EndSection

Picture of the problem, see the pink banner here:
http://www.osnews.com/img/17627/ibm-t23-1.jpg
The video is over 800 pixels wide (480p is 853x480).

BTW, a sane default would be to increase the hardcoded overlay width to 1280x720, which is used in 720p HD video. Of course, videos can be bigger than the 720p resolution (e.g. 576p and 1080p), but the point is, I don't think that anyone with a Savage-based computer will try to playback anything bigger than 720p videos, because usually Savage is used on older machines and these older machines don't have the CPU power to render such big videos.

So I think that a sane limit could be 1280x720 (currently it seems to be 800x600), unless VIA surprises us and comes out with a really fast chipset that gets used in newer computers too. But as it stands now, the upper limit can safely be up'ed to 1280 pixels wide.

Giorgio Vazzana (mywing) wrote :

I can confirm this bug on a IBM Thinkpad T23 (2647-4MG).
"lspci | grep Savage" reports: "01:00.0 VGA compatible controller: S3 Inc. SuperSavage IX/C SDR (rev 05)"
Here is my Device section in /etc/X11/xorg.conf:

Section "Device"
        Identifier "S3 Inc. SuperSavage IX/C SDR"
        Driver "savage"
        BusID "PCI:1:0:0"
        Option "AGPMode" "4" #Setto il bus AGP a 4x
EndSection

The only difference is that I have DRI working, I've followed the procedure described in bug #88905.

MiDWaN (midwan) wrote :

Same thing here, on an IBM Thinkpad T23 as well.

My xorg.conf is the same as Giorgio Vazzana's above, with the exact same "lspci" output (I guess there's no need to paste a copy of them here as well).

Unfortunately nothing I've tried so far has helped. :(

the overlay hardware is limited to 1024x1024.

The overlay is actually limited to 800x600. The point is to offer support for 720p, in which case the source code of the driver must be made to support 1280x720.

Tormod Volden (tormodvolden) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Sorry it went unanswered for so long time.

Can you please try Gutsy Beta and see if the issue is still there? If so, please attach /var/log/Xorg.0.log and /etc/X11/xorg.conf
Try also without any xorg.conf.

Changed in xserver-xorg-video-savage:
assignee: nobody → tormodvolden
status: New → Incomplete
Eugenia Loli-Queru (eloli) wrote :

There is no point of giving you xorg.conf or upgrading that laptop to Gutsy. The bug is STILL there and is a driver limitation, not a xorg.conf misconfiguration. I have made a bug report about the same thing here: http://bugs.freedesktop.org/show_bug.cgi?id=10549 but NO ONE has fixed it there. It is up to Ubuntu people to fix the Savage overlays for 720p resolutions, because usually people with IBM laptops and Savage cards run Linux a lot. Please do not pass this bug to freedesktop.org, they won't fix it there because the savage driver is unmaintained there. It's up to Ubuntu guys. To reproduce it, just run an HD video to a Savage IBM laptop.

Eugenia Loli-Queru (eloli) wrote :

Can you please change the status from "uknown" to "confirm"? The limitation is STILL there, and the xorg.conf configuration you asked is this:
Section "Device"
        Identifier "S3 Inc. SuperSavage IX/C SDR"
        Driver "savage"
        Option "VBERestore" "true"
        Option "hwcursor" "1"
        Option "DPMS" "on"
        Option "backingstore"
Option "BusType" "AGP"
Option "DmaType" "AGP"
Option "DmaMode" "None"
Option "AGPMode" "4"
Option "AGPSize" "16"
EndSection

Tormod Volden (tormodvolden) wrote :

It's not true that savage is not maintained at freedesktop.org. They work on it as time and priority permits. I don't think "it's up to Ubuntu people" to fix it, upstream has better chance at doing it correctly, and Ubuntu can not prioritize video driver development. But we will of course try out and incorporate patches if somebody tracks it down.

I understand from the upstream bug report that the hardware is limited to 1024x1024 overlay, so supporting 1280x720 will not be possible. However, that doesn't mean there has to be a pink banner next to it. Unfortunately I am not able to reproduce on my own savage card.

Changed in xserver-xorg-video-savage:
assignee: tormodvolden → nobody
status: Incomplete → Confirmed
Eugenia Loli-Queru (eloli) wrote :

Did you try to playback a 720p trailer from Apple? Did it work for you without pink banners?

Tormod Volden (tormodvolden) wrote :

> Can you please change the status from "uknown" to "confirm"?

The status of the upstream task is automatically updated from the upstream bug.

> Did you try to playback a 720p trailer from Apple?

Can you please give a link to the smallest (in file size) movie that exhibits this problem?

Changed in xorg-server:
status: Unknown → Confirmed
Tormod Volden (tormodvolden) wrote :

My screen is only 1024, so I can not test this 1280 wide movie properly I guess. Nice film though :) I don't see any pink banners.

Bryce Harrington (bryce) on 2007-10-19
Changed in xserver-xorg-video-savage:
importance: Undecided → Medium
status: Confirmed → Triaged
Giorgio Vazzana (mywing) wrote :

I've installed Ubuntu Hardy 8.04 on my T23 and the problem is still present. But at least now DRI works out of the box.

Tormod Volden (tormodvolden) wrote :

These days it would be nice if someone can test on Ubuntu 9.10...

Giorgio Vazzana (mywing) wrote :

Interestingly, Eugenia says that this bug is fixed for her in Hardy:

http://eugenia.gnomefiles.org/2008/07/08/ubuntu-hardy-804-on-the-ibm-t23-thinkpad/

Still, I have had no luck...

Have you been able to playback videos >800px width without pink banner, Alex? I see there is some of the video showing through under the banner so I agree that the gfx card is capable of a 1024x1024 overlay. (I set mplayer to crop any video above 1024: -vf crop=1024.) But there is always this banner showing up which is some kind of more or less condensed 'fade to pink'.
I'm on a T23 as well. They are real die-hards ;)

(In reply to comment #3)
> [...] the source code of the driver must be made to support 1280x720.

Type xvinfo in the console and you will see the current overlay size limit. While that is what the driver says I believe the developer that the hardware is at its limits there. Ten years ago NTSC/PAL videos where the maximum video size you would see in real life I guess.

BTW: I added myself to CC and now all private email adresses show up as 'excluded'. I should really have read the documentation on bugzilla.

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Eugenia,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 99255

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 99255 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/99255

Changed in xserver-xorg-video-savage (Ubuntu):
status: Triaged → Incomplete
tags: added: needs-retested-on-lucid-by-june
Changed in xorg-server:
importance: Unknown → Medium

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? If so, please feel free to mark this bug as new. Thanks!

Eugenia Loli-Queru (eloli) wrote :

I do not have that laptop anymore. You will have to simply download a 720p movie and try it to reproduce it yourselves.

Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium

Created attachment 52160
photo of issue

Please attach files if possible. I'm glad that your image wasn't 404ing after
4 years, so I was able to upload it to the bug.

While the hardware is limited to 1Kx1K, is there something we can do to make
this fail more elegantly than with the "pink banner"?

Thank you for your bug report. If you can't test this any more I close this report or has another person also a hardware to test?

Changed in xserver-xorg-video-savage (Ubuntu):
status: Incomplete → Invalid
Giorgio Vazzana (mywing) wrote :

I still have the hardware and should be able to test. I can confirm that the problem is still present in Lucid.

Thank you for confirming this bug.

Changed in xserver-xorg-video-savage (Ubuntu):
status: Invalid → Confirmed

Eugenia Loli-Queru, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-savage/+bug/99255/comments/23 regarding you no longer have the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-video-savage (Ubuntu):
status: Confirmed → Invalid
Changed in xorg-server:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.