Regression in savage DRM support

Bug #99251 reported by Eugenia Loli-Queru on 2007-03-31
16
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-savage (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-savage

I got a new (secondhand) IBM laptop today and installed Feisty. It has the SuperSavage IX/C card in it and there is 3D support for it in Xorg. But unfortunately, in the last few weeks, the savage DRI driver is broken and only 2D works, not 3D. Here is what glxgears says:

eugenia@ibm-T23:~$ glxgears
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering

The kernel driver is loaded btw.
eugenia@ibm-T23:~$ lsmod | grep "savage"
savage 34048 1
drm 81044 2 savage

It seems to just be broken... Here is a similar debian bug report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=393266

Eugenia Loli-Queru (eloli) wrote :

Confirmed, after I did what it is suggested in the debian bug report, recompiling the latest driver, it worked. Please provide an updated driver.

Timo Aaltonen (tjaalton) wrote :

I have a T23 myself :)

Changed in xserver-xorg-video-savage:
assignee: nobody → tepsipakki
status: Unconfirmed → In Progress
Timo Aaltonen (tjaalton) wrote :

Ok, I've confirmed this with the latest updates. Since I don't update the laptop that often, I can verify that this worked with the updates from week ago. So, something during the past week broke this.

Changed in xserver-xorg-video-savage:
status: In Progress → Confirmed
Timo Aaltonen (tjaalton) wrote :

Eugenia: recompiling the driver didn't work for me.. are you sure you didn't do something else too?

Eugenia Loli-Queru (eloli) wrote :

Nope, I just followed the steps in the debian bug report. The driver got built and installed and ran depmod -a and then rebooted. Just make sure you haven't updated your kernel in the meantime because the driver only installs in the current kernel installed. For example, if you copied the .ko drivers in the wrong kernel version directories, you won't get 3D support because that kernel version is not currently loaded.

Timo Aaltonen (tjaalton) wrote :

Ok, so you compiled the kernel savage-module, but did you take a newer version from upstream? I'm a bit confused about this :) Maybe this bug should be reassinged to the kernel.

Eugenia Loli-Queru (eloli) wrote :

I downloaded the latest version of the savege code from freedesktop.org and recompiled. The ubuntu version of the driver doesn't seem to work.

Timo Aaltonen (tjaalton) wrote :

There's the xf86-video-savage, and mesa/drm in fd.o. Which one did you download?

There aren't that obvious changes in the driver, but the kernel module should already be a recent one (grabbed from 2.6.21-rc4 AFAIK)

Eugenia Loli-Queru (eloli) wrote :

As I said, I just followed these steps:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=393266;msg=37;att=0
and made sure I copied the two drivers on my latest kernel. It was savage.ko and drm.ko.

Timo Aaltonen (tjaalton) wrote :

Ok, I'll give up, maybe the kernel team has ideas why it doesn't work now. The drm code should be recent, and there hasn't been updates to the savage-code for a while.

Changed in xserver-xorg-video-savage:
assignee: tepsipakki → ubuntu-kernel-team
Tormod Volden (tormodvolden) wrote :

Judging from Alex' answer here: http://bugs.freedesktop.org/show_bug.cgi?id=10499#c9 , I understand there have been some drm changes that might affect savage even if the savage* files have not been changed.

giorgio (giorgio11) wrote :

Hi everyone, I was having the same problem on my t23, but I found a different solution(a recompile of the latest drm and savage sources wasn't helpful).
Following the instructions at https://systemausfall.org/wikis/howto/Debian_on_IBM_T23 ,
section "dri", I found out that the file savage_dri.ko was installed in /usr/lib/dri , but was expected to reside in /usr/X11R6/lib/modules/dri/ .
Fixed with a symlink, and now everything is ok!
Well, apart from the usb-dead-on-resume bug... :-(
Hope it may help someone.

Tom Shaw (firephoto) wrote :

I've had this problem on and off for a few weeks now. Seems to coincide with kernel updates possibly but that could be just the associated reboot.

What I found out after some testing today was that if I reboot it would still happen but if I powered down (halt), then started the system then everything was working fine. I remember a recent bug or discussion about warm/cold reboots and a kernel change so maybe this could be related or it's just the actual powering down that is clearing something.

When the problem occurs the desktop starts fine (kde) but anything that paints to the screen is extremely slow and Xorg cpu useage goes way up.

This is on a Thinkpad T20 with the savage drivers.

Matt Zimmerman (mdz) wrote :

Rejecting xorg task; the Debian bug seems to confirm this is a kernel DRM issue

Changed in xserver-xorg-video-savage:
status: Unconfirmed → Rejected
Eugenia Loli-Queru (eloli) wrote :

Matt, why did you reject the whole bug? Why didn't you simply assigned it to the kernel team? Please re-open the bug and assign it to the right people.

Tormod Volden (tormodvolden) wrote :

Eugenia, please look closely at the "Affects" and "Status" fields...

Joachim Frieben (jfrieben) wrote :

This is a duplicate of bug #88905. There you also find the reference to the upstream bug http://bugzilla.kernel.org/show_bug.cgi?id=7767 that I had reported back in January 2007.

yoyoliyang (yoyoliyang) wrote :

you can do it like this:

sudo apt-get autoremove xserver-xorg-video-savage

then make your "sources.list" form "feisty" to "edgy"
now "apt-get update",and then install the savage driver from edgy's sources.list

sudo apt-get install xserver-xorg-video-savage

ok,restart your X,hope everything is ok.good luck!

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.