Kubuntu 9.04 + Radeon X1300 - No dual monitor option in system settings (dual-head)

Bug #367776 reported by Ped on 2009-04-27
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-radeonhd (Ubuntu)
Undecided
Unassigned

Bug Description

I have dual head ATI Radeon X1300 card with two LCDs, before 9.04 there was always proprietary driver offered after installation (fglrx), which did work well with dual head.

With 9.04 there's no proprietary driver (and according to http://ubuntuforums.org/showthread.php?t=1123631 there never will be), so I'm probably stuck to OSS drivers, which is actually a change I like (I don't miss the 3D performance most of the time I use this PC).
But I'm also without any dual head support in system settings (I have still to do research if it's possible to tweak it at least trough command line), which renders the Kubuntu 9.04 practically unusable for me.

This is critical missing feature for me, just as same as missing keyboard or having no graphics display at all. (I know 1 LCD is better then 0 factually, but in the end it's same, at least in this particular case for me)

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82P965/G965 Memory Controller Hub [8086:29a0] (rev 02)
     Subsystem: Intel Corporation Device [8086:514d]
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV515 PRO [Radeon X1300/X1550 Series] [1002:7142]
     Subsystem: ASUSTeK Computer Inc. Device [1043:0142]

affects: ubuntu → xserver-xorg-video-radeonhd (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi ped,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-radeonhd (Ubuntu):
status: New → Incomplete
Ped (ped) wrote :
Ped (ped) wrote :
Ped (ped) wrote :

The xorg.conf is without any change, just like the Kubuntu 9.04 install process created it.

I'm discussing this problem at forums too, I have found one similar thread at:
http://phoronix.com/forums/showthread.php?t=16460

The suggested 'xrandr --output DVI-0 --right-of VGA-0 --auto' leads to:
xrandr: screen cannot be larger than 1280x1280 (desired size 2560x1024)
(I think I will have to edit xorg.conf to get bigger virtual resolution to make xrandr to work, I will look into it soon)

Another interesting note from that thread related to this bug is:
"... KDE4 seems to remember the configuration so you just need to configure it once. And BTW if you open Display Settings it will revert to cloning"

So even if xrandr workaround will work, it would be still nice to get Display settings fixed anyway.

Ped (ped) wrote :
Download full text (3.3 KiB)

I did change xorg.conf for bigger virtual resolution, now the xrandr doesn't complain about small screen, but I run into different problem.
Almost everything I ask xrandr to do with one output, it does it with both of them.
Here are some examples and additional information about xrandr:

xrandr -v
Server reports RandR version 1.3

xrandr -q
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 2560 x 1024
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024 60.0*+ 75.0 72.0 60.0*
   ... some more modes ...
DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024 60.0*+ 75.0 72.0 60.0*
   ... some more modes ...

xrandr --verbose --output DVI-0 --pos 200x0
screen 0: 1480x1024 432x298 mm 86.99dpi
crtc 0: 1280x1024 60.0 +200+0 "DVI-0" "VGA-0"
* does move BOTH screens right by 200px

xrandr --verbose --output DVI-0 --off
crtc 0: 1280x1024 60.0 +0+0 "VGA-0"
* the single command which actually works only at desired output, and NOT at both, this one does switch the LCD at right off, and the LCD at left remains ON

Any other variation trying to set VGA-0 and DVI-0 to have correct mode+position to cover whole virtual screen leads to both LCD show either left or right portion of virtual screen, but always the same one, i.e. cloned view.

Final puzzling bit of information for me:
xrandr --verbose -q
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 2560 x 1024
VGA-0 connected 1280x1024+0+0 (0x4d) normal (normal left inverted right x axis y axis) 376mm x 301mm
        Identifier: 0x4b
        Timestamp: 438515
        Subpixel: no subpixels
        Clones: DVI-0
        CRTC: 0
        CRTCs: 0 1
       ... rest (panning and stuff, transform, EDID_DATA, list of modes) is very likely not interesting in this case...
DVI-0 connected 1280x1024+0+0 (0x4d) normal (normal left inverted right x axis y axis) 376mm x 301mm
        Identifier: 0x4c
        Timestamp: 438515
        Subpixel: no subpixels
        Clones: VGA-0
        CRTC: 0
        CRTCs: 0 1
        ...

* the puzzling bit is "Clones:" line. This doesn't sound right.

After xrandr --output DVI-0 --pos 200x0 the verbose query reveals:
Screen 0: minimum 320 x 200, current 1480 x 1024, maximum 2560 x 1024
VGA-0 connected 1280x1024+200+0 (0x4d) normal (normal left inverted right x axis y axis) 376mm x 301mm
        Identifier: 0x4b
        Timestamp: 438515
        Subpixel: no subpixels
        Clones: DVI-0
        CRTC: 0
        CRTCs: 0 1
        Panning: 0x0+0+0
        Tracking: 0x0+0+0
        Border: 0/0/0/0
        ...
DVI-0 connected 1280x1024+200+0 (0x4d) normal (normal left inverted right x axis y axis) 376mm x 301mm
        Identifier: 0x4c
        Timestamp: 438515
        Subpixel: no subpixels
        Clones: VGA-0
        CRTC: 0
        CRTCs: 0 1
        Panning: 0x0+0+0
        Tracking: 0x0+0+0
        Border: 0/0/0/0

IMHO the driver is forcing both outputs to be clone of each other and requires either further xorg.conf options (maybe definitions o...

Read more...

Ped (ped) wrote :

BTW: Installing *fglrx* packages is deadly in this case, after reboot there's black screen in graphics mode with some sparse color dots in top area and system does completely freeze, not even Ctrl+Alt+Del works. (sort of expected, as fglrx should not work with my X1300 card and new xorg, still the way how it does not work is ugly .. and probably dangerous for ordinary user, he would have very hard time to recover)

Ped (ped) on 2009-04-29
Changed in xserver-xorg-video-radeonhd (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) on 2009-05-01
Changed in xserver-xorg-video-radeonhd (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-05-06
description: updated
Ped (ped) wrote :

I don't think this is duplicate. From the #362061: "I am able to set a big desktop in gnome using the same driver"
If that would be the case, I would be able to configure it by hand trough xorg.conf and xrandr, right?

I think #362061 is UI KDE4 bug, while my problem is somewhere between driver, xrandr and xorg.

Bryce Harrington (bryce) on 2009-09-02
tags: added: kubuntu
tags: added: jaunty
Ped (ped) wrote :

I'm testing it with 9.10 now.

With default xorg.conf I still get:
"xrandr: screen cannot be larger than 1280x1280 (desired size 2560x1024)"

After changing xorg.conf, the "xrandr --output DVI-0 --right-of VGA-0 --auto" *WORKS*.

Visiting System settings -> Display will reconfigure X back to cloned view. (and of course there's no way to enable dual head back, it's completely broken for me)

After restart I get the cloned view again (as expected), I wonder what's the "proper" way to configure this automatically, help me in forums if you know.

Summary:
+ driver looks now functional
- KDE4 system settings keeps insisting I don't have dual head configuration, Identify outputs identifies both DVI-0 and VGA-0 to be on the same LCD and the other one is cloned. It also resets any hand made xrandr changes.

Ped (ped) wrote :

Testing Kubuntu 10.04 RC (386 desktop CD image), live session behaviour:

driver [OK]

KDE4 system settings - Display:
default: cloned view [OK ? I would prefer dual view, but cloned is probably more safe for live session.]
after changing position of the secondary output from cloned to "Right of" and clicking Apply, it doesn't set up. [BUG]
after changing position of secondary + refresh rate (from 72Hz to Auto) and clicking Apply, it does set up dual monitor desktop [OK]
(looks like the position-only change gets somewhat ignored by apply)

The second menu in display options (something about big virtual desktop over several monitors, but can't recall the exact name) still insists I don't use such setup (although it's already working well). Anyway, I find everything important already in the first display settings menu, so I'm not sure what's that second thing good for. Some unimplemented feature of upstream or something obsolete? Or should it do something interesting for me and it's bug?

Ped (ped) wrote :

summary: it works sufficiently well for me to be used, although some polish wouldn't hurt. But for me this case is closed.

tags: added: iso-testing
damahevi (damahevi) wrote :
Download full text (3.6 KiB)

Same Problem with Kubuntu 10.04 Lucid Lynx AMD64 default install:

Summary: switching off KMS with boot parameter and custom xorg helped (see below), fix for KMS and dualhead detection needed.

Detail:

In System Settings -> Display -> Multiple Montors
I got the message that on my system I don't have multiple monitors. However I see the cloned view.
If I tree to change the settings from clone to left or right display gets totally scrambled (i.e. many coulored lines and noise), only sysrq-k helped (who disabled ctrl-alt-bsp per default !?).

Then I tried xrandr:
xrandr --output DVI-0 --right-of VGA-0 --mode 1280x1024
with the same result scrambled display!

When I used a customized xorg.conf it seemed to wrok but kdm restarts itself after about 10 minutes!!!
The only log-entries I found were:
kdm.log:QFileSystemWatcher: failed to add paths: /tmp/0659673494/.config/ibus/bus
kdm.log:Bus::open: Can not get ibus-daemon's address.
kdm.log:IBusInputContext::createInputContext: no connection to ibus-daemon

So I changed the file /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

and after a sudo grub-update everything works!

There seems to be a problem with raeon driver and KMS with dual-head display!

My xorg.conf:
Section "Device"
        Identifier "Configured Video Device"
        Option "monitor-VGA-0" "VGA"
        Option "monitor-DVI-0" "Extern"
EndSection

Section "Monitor"
        Identifier "VGA"
        Option "PreferredMode" "1280x1024"
        Option "Right Of" "Extern"
EndSection

Section "Monitor"
        Identifier "Extern"
        Option "PreferredMode" "1280x1024"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "Configured Video Device"
        DefaultDepth 24
        SubSection "Display"
            Depth 24
            Virtual 2560 1024
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier "Default Layout"
        Screen "Default Screen"
EndSection

Excerpt of lspci -vvv:

01:05.0 VGA compatible controller: ATI Technologies Inc RS480 [Radeon Xpress 200G Series]
        Subsystem: Hewlett-Packard Company Device 3009
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 64 (2000ns min), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 17
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at cc00 [size=256]
        Region 2: Memory at fdaf0000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at fda00000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel modules: radeon

01:05.1 Display controller: ATI Technologies Inc Radeon Xpress Series (RS480)
        Subsystem: Hewlett-Packard Company Device 3008
        Control: I/O- Mem- BusMas...

Read more...

Timo Aaltonen (tjaalton) wrote :

there is no -radeonhd in the archive anymore, closing the bugs.

Changed in xserver-xorg-video-radeonhd (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers