[M76] Gnome desktop resolution incorrect

Bug #152179 reported by Wolf Rogner on 2007-10-13
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-radeonhd (Ubuntu)
Undecided
Unassigned

Bug Description

I have a HP notebook 8510p with a WSXGA+ (1680 x 1050) display.

Gnome finds a resolution of 1400 x 1050.

If I select a 1680x1050 LCD display the max. adjustable resolution still is 1400 x 1050.

Using Gnome screen resolution adjustments does not work.
Using xorg.conf manual adjustment does not work (as settings are simply ignored)

Is there a fix for this?

unggnu (unggnu) wrote :

Please provide more information like lspci output, your xorg.conf or your Ubuntu version.

Wolf Rogner (war-rsb) wrote :

Ubuntu 7.10 rc

Linux wb 2.6.22-14-generic #1 SMP Wed Oct 10 05:28:36 GMT 2007 x86_64 GNU/Linux

Wolf Rogner (war-rsb) wrote :

lspci output

Wolf Rogner (war-rsb) wrote :

xorg.conf

Wolf Rogner (war-rsb) wrote :

Played around the whole day.

On my last reboot Gnome came up with a dialog saying:

"The X system keyboard settings differ from your current GNOME keyboard settings.

Expected was model "pc105", layout "us" and no options, but the the following settings were found: model "pc105", layout "de" and no options.

Which set would you like to use?"

Use X settings | Keep Gnome settings

Strange:

- xorg.conf has the german keyboard layout set (see attached xorg.conf)
- Gnome Keyboard Preferences have the German keyboard selected (no other kbd installed)

Another observation:

Changing the screen type to LCD 1680x1050 wide screen allowed me to select Resolution 1680x1050. Restart of gdm did not take these settings. In the Preferences -> Screen Resolution 1400x1050 was the only selectable resolution (even after changing the global screen parameters)

In gconf-editor the screen resolution is 1680x1050 (/desktop/gnome/screen/default/0/resolution = 1680x1050, rate=65)

I think there is something out of sync.

My testing showed that adjustments to xorg.conf did not matter at all.

unggnu (unggnu) wrote :

Have you checked out the fglrx-driver? Your card doesn't seem to be supported through the open source driver.

Wolf Rogner (war-rsb) wrote :

I have tried to install fglrx to no avail.

The machine resorts into the gdm recovery mode and sets the vesa drivers.

Fine to learn that my card is not supported. Its in a notebook and cannot be replaced easily ;-)

unggnu (unggnu) wrote :

Check out this Howto http://wiki.ubuntuusers.de/ATI-Grafikkarten/fglrx or http://wiki.ubuntuusers.de/ATI-Grafikkarten/fglrx/Manuelle_Treiberinstallation if the first one doesn't work. Maybe it can help you to get your card working with proprietary driver. Otherwise you have to wait until a working driver is developed. Vesa supports 4:3 only afaik.

Changed in xserver-xorg-video-ati:
status: Incomplete → New
Wolf Rogner (war-rsb) wrote :

Thanks for the link. I have checked these links and they describe the default way to install fglrx. But as I mentioned in my previous post: This does not work.

I presume you are right with: My card is not recognized.
So: How can I make it get recognized.

There is another issue and I think this is more serious: Gnome and Xorg are out of sync. I used to be able to set screen and card configurations in xorg.conf. I am not any more.

Maybe it has something to do with the module that tries to be smart. It always reverts to 1400x1050 / vesa.

Tormod Volden (tormodvolden) wrote :

Your card should work fine with the open-source driver. Only R5xx based cards and above need any proprietary driver.

Try the "ati" driver without any xorg.conf and attach the Xorg.0.log. But first make sure you have properly removed any fglrx stuff.

Changed in xserver-xorg-video-ati:
assignee: nobody → tormodvolden
status: New → Incomplete
Wolf Rogner (war-rsb) wrote :

Excuse me if my tone gets rough but I have tested Ubuntu for 7 days without any break

1. Gnome ignores whatever you write into xorg.conf
2. If Gnome cannot set the resolution it falls back into some catchup routine to adjust the settings to some failback
3. There is an xorg.conf attached somewhere above

What I tested:

1. I removed any ati proprietory drivers (that would not work anyway)
2. I deleted any xorg.conf and any Xorg.0.log (and Xorg.9.log in the process)
3. I set the screen parameters in the control panel Screens and Resolutions
-> Driver: ati (sets it to Mach 8,...)
-> Screen: 1680x1050 Widescreen
-> Screen Resolution: 1680x1050@60
4. restarted X (ctrl-alt-back)
Screen blinks three times
5. Ran through the catchup again
-> Set all parameters again to the above settings
Screen blinks again 3 times
Logon screen
Screen Resolution 1400x1050

xorg.conf attached (the one used with current 1400x1050 res)
xorg.conf.1 attached (the one created after setting res in control panel)
xorg.conf.failsafe (created sometimes during the process)
Xorg.0.log attached
Xorg.0.log.old attached

There is another thing anoying me: My keyboard setting is GERMAN (de). The us keyboard is ignored.

This leads me to the conclusion:

1. xorg.conf is not honored by Gnome
2. Settings are stored somewhere else, just where
3. My card should work fine it just doesn't !!!

I think this should be handled by someone dealing with Gnome. They should know where the store their settings and how to get the card (if at all) to set to the right resolution.

Wolf Rogner (war-rsb) wrote :
Wolf Rogner (war-rsb) wrote :
Wolf Rogner (war-rsb) wrote :
Wolf Rogner (war-rsb) wrote :
Tormod Volden (tormodvolden) wrote :

Keyboard and resolution can be set in xorg.conf, but they will be overridden by Gnome if it has settings for it. Try gconf-editor to hunt down these settings.

It would be important to know if the driver itself finds (and uses) the right resolution: restart X without any xorg.conf and log in to a Failsafe Terminal session.

Wolf Rogner (war-rsb) wrote :

I know we are all exhausted.

I do not need to change my keyboard settings. They are correct.

I always fall into failsafe terminal. I never get anything else.

Gnome has set 1680x1050 but does not show it. I read the documentation on the web but they are inaccurate to say the least.

Is there any additional information I can provide other than the ony I already have?

Tormod Volden (tormodvolden) wrote :

I don't understand. You "always fall into failsafe terminal" so why do you talk about gnome then? (Maybe I am exhausted yes :) )

Changed in xserver-xorg-video-ati:
assignee: tormodvolden → nobody
status: Incomplete → New
Wolf Rogner (war-rsb) wrote :

There is a catchup routine in Gnome that generates a failsafe Gnome session. This is what I talk about. I did not know there was anything else

How can I get into what you need me to check?

Tormod Volden (tormodvolden) wrote :

At the log-in window click "Select Session" in the bottom left menu, and choose Failsafe Terminal (not Failsafe Gnome).

Wolf Rogner (war-rsb) wrote :

I delete the xorg.conf and restart the X server.

The catchup dialog:

Ubuntu is running in low-graphics mode
Your screen and graphics card could not be detected correctly.
To use higher resolutions, visual effects or multiple screens,
you have to configure the display yourself
[ ] Always run in low-graphics mode
[Configure...][Shut Down][Continue]

I continue (at this time there is a xconf.org and xconf.org.failsafe created. I get 1400x1050)

I get a dialog confirming the failsafe terminal which shows in the right bottom corner of the screen.

xorg.conf as uploaded above.

I just read about xrandr

This utility returns

Screen 0: minimum 1400 x 1050, current 1400 x 1050, maximum 1400 x 1050
default connected 1400x1050+0+0 0mm x 0mm
   1400x1050 60.0*

Is there a chance to add a different screen resolution?

Tormod Volden (tormodvolden) wrote :

In your logs I can see you are using the vesa driver. The vesa driver can not use 1680x1050 (it's not part of the VESA specification). Please try the "ati" driver and attach new logs.

Changed in xserver-xorg-video-ati:
status: New → Incomplete
Wolf Rogner (war-rsb) wrote :

OK, lets just calm down and start over:

1. I did set the driver to ati (there is a bug in the settings panel as well, the dropdown and listbox are not in sync)
2. It always reverts to failsafe and use vesa drivers. There is no other behaviour.
3. The logs are always the same. You have them.

Can you try to repeat the steps you think I take to set the drivers? Maybe this will clarify where we are apart.

Tormod Volden (tormodvolden) wrote :

I would like to see the log where the "ati" driver tries to start. Which one is that?

Please do not use the gnome tools (they will make an xorg.conf), just delete the old xorg.conf. After restarting X, and once the failsafe things have started a new vesa session, the ati log will be Xorg.0.log.old I think.

Wolf Rogner (war-rsb) wrote :

You are wrong. There is no log file for the ati driver. The screen jumps immediately to the 1400x1050 resolution.

I think we give up on this.

Maybe you are the wrong person to bother in the first place. I should get acquainted to how X, gdm and Gnome interact. Maybe then I understand where the problem lies.

Thanks

Tormod Volden (tormodvolden) wrote :

I apologize, I must have mixed up some bug reports, I was sure you had a different card. Actually you never said what card you have. Can you please run:
 lspci -nn|grep VGA

Tormod Volden (tormodvolden) wrote :

Looking closer at the lspci output you already provided I think you have a card with PCI ID 1002:9581
This card is not recognized by the ati driver, which explains it's picked up by the vesa driver instead. The card is not even in the pci.ids file. Can you give more information about this card?

Tormod Volden (tormodvolden) wrote :

Google says: AMD/ATI Radeon HD 2600 Mobility (M76)
You can try the xserver-xorg-video-radeonhd package from universe, but it's kind of experimental and no DRI/3D yet.

Wolf Rogner (war-rsb) wrote :

No apologies, you found the card, you found that its not in pci.ids and you found that xorg-video-radeonhd exists.

Thats the good news.

The bad news is, I tried them, they are installed and still don't work. Thats not experimental as I cannot even start with any experiments.

You can use the drivers from AMD (http://ati.amd.com/support/drivers/linux64/linux64-radeonhd.html) but they lack power management (the machine freezes on suspend to RAM and hibernate), don't work with compiz and are extremely sluggish.

I use ATI's drivers for working but would like to have the open source version that is maintained in Ubuntu.

Now that we have that settled, lets reiterate what we know:

If there is a problem with the video driver X (or is it Gnome) reverts to a default setting that offers maximum screen resolution by using a vesa driver. I suspect that the driver reports an error on load that triggers the fallback.

So, how can I help you find the error message.

Here is the Xorg.0.log from the ATI proprietory driver. Maybe you can make use of this and find some differences.

Wolf Rogner (war-rsb) wrote :

And here the corresponding xorg.conf (created by ATI installer)

Wolf Rogner (war-rsb) wrote :

Comparing the two Xorg.0.log files there are several things that catch my attention:

1. (WW) "dbe", "dri", "glx", "vbe" will not be loaded unless you've specified it to be loaded elsewhere. ?
In the ATI log these modules are loaded successfully

2. After the RECORD extension ATI loads fglrx and the Ubuntu loads vesa
Why? The xorg.conf states fglrx to load

3. After thy synaptics drivers, ATI loads Video4Linux drivers and starts the proprietory ATI driver, Ubuntu launches the vesa driver

4. Somewhere later the vesa driver decides first not to use 1400x1050 then it chooses to do so. This is a vesa built-in mode.

Does this make sense for you?

Tormod Volden (tormodvolden) wrote :

The vesa driver does not support wide-screen resolutions. 1400x1050 is probably the highest resolution provided by the vesa standard on your hardware.

I have uploaded the very latest version of the free radeonhd driver to my personal package archive:
 https://launchpad.net/~tormodvolden/+archive
Feel free to try it out once the debs are built. But there will be no DRI and hence no compiz with them AFAIK.

Tormod Volden (tormodvolden) wrote :

Re 1. vesa can not use dri or glx extensions
Re 2/3. the Xorg server loads fglrx if specified in xorg.conf. If not, it checks all its drivers for support for your card. Only vesa takes up the challenge. ati does not recognize the card. If you have radeonhd installed, I think it will be picked (before vesa).
Re 4. the Xorg server first checks for valid modes with a strict filter. Since nothing passes through, it checks again with a less strict filter.

Wolf Rogner (war-rsb) wrote :

I had xserver-xorg-video-radeonhd 0.0.1+git20070918-1ubuntu1 installed.

It does not get detected by the Xorg Server.

Yours does not satisfy dependencies.

I will try to replace your new version with the one I have installed on my machine tomorrow.

Wolf Rogner (war-rsb) wrote :

I tried your driver by copying it into /usr/lib/xorg/modules/drivers (hopefully its the right place).

On boot the machine still behaves like I found with all other settings above.

I might deinstall everything else from ati to see if it finds the driver then.

Tormod Volden (tormodvolden) wrote :

xserver-xorg-video-radeonhd_0.0.1+git20071020-0ubuntu0tv1_i386.deb installed without any dependency issues on my clean Gutsy install. Since I don't have any radeonhd card, I can not test it though :) Can you explain (or copy-paste) what dependency trouble you have?

Wolf Rogner (war-rsb) wrote :

In Gdebi under Status:

"Error: Dependency is not satifiable: xserver-xorg-video-radeonhd"

Could it be that debugging symbols are required (which I doo not have installed)?

How can I provide you with more feedback? The Xorg.?.log files are not a good source it seems.

Tormod Volden (tormodvolden) wrote :

I guess you are trying to install the -dbg package. It is an add-on to the normal package, which you should install first. Or both at the same time with "sudo dpkg -i xserver-xorg-video-radeonhd*.deb"

Changed in xserver-xorg-video-ati:
assignee: nobody → tormodvolden
Tormod Volden (tormodvolden) wrote :

Can you please try the new -radeonhd 1.1.0 driver? Or even the newest -ati driver from https://wiki.ubuntu.com/XorgOnTheEdge

Timo Aaltonen (tjaalton) wrote :

Vesa doesn't support widescreen resolutions, but now this bug has changed to "does it work with radeonhd".

Wolf Rogner (war-rsb) wrote :

Sorry, I cannot contribute to this anymore. I got the machine replaced with one running a NVidia card.

This solved several issues I had (sleep mode not working, no sound after wakeup, no compiz effects, weak graphics performance, no external monitor, ...)

No sweat, no hassle.

Can only recommend it.

Timo Aaltonen (tjaalton) wrote :

Ok, although the sound & powersaving issues have nothing to do with ati/nvidia :)

Closing the bug since it cannot be debugged further.

Changed in xserver-xorg-video-radeonhd:
assignee: tormodvolden → nobody
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers