9.04 PPC: r128 does not detect ATI Rage 128 on G3 iMac

Bug #400864 reported by Thomas Ribbrock
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-r128 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-r128

Ubuntu 9.04PPC "out-of-the-box" fresh install on an iMac DV 400MHz (G3, slot-loader):

As the default installation results in 8bit only display (256 colours, PseudoColor mode), I have tried to force the usage of the r128 driver using a minimal xorg.conf (see attachments). This fails, as the r128 driver fails to detect the card (see attached Xorg.0.log). I could not see any difference between including the "disable 'dri'" statement and leaving it out - in the log, it looks like this statement is actually ignored/overridden by the X server.

If I run strace against "startx" (strace -fo xserver.trace startx), I can see that the driver accesses the AGP bus and both PCI busses (see also attached output of "lspci -vvnn").

Under 8.04, the same driver works fine on the same hardware.

Note: This bugreport supersedes https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-r128/+bug/398204 !

Revision history for this message
Thomas Ribbrock (emgaron+ubuntu) wrote :
Revision history for this message
Thomas Ribbrock (emgaron+ubuntu) wrote :

Logfile when trying to start X with r128 driver

Revision history for this message
Thomas Ribbrock (emgaron+ubuntu) wrote :

Result of running strace against startx

Revision history for this message
Thomas Ribbrock (emgaron+ubuntu) wrote :

Output of lspci -vvnn

Revision history for this message
Thomas Ribbrock (emgaron+ubuntu) wrote :

For completeness: dmesg

Revision history for this message
Thomas Ribbrock (emgaron+ubuntu) wrote :

Partial SOLUTION:

xorg.conf must contain the line

BusID "PCI:0:16:0"

in the "Device" section - this will detect the ATI Rage. I had not tried this as I assumed that the lspci (hex-)value should be correct, but apparently, xorg expects decimal.
Hence, the installer needs to somehow come up with this.

Unfortunately, the r128 driver now crashes. I will open a new bug for *that* problem.

Bryce Harrington (bryce)
Changed in xserver-xorg-video-r128 (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce)
tags: added: jaunty
Revision history for this message
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xserver-xorg-video-r128 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Revision history for this message
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-r128 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers