[Xubuntu][Intrepid] wrong resolution with ATI Rage Mobility M3 AGP 2x (rev 02)

Bug #284309 reported by sebastian-s on 2008-10-16
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-r128 (Ubuntu)
Medium
Unassigned

Bug Description

since hardy and now in intrepid beta I can't get a higher resolution than 800x600 to work on my xubuntu system.

the machine is a old Dell Inspiron 4000 with a ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02) graphics card according to lspci.

When still on hardy I tried to change the resolution in various ways

sudo dpkg-reconfigure xserver-xorg
sudo displayconfig-gtk
sudo X -configure

I tried to add VGA=791 but nothing worked so far.

From what I found out this particular graphics card is supported by the open source driver so I think it is a detection problem

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Could you please also try to run without any /etc/X11/xorg.conf and let Xorg autodetect your display and video card? Please also attach the /var/log/Xorg.0.log from this attempt.

For more information about debugging xorg issues, please see https://wiki.ubuntu.com/X/Debugging.

Thanks in advance.

sebastian-s (sebastian-s) wrote :

hi, I uploaded them as requested

/etc/X11/xorg.conf http://paste.ubuntu.com/63141/ or attached

sebastian-s (sebastian-s) wrote :

there is also a Xorg.9.log is this one needed as well?

sebastian-s (sebastian-s) wrote :

so, I pulled in all latest updates from the RC and renamed conf and log file.

Attached is the log file after a Xorg autodetect. Somehow there is no new Xorg.conf only the old one I renamed?

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

In Intrepid 8.10, Xorg uses an autoconfiguration that no longer writes the xorg.conf file, to the best of my knowledge. So, yes, I think that not having xorg.conf is normal under auto detect.

Changed in xserver-xorg-video-ati:
importance: Undecided → Medium
status: Incomplete → Confirmed
Jaime Carpenter (j.carpenter) wrote :

I also have a Dell Inspiron 4000 Laptop with the same ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02) video card and low res issue. I want to enable 1024x768 but I'm stuck with 640x480 or 800x600. Desktop effects would also be nice, but I'll settle for 1024x768.

Jaime Carpenter (j.carpenter) wrote :

I forgot to mention, I'm running Hardy 8.04.1.

Bryce Harrington (bryce) wrote :

I've written a couple pages for configuring and troubleshooting incorrect resolution issues which may be of some value:

   https://wiki.ubuntu.com/X/Config/Resolution
   https://wiki.ubuntu.com/X/Troubleshooting/Resolution

If the workarounds help you, I'd greatly appreciate it if you could fill in Xubuntu-oriented versions of the workarounds.

Meanwhile, please attach the output from the following commands:

 # ddprobe
 # get-edid | parse-edid (from the read-edid package)
 # xrandr --verbose

Changed in xserver-xorg-video-ati:
status: Confirmed → Incomplete
TenLeftFingers (tenleftfingers) wrote :

I have exactly the same laptop and problem with my resolution. I'm attaching the files Bryce asked for and I'll get back on the workarounds asap.

sebastian-s (sebastian-s) wrote :

amazing - my output from the commands looks 100% the same - seems like the computers are really the same spec.

I had a look at the wiki pages. Firstly I needed to install 'read-edid' and 'xresprobe'

Looking at the ddcprobe output I figured I don't need to add a mode

Next I wanted to change the mode with 'sudo xrandr --output VGA --mode 1024x786' but as I was not sure if it is VGA or VGA-0 I tried a few. Nothing changed and I could not switch to higher res with <alt><ctrl>+ either.

How to I find the right output?
Should I still attach the output of the commands?

Jaime Carpenter (j.carpenter) wrote :

To add some more information about my issue this is using Hardy 8.04.1 running on a Dell Inspiron 4000. I am able to run 'sudo displayconfig-gtk' and select LCD 1024x768 and test it successfully. Yet when I log out and restart X, the resolution is back to 800x600 and the monitor is set back to plug-n-play. I don't understand why the successful test using displayconfig-gtk is not saved. Please let me know if I need to post any config data.

Åke Nordin (moose-netia) wrote :

I've just put 8.10/intrepid on an old Dell Inspiron 4000 (HCXD50J, but with 512M/120G) that has an ATI RAGE Mobility 128 W/2xAGP, 8MB. I'ts not going to be my regular workhorse, I'm just going to test some LAMP stuff on it, so I might need some 48 hours to test things (but I like this Ubuntu stuff more and more... 8^). According to my Xorg.0.log, it doesn't accept any recognized video modes directly but fall back to the VBIOS specified ones, of which 800x600 is the largest.

The recent /var/log/Xorg.0.log and bootstrap.log is attached in a tarball, together with the output of dmesg and some apt-cache policy output for the packages I thought were interesting.
The only changes to the base system since install is the addition of apache2 and php through synaptics (I haven't even added mysql yet, it might end up on another box).

moose@ares:~$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

Åke Nordin (moose-netia) wrote :
Åke Nordin (moose-netia) wrote :

"I shall always report bugs with the standard configuration, not a botched one" rinse, repeat six more times.

Now the /etc/X11/xorg.conf is as installed, and the error remains the same. I've attached the /var/log&Xorg.0.log with untouched xorg.conf to protect the sanity of the readers.

Sorry for the confusion.

Åke Nordin (moose-netia) wrote :

The problem with my Dell "HCXD50J" seems to be related to the autoconfiguration of X getting very conservative acceptable values for hsync. I wonder if the probing failures (i. e. get-edid reporting errors and flagging the result as untrustworthy) results in the upper limit of hsync being as low as 37.90 kHz?

Anyway, adding HorizSync 31.50-50.00 to the "Monitor" section of xorg.conf resolved the issue for me. diff -u of xorg.conf(-orig) and new Xorg.0.log attached in new compressed tarball which unpacks adjacent to the old one.

Mike (e-launchpad-romram-se) wrote :

It is my experience that the comments above is the solution to the problem. It was for me at least. Is it possible to mark this bug as solved, that would help coming readers I think.

sebastian-s (sebastian-s) wrote :

I can confirm that adding 'HorizSync 31.50-50.00' to the "Monitor" section of xorg.conf resolved the issue for me.
I added the line to a blank xorg.conf, hit <ctrl><alt><backspace> and X started with 1024x768

Now is this a general 'fix' or does it only work for some computers?

sebastian-s (sebastian-s) wrote :

the suggested fix worked for me as well so I changed it to confirmed. Not sure if it should be changed to 'fix committed'.

Changed in xserver-xorg-video-r128:
status: Incomplete → Confirmed
sebastian-s (sebastian-s) wrote :

I had another test on a different old Dell notebook where I had the same screen issues (no higher res by autodetect) with Xubuntu.

This time the fix/trick did not work, or it did not yield the desired result. I added the line to xorg.conf but after restarting X the screen went berserk. It looked like on CRTs when the resolution is not supported.

Could it be that the frequencies where not supported by the display? how can I find out?

Tormod Volden (tormodvolden) wrote :

If autoconfiguration using EDID can not be done, the server will default to narrow sync ranges (30-37). In earlier version, the user would be asked during installation about monitor info, and the default answer would give a sync range of 30-50.

If the EDID from the monitor is broken or missing, the best we can offer is a user tool for configuring xorg.conf, which is work in progress.

Anyway, if somebody can try latest Jaunty and attach the logs (you can use "apport-collect 284309"), it would be nice.

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-r128 6.8.0+git20090201.08d56c88-1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

mockdeep (rtfletch81) wrote :
mockdeep (rtfletch81) wrote :

That did the trick for me. Now if there is any way to get a little of the pretty compiz fusion stuff in there...

Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid
Bryce Harrington (bryce) on 2010-03-18
tags: added: xubuntu
Timo Aaltonen (tjaalton) wrote :

​​​​this driver has been removed from Ubuntu, closing the bugs

Changed in xserver-xorg-video-r128 (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.