Ubuntu 12.04 LTS 32-bit and ATI Rage 128 PRO Boot Screen Quality and ACPI S3 State resume problems

Bug #1017036 reported by fpgahardwareengineer on 2012-06-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-r128 (Ubuntu)
Undecided
raymond rector

Bug Description

Hi,

There are several severe stability problems I have noticed with Ubuntu 12.04 LTS 32-bit and ATI Page 128 PRO card.

-Several flickers and junk is displayed during boot up and ACPI S3 State resume

Please, eliminate these kinds of problems because this kind of issues are preventing Linux from competing with Microsoft Windows for the desktop PC market.
These aren't crashes, but still, they are huge eyesores.

- Starts up with very high screen resolution when it boots

This causes problems when I try to move the computer from a very high resolution monitor (22 inch LCD monitor supporting 1600 X 1050) to a moderate resolution monitor (17 inch CRT minitor supporting 1024 X 768 at 75Hz).
Shouldn't Ubuntu sense that the monitor being used doesn't support 1600 X 1050 screen resolution?

- Generally, the redering is somewhat slow

Is there any acceleration with ATI Rage 128 PRO?
It seems like screen is being rendered by VESA driver according to System Settings -> Details -> OVerview because it says, "Graphics VESA: R128."

- ACPI S3 State resume doesn't work reliabily with LiveCD or doesn't at all when installed to a hard drive

ACPI S3 State resume worked fine with Ubuntu 10.04.4 LTS 32-bit with LiveCD.
When tested with Ubuntu 12.04 LTS 32-bit, it works some times, but does freeze fairly frequently when resuming.
It doesn't work at all when Ubuntu 12.04 LTS 32-bit is installed to a hard drive.
In this particular case, the computer will simply reboot when I try to resume from ACPI S3 State.
I installed all the updates published to date (as of 6/23/2012) via Update Manager.

System Configuration:

- Intel Pentium 4 1.6 GHz (Willamette)
- ASUS P4T-E mainboard
  * BIOS Revision 1007 (last release)
- 512MB PC800 RDRAM (256MB X 2)
- ATI Rage 128 PRO
  * Recognized by Ubuntu as ATI Rage 128 PF/PRO AGP 4x TMDS
  * 1.5V AGP support
  * SGRAM
- Creative Labs Sound Blaster Audigy Platinum 6.1
- Lite-On Communications LNE100TX 100M bps Ethernet
- 20GB Seagate Ultra DMA/100 PATA hard drive
- BTC BDV316C PATA DVD-ROM drive
- Hitachi-LG PATA CD-RW drive
- Legacy 3.5" floppy drive
- USB keyboard
- USB mouse

Please fix these bugs/problems.

Regards,

fpgahardwareengineer

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic-pae 3.2.18
Uname: Linux 3.2.0-25-generic-pae i686
.tmp.unity.support.test.1:

ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDmesg:
 [ 19.512259] net eth0: Setting full-duplex based on MII#1 link partner capability of 45e1
 [ 26.752056] eth0: no IPv6 routers present
Date: Sat Jun 23 18:39:50 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Rage 128 PF/PRO AGP 4x TMDS [1002:5046] (prog-if 00 [VGA controller])
   Subsystem: Advanced Micro Devices [AMD] nee ATI Device [1002:0404]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 413c:3200 Dell Computer Corp. Mouse
 Bus 002 Device 003: ID 413c:2003 Dell Computer Corp. Keyboard
MachineType: System Manufacturer System Name
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-25-generic-pae root=UUID=553e796c-d5d8-409a-99ab-d58ccd562ee9 ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/14/2002
dmi.bios.vendor: Award Software, Inc.
dmi.bios.version: ASUS P4T-E ACPI BIOS Revision 1007
dmi.board.name: <P4T-E>
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: REV 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 6
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAwardSoftware,Inc.:bvrASUSP4T-EACPIBIOSRevision1007:bd08/14/2002:svnSystemManufacturer:pnSystemName:pvrSystemVersion:rvnASUSTeKComputerINC.:rn<P4T-E>:rvrREV1.xx:cvnChassisManufacture:ct6:cvrChassisVersion:
dmi.product.name: System Name
dmi.product.version: System Version
dmi.sys.vendor: System Manufacturer
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Steve Langasek (vorlon) on 2012-06-24
tags: removed: regression-update
Bryce Harrington (bryce) wrote :

The problem is you're using the r128 driver, which is not widely used. Really you should work with upstream on all of those issues, it's not going to be a priority in Ubuntu. But I'll refile your bug report and leave it open in case someone else wants to work on it.

affects: xorg (Ubuntu) → xserver-xorg-video-r128 (Ubuntu)
bugbot (bugbot) on 2012-07-12
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
bugbot (bugbot) on 2012-07-12
tags: added: resume
madbiologist (me-again) wrote :

EXA acceleration has finally been added to the old r128 driver - see http://www.phoronix.com/scan.php?page=news_item&px=MTEzNDI

This might make it into the upcoming Ubuntu 12.10 "Quantal Quetzal" release. Otherwise you can try using the xorg-edgers PPA.

madbiologist (me-again) wrote :

An updated driver version that includes the abovementioned support has now been formally released - see http://www.phoronix.com/scan.php?page=news_item&px=MTE5NDE

madbiologist (me-again) wrote :

The updated driver has made it into the upcoming Ubuntu 12.10 "Quantal Quetzal" - see https://launchpad.net/ubuntu/+source/xserver-xorg-video-r128

tags: added: ati r128

(In reply to #3)

Hi madbiologist,

What a miracle!
Someone let me know that device driver support is improving!
This is the first time I finally got a Linux developer to pay attention to the bug report I have submitted!
Nice to hear that someone out there is still working on improving hardware support for a 10+ year old hardware on Linux.
I still have quite a few 8 to 10+ year old hardware I picked up from e-waste sites at where I live.
For the most part, the 10+ year old graphics card's performance is still more than good enough for most non-performance critical tasks. (i.e., browsing the Internet on Firefox)
I own about 5 ATI Technologies Rage 128/128 PRO cards, so if anyone needs testing of the newer Rage 128 device driver, I can probably help out on that.
I also own many AGP 1.5V/Universal/3.3V slot mainboards from various chipset vendors (Intel, AMD, SiS, VIA Technologies, NVIDIA) that can be used to make sure that the Rage 128 device driver will work on as many platforms as possible.
Again madbiologist, thanks for letting me know about the development with regard to Rage 128 display device driver.

Regards,

fpgahardwareengineer

(In reply to Bug Description)

Hi,

I need to give status update on this posting from while back.
Regarding the problems I have identified with regard to ATI Technologies Rage 128 display device driver, the ACPI S3 State resume freeze problem with ASUS P4T-E was due to a buggy BIOS.
The BIOS I used when I posted the bug report was Revision 1007, which is ASUS P4T-E's last official release version of the BIOS.
However, it turns out if I used Revision 1008 Beta 003 or Revision 1008 Beta 004, then the ACPI S3 State resume freeze problem will go away.
Here is ASUS P4T-E's download page.

http://support.asus.com/download.aspx?SLanguage=en&p=1&s=15&m=P4T-E

I have a policy of not using beta version BIOS whenever possible when filing bug reports.
However, based on my experiments with ASUS P4T-E, the last official release version was buggy around ACPI so I now use the beta version BIOS (Revision 1008 Beta 004) for this mainboard.
My view is that, beta version of BIOS (Revision 1008) was released specifically to deal with Revision 1007's ACPI S3 State resume bug.
I will also add that ASUS probably forgot to qualify Revision 1008 as an official release version.
I never tested this board with Windows 2000/XP so I don't know how it will fare in a Windows environment.
Note that ASUS P4T-E's ACPI S3 State resume is done through video rePOST (re-Power On Self Test) method, and that's the only method available for this mainboard.
It does not give the option of not doing video rePOST, but since Ubuntu 12.04 works reliably now, I think I can conclude that I found a good solution to the bug report I submitted.
        I think it is fair now to close this bug report since I found a solution to the problem, and for other issues I have raised in this bug report, I will refile them later in a different bug report with relatively low priority since the flashing green screen is not a fatal bug.

Regards,

fpgahardwareengineer

Changed in xserver-xorg-video-r128 (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Fix Released
raymond rector (01rayrctr) wrote :

I bought a shk 9250 r128 card because the advertisement sounded like it was the next to sliced bread. Is ubuntu wrong or Amazon?

Changed in xserver-xorg-video-r128 (Ubuntu):
assignee: nobody → raymond rector (01rayrctr)

(In reply to Comment #8)

Hi Raymond,

I believe Radeon 9250 (RV280) is already supported by Ubuntu.
I also have a Radeon 9250 AGP graphics card, and it works well.
The discussion here is related to ATI Technologies Rage 128/128 Pro-based graphics, not the newer Radeon-based graphics.

Regards,

fpgahardwareengineer

raymond rector (01rayrctr) wrote :

r128 shk9250 on 12.04.1 runs great but with help from xorg krack pushers, ricotz testing. and gnome 3 team ppa's. I have no money for a new graghics card, I have to make due with this one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers