Ubuntu

intel poulsbo (psb): kernel BUG: unable to handle kernel NULL pointer dereference at 00000000

Reported by D on 2009-07-29
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Mobile Edition
Undecided
Unassigned
xserver-xorg-video-psb (Ubuntu)
Undecided
Unassigned

Bug Description

I get the attached crash when trying to load the psb module. Compiled with dkms or precompiled.

I've already tried kernel 2.6.30-rc2 (with a patched module) as well, without success.
So it's probably a bug in ubuntu mobile ppa's psb-modules / psb-kernel-source.

I use Ubuntu 9.04 with the ubuntu mobile ppa on a MSI Wind U110.

Please let me know if you need any more information.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation System Controller Hub (SCH Poulsbo) [8086:8100] (rev 07)
     Subsystem: Micro-Star International Co., Ltd. Device [1462:1002]
00:02.0 VGA compatible controller [0300]: Intel Corporation System Controller Hub (SCH Poulsbo) Graphics Controller [8086:8108] (rev 07)
     Subsystem: Micro-Star International Co., Ltd. Device [1462:1002]

D (dj-lp) wrote :
D (dj-lp) wrote :
D (dj-lp) wrote :

Here is the interesting dmesg part:

[ 443.561553] [drm] Initialized drm 1.1.0 20060810
[ 443.593094] psb 0000:00:02.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 443.593109] psb 0000:00:02.0: setting latency timer to 64
[ 443.593189] [drm] psb - 5.0.1.0046
[ 443.612114] [drm:psb_do_init] *ERROR* Debug is 0x00000000
[ 443.636854] psb 0000:00:02.0: firmware: requesting msvdx_fw.bin
[ 443.668409] [drm:msvdx_get_fw] *ERROR* MSVDX: msvdx_fw.bin request_firmware failed: Reason -2
[ 443.668531] [drm:psb_setup_fw] *ERROR* psb: No valid msvdx_fw.bin firmware found.
[ 443.681645] [drm] SGX core id = 0x01130000
[ 443.681655] [drm] SGX core rev major = 0x01, minor = 0x02
[ 443.681661] [drm] SGX core rev maintenance = 0x01, designer = 0x00
[ 443.682508] [drm] intel_lvds_init: OpRegion has the VBT address
[ 443.682523] [drm] intel_lvds_init: The bdb->signature is BIOS_DATA_BLOCK ƒ, the bdb_off is 48
[ 443.682552] [drm] intel_lvds_init: BLC Data in BIOS VBT tables: datasize=0 paneltype=7 type=0x00 pol=0x01 freq=0x00c8 minlevel=0x00 i2caddr=0x58 cmd=0xaa
[ 443.682574] [drm] intel_lvds_init: the CoreClock is 200
[ 443.682584] [drm] intel_lvds_init: sku_value is 0x00800000
[ 443.682590] [drm] intel_lvds_init: sku_bMaxResEnableInt is 0
[ 443.936206] integrated sync not supported
[ 443.936241] BUG: unable to handle kernel NULL pointer dereference at 00000000
[ 443.936438] IP: [<f7fc1389>] drm_mode_probed_add+0x9/0x20 [drm]
[ 443.936591] *pde = 00000000
[ 443.936598] Oops: 0002 [#1] SMP
[ 443.936750] last sysfs file: /sys/devices/pci0000:00/0000:00:02.0/firmware/0000:00:02.0/loading
[ 443.936856] Dumping ftrace buffer:
[ 443.936927] (ftrace buffer empty)
[ 443.936997] Modules linked in: psb(+) drm agpgart i2c_algo_bit binfmt_misc ppdev bridge stp bnep input_polldev joydev lp parport snd_hda_intel snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device psmouse snd serio_raw i2c_isch pcspkr soundcore rt2860sta snd_page_alloc video output fbcon tileblit font bitblit softcursor
[ 443.938941]
[ 443.939009] Pid: 4203, comm: modprobe Not tainted (2.6.28-13-generic #45-Ubuntu) U110
[ 443.939110] EIP: 0060:[<f7fc1389>] EFLAGS: 00010202 CPU: 1
[ 443.939209] EIP is at drm_mode_probed_add+0x9/0x20 [drm]
[ 443.939285] EAX: ee7bfa00 EBX: 00000001 ECX: cac7b6c0 EDX: 00000000
[ 443.939363] ESI: cbc2cf12 EDI: f6705000 EBP: d16cdb20 ESP: d16cdb20
[ 443.939441] DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
(...)

D (dj-lp) wrote :
Adil Arif (adisari06) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Judging from your description, I am going to assign this bug to the xserver-xorg-video-psb package in hopes that it will have a faster response. If you believe that I have chosen the wrong package, please change your bug to the correct one. Good luck on getting it fixed!

affects: ubuntu → xserver-xorg-video-psb (Ubuntu)
Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Bryce Harrington (bryce) on 2009-10-10
description: updated

I've fixed it through commenting out a few codelines:

        if (edid)
                drm_add_edid_modes(output, edid);

in static int intel_lvds_get_modes(struct drm_output *output) file intel_lvds.c of package psb-kernel-source

D (dj-lp) wrote :

Thanks Jtb, I hope to get that to work as well for me!

I'm pretty sure I've tried that and it didn't work for me.
What kernel and psb-module version do you use?
Only comment out those two lines?

D (dj-lp) wrote :

Okay. I take that back. It works perfectly! :)

Rolf Leggewie (r0lf) on 2010-01-22
Changed in ubuntu-mobile:
status: New → Confirmed
Changed in xserver-xorg-video-psb (Ubuntu):
status: New → Triaged
D (dj-lp) wrote :

Any news on this? I've tried to code around it a bit but it didn't work. I have a feeling this might be a reason I have no backlight control...

It would be great to at least come up with a patch that can be sent upstream.

bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xserver-xorg-video-psb (Ubuntu):
status: Triaged → New
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.