Ubuntu

[GMA-500] Xorg spontaneously freezes (under heavy loads?) after a while

Reported by Ronald J. Wright on 2009-06-29
66
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-psb (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by gururise
Nominated for Karmic by gururise

Bug Description

Hello,

I have a Compulab fit-PC2 running Ubuntu Jaunty, and its graphics chip is the Intel GMA-500. I am using the Poulsbo driver (xserver-xorg-video-psb 0.31.0-0ubuntu1~904um1 with psb-modules 4.41.1-0ubuntu1~904um1) from Launchpad's Ubuntu Mobile PPA site. However, I keep running into troubles with Xorg (xserver-xorg 7.4~5ubuntu18), and now it seems more often than not that I keep seeing Xorg spontaneously freeze. I assume that the crashes occur under heavy loads (e.g. when compiling a program or frequently opening and closing or switching windows). The display becomes frozen, but you can still move the mouse pointer, and the machine is still remotely accessible via SSH.

As you can tell in the attached file containing the strace output of Xorg, the freeze begins when the ioctl() function starts repeatedly returning -1 (EAGAIN, which means "Try again" or "Resource temporarily unavailable"), and if I try to kill the Xorg server by calling 'sudo kill -9 $(ps -C Xorg -o pid=)', the display becomes completely frozen (i.e. you cannot move the mouse pointer as well) and the whole machine freezes (as evidenced in an SSH connection on a remote machine where you cannot kill the SSH client by pressing Ctrl+C or type anything in the terminal). There is no indication in the logs that a kernel oops related to this problem occurred.

Bryce Harrington (bryce) on 2009-07-02
affects: xorg (Ubuntu) → xserver-xorg-video-psb (Ubuntu)
Davide Saurino (dsaurino) wrote :

I realized that my trouble with freezing was dued to poulsbo 3d driver, so I removed that and I have no more freeze even running a -13 kernel.

I confirme that it's the poulsbo 3d driver which produce this bug, I install it and start to have this freeze. Uninstall it solves the problem but you don't have the 3d support.

marduk (dennis-schwan) wrote :

I can confirm this on Ubuntu 8.10 / Intrepid, with 3D-enabled i sometimes get freezes and only turning off the laptop helps

vaivaswatha (vaivaswatha) wrote :

I confirm this bug too. X freezes completly. Remote login via ssh works fine (so that can safely poweroff the machine).

Steeve Cottin (stef-cottin) wrote :

My ACER Aspire One 751 has a GMA500 (poulsbo) and the same problem (duplicate bug #404684) :

What can I do to report more elements ?

The "poulsbo-driver-3d" version is : "1.1-0ubuntu1~904um1 (jauntry)". It depends on :
* poulsbo-driver-2d
* xpsb-glx
* libva1
* libgl1-mesa-glx

Steeve Cottin (stef-cottin) wrote :

Is this bug related to the Facebook Intel Poulsbo (GMA500) Dissatisfaction Group : http://www.facebook.com/group.php?gid=62711517402 ?

Davide Saurino (dsaurino) wrote :

@Stef
Well, according to me this is only one of the reasons...

Davide Saurino (dsaurino) wrote :

I re-installed 3D driver and firmware, inserted these lines

Option "AccelMethod" "EXA"
Option "DRI" "off"
Option "MigrationHeuristic" "greedy"

into the "Device" section of xorg.conf and now I get no more freeze, even with 3D installed.

Steeve Cottin (stef-cottin) wrote :

YES... (thank you) ...it seems to work also for me with an ACER Aspire One 751 (AO751h).
I'm waiting for a freeze that doesn't came, but I noticed some "limitations" :

  * It seems to be 3D, but compiz is no more "activable" (as I tried to add "psb" in te WHITELIST of /usr/bin/compiz).

  * I had to "recompile" the psb module when I received the "2.6.28-14" kernel upgrade, doing :
           $ sudo apt-get install psb-kernel-source
           $ sudo shutdown -r now
                 => this second line is a "reboot now"

  * It is impossible to "change user" in gnome without closing the user session

Davide Saurino (dsaurino) wrote :

You're right for the first two points, for the third one I've not tried to change user as I'm the only user of my netbook.

Furthermore, I have some problems with suspend option as I'm not able to resume the system after a suspend (I've to investigate more, I'm not sure that this problem happens always).

Steeve Cottin (stef-cottin) wrote :

Didn't you even try to "open a guest session" without "closing yours" ?

Davide Saurino (dsaurino) wrote :

You're right, this doesn't work for me too...

Actually I'm running compiz, it works fine. I added psb to the WHITELIST and just enabled it. No more configuration.

Bryce Harrington (bryce) wrote :

Hi logiconcepts819,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log (or Xorg.0.log.old) from after reproducing the issue?

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in xserver-xorg-video-psb (Ubuntu):
status: New → Incomplete
Steeve Cottin (stef-cottin) wrote :

I re-activated DRI on my Acr Aspire One 751 pro (AO751h) in order to reproduce the problem and give you the /var/log/Xorg.0.log (attached with de /etc/X11/xorg.conf file).

Do you need any more info (I don't know how to strace Xorg) ?

Steeve Cottin (stef-cottin) wrote :

I've just found a solution to activate DRI on a link in the facebook group : http://www.facebook.com/group.php?gid=62711517402 . The link is : http://ubuntuforums.org/showpost.php?p=7775498&postcount=9 ... and explains hw to free memory at the kernel level for the GMA500.

It didn't work a the first time for me (I get problems with sound and wifi) and I need also to add before the kerne line in the menu.lst file :

 uppermem 804864

(804864=738*1024)

My Dell Mini 12 (GMA 500) is working fine with DRI enabled. And I don't put memory for the graphic card. I only add the nosplash option to GRUB but I don't know if it has something to do with it. Or maybe it's an update on Ubuntu, because now, after 2 days I have no freeze. :-)

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty

I should make it clear that the previous post is the Xorg.0.log.old file.

Bryce Harrington (bryce) wrote :

Thanks for the Xorg log. We also need the lspci -vnvn output attached to this bug as a file

tags: removed: needs-xorglog
Changed in xserver-xorg-video-psb (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-psb (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers