Ubuntu

[VX800]openchrome hangs when the mouse cursor is inside of a image in gimp

Reported by Lasse on 2009-08-07
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
openchrome
Fix Released
Unknown
xserver-xorg-video-openchrome (Debian)
Confirmed
Unknown
xserver-xorg-video-openchrome (Ubuntu)
Low
Bryce Harrington
Oneiric
Low
Bartosz Kosiorek

Bug Description

[Impact]
System hang with openchrome driver when using GIMP.

[Development Fix]
The issue was fixed upstream with a pair of patches. An svn snapshot containing both fixes is shipped in Precise.

[Stable Fix]
The two fixes are cherrypicked and apply directly to oneiric's source. I had to reformat the patches but there were no code changes required.

[Text Case]
1. Boot up on an openchrome (VIA) based system
2. Start GIMP
3. Create a new picture
4. Move mouse cursor inside the picture
Broken Behavior: X.org hangs
Fixed Behavior: No hang, GIMP works normally

[Regression Potential]
The patches have received testing in Debian and upstream, so presumably should be fairly safe. The number of people using openchrome is relatively small compared to the main X drivers, so the scope of risk is rather small here.

[Original Report]
root@ltsp47:~# lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

root@ltsp47:~# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VX800 Host Bridge (rev 12)
00:00.1 Host bridge: VIA Technologies, Inc. VX800/VX820 Error Reporting
00:00.2 Host bridge: VIA Technologies, Inc. VX800/VX820 Host Bus Control
00:00.3 Host bridge: VIA Technologies, Inc. VX800 PCI to PCI Bridge
00:00.4 Host bridge: VIA Technologies, Inc. VX800/VX820 Power Management Control
00:00.5 PIC: VIA Technologies, Inc. VX800/VX820 APIC and Central Traffic Control
00:00.6 Host bridge: VIA Technologies, Inc. VX800/VX820 Scratch Registers
00:00.7 Host bridge: VIA Technologies, Inc. VX800/VX820 North-South Module Interface Control
00:01.0 VGA compatible controller: VIA Technologies, Inc. Device 1122 (rev 11)
00:03.0 PCI bridge: VIA Technologies, Inc. VX800/VX820 PCI Express Root Port
00:0f.0 IDE interface: VIA Technologies, Inc. VX800 Serial ATA and EIDE Controller
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. VX800/VX820 Bus Control and Power Management
00:11.7 Host bridge: VIA Technologies, Inc. VX800/VX820 South-North Module Interface Control
00:13.0 PCI bridge: VIA Technologies, Inc. Device b353
00:14.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 20)
01:00.0 Ethernet controller: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter (rev 82)

The computer is a HP t5545 (a thinclient) and Jaunty is serverd to it through ltsp.

It is 7:th of August 2009, the system is fully upgraded.

In Jaunty:
1. Everything works almost perfectly until Gimp is started and a new picture is created and the mouse cursor is moved inside of it. Then the whole X.org system hangs. It is possible for some time to log in through SSH but after some time the system locks up completely. "NoAccel" is solving the problem but the computer is then unacceptable slow. Same problem appears sometimes with Wine.

2. A lot of green lines appears on the screen if I switch to a text console with Ctrl+Alt+F1 and then back to X (Ctrl+Alt+F7). By upgrading to the driver from Karmic, this problem disappears. But still this is not solving my first bug.

In Hardy:
The Via driver is not working at all with this computer.

In Intrepid:
The Via driver is not working at all with this computer.

Bartosz Kosiorek (gang65) wrote :

Please build/install the latest openchrome driver and enable debug mode.
The detail build instruction is available at:
https://help.ubuntu.com/community/OpenChrome

Then run GIMP and hang system.

On the next reboot attach your Xorg.0.log file (and Xorg.0.log.old).
It is located at /var/log/Xorg.0.log

summary: - openchrome hangs when the mouse cursor is inside of a image in gimp
+ [VX800]openchrome hangs when the mouse cursor is inside of a image in
+ gimp
Changed in xserver-xorg-video-openchrome (Ubuntu):
status: New → Confirmed
Lasse (lengblom) wrote :

I followed the instructions on https://help.ubuntu.com/community/OpenChrome to install the svn version and I saw no error message during the installation.

After I have been updating the ltsp-image and put the thinclient to boot, it hangs where it is normally starting X. I am sorry that I can not get any Xorg.0.log as the computer is diskless and it hangs so completely that I can not ssh into it to retrieve anything.

Apparenty the svn version is behaving even worse on this hardware :(
... or is there anything I can do, besides what was in those instructions?

Bartosz Kosiorek (gang65) wrote :

Please install openchrome from Karmic, and attach Xorg.log
Try to attach the Xorg.log file after GIMP freeze.

In the Karmic Koala there is openchrome revision is 758.
The latest openchrome revision is 772

You can go back to revision that you want, by type:
     svn update -r<revision>

for example:
      svn update -r762

Please check where this system freeze appears.

To do this, you must go back to the specific revision between 758 and 772, compile, install and check if it hangs or not.

Good Luck

Lasse (lengblom) wrote :

Here is the log with the Karmic driver... Hopefully it will help, even though the crash apparently did not get recorded.

Bartosz Kosiorek (gang65) wrote :

Please check on which openchrome revision the system starts hang, where it is normally starting X.

It is very important for me because it mean that the latest openchrome revision is broken.

With your investigation, I will know on which revision this error occured.

Download full text (3.8 KiB)

I will try to do it... The problem is that it is a ltsp system that is
taken into use. This mean that I have difficulties to experiment with
it without causing all our customers computers to be down. As soon as
I get a chance to get my hands on the system after their work time I
will. Because of this bug we are very much after in our schedule with
our other customers....

I am really hoping I will be able of providing the information as I am
also very eager to get it solved

On Fri, Aug 14, 2009 at 4:30 PM, Bartosz<email address hidden> wrote:
> Please check on which openchrome revision the system starts hang, where
> it is normally starting X.
>
> It is very important for me because it mean that the latest openchrome
> revision is broken.
>
> With your investigation, I will know on which revision this error
> occured.
>
> --
> [VX800]openchrome hangs when the mouse cursor is inside of a image in gimp
> https://bugs.launchpad.net/bugs/410262
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-openchrome” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: xserver-xorg-video-openchrome
>
> root@ltsp47:~# lsb_release -rd
> Description:    Ubuntu 9.04
> Release:        9.04
>
>
> root@ltsp47:~# lspci
> 00:00.0 Host bridge: VIA Technologies, Inc. VX800 Host Bridge (rev 12)
> 00:00.1 Host bridge: VIA Technologies, Inc. VX800/VX820 Error Reporting
> 00:00.2 Host bridge: VIA Technologies, Inc. VX800/VX820 Host Bus Control
> 00:00.3 Host bridge: VIA Technologies, Inc. VX800 PCI to PCI Bridge
> 00:00.4 Host bridge: VIA Technologies, Inc. VX800/VX820 Power Management Control
> 00:00.5 PIC: VIA Technologies, Inc. VX800/VX820 APIC and Central Traffic Control
> 00:00.6 Host bridge: VIA Technologies, Inc. VX800/VX820 Scratch Registers
> 00:00.7 Host bridge: VIA Technologies, Inc. VX800/VX820 North-South Module Interface Control
> 00:01.0 VGA compatible controller: VIA Technologies, Inc. Device 1122 (rev 11)
> 00:03.0 PCI bridge: VIA Technologies, Inc. VX800/VX820 PCI Express Root Port
> 00:0f.0 IDE interface: VIA Technologies, Inc. VX800 Serial ATA and EIDE Controller
> 00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
> 00:11.0 ISA bridge: VIA Technologies, Inc. VX800/VX820 Bus Control and Power Management
> 00:11.7 Host bridge: VIA Technologies, Inc. VX800/VX820 South-North Module Interface Control
> 00:13.0 PCI bridge: VIA Technologies, Inc. Device b353
> 00:14.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 20)
> 01:00.0 Ethernet controller: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter (rev 82)
>
> The computer is a HP t5545 (a thinclient) and Jaunty is serverd to it through ltsp.
>
> It is 7:th of August 2009, the system is fully upgraded.
>
> In Jaunty:
> 1. Everything works almost perfectly unti...

Read more...

Bartosz Kosiorek (gang65) wrote :

Thank you for your help.

I'm waiting for results of your test.

Bryce Harrington (bryce) on 2009-09-02
tags: added: karmic
Bartosz Kosiorek (gang65) wrote :

Check if this error exists in the latest openchrome revision.

Lasse (lengblom) wrote :
Download full text (3.2 KiB)

From Karmic? Or from svn?

On Fri, Sep 11, 2009 at 4:03 PM, Bartosz <email address hidden> wrote:
> Check if this error exists in the latest openchrome revision.
>
> --
> [VX800]openchrome hangs when the mouse cursor is inside of a image in gimp
> https://bugs.launchpad.net/bugs/410262
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-openchrome” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: xserver-xorg-video-openchrome
>
> root@ltsp47:~# lsb_release -rd
> Description:    Ubuntu 9.04
> Release:        9.04
>
>
> root@ltsp47:~# lspci
> 00:00.0 Host bridge: VIA Technologies, Inc. VX800 Host Bridge (rev 12)
> 00:00.1 Host bridge: VIA Technologies, Inc. VX800/VX820 Error Reporting
> 00:00.2 Host bridge: VIA Technologies, Inc. VX800/VX820 Host Bus Control
> 00:00.3 Host bridge: VIA Technologies, Inc. VX800 PCI to PCI Bridge
> 00:00.4 Host bridge: VIA Technologies, Inc. VX800/VX820 Power Management Control
> 00:00.5 PIC: VIA Technologies, Inc. VX800/VX820 APIC and Central Traffic Control
> 00:00.6 Host bridge: VIA Technologies, Inc. VX800/VX820 Scratch Registers
> 00:00.7 Host bridge: VIA Technologies, Inc. VX800/VX820 North-South Module Interface Control
> 00:01.0 VGA compatible controller: VIA Technologies, Inc. Device 1122 (rev 11)
> 00:03.0 PCI bridge: VIA Technologies, Inc. VX800/VX820 PCI Express Root Port
> 00:0f.0 IDE interface: VIA Technologies, Inc. VX800 Serial ATA and EIDE Controller
> 00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
> 00:11.0 ISA bridge: VIA Technologies, Inc. VX800/VX820 Bus Control and Power Management
> 00:11.7 Host bridge: VIA Technologies, Inc. VX800/VX820 South-North Module Interface Control
> 00:13.0 PCI bridge: VIA Technologies, Inc. Device b353
> 00:14.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 20)
> 01:00.0 Ethernet controller: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter (rev 82)
>
> The computer is a HP t5545 (a thinclient) and Jaunty is serverd to it through ltsp.
>
> It is 7:th of August 2009, the system is fully upgraded.
>
> In Jaunty:
> 1. Everything works almost perfectly until Gimp is started and a new picture is created and the mouse cursor is moved inside of it. Then the whole X.org system hangs. It is possible for some time to log in through SSH but after some time the system locks up completely. "NoAccel" is solving the problem but the computer is then unacceptable slow. Same problem appears sometimes with Wine.
>
> 2. A lot of green lines appears on the screen if I switch to a text console with Ctrl+Alt+F1 and then back to X (Ctrl+Alt+F7). By upgrading to the driver from Karmic, this problem disappears. But still this is not solving my first bug.
>
> In Hardy:
> The Via driver is not working at all with this computer.
>
> In I...

Read more...

Bartosz Kosiorek (gang65) wrote :

From SVN.

The detail build instruction is available at:
https://help.ubuntu.com/community/OpenChrome

Bartosz Kosiorek (gang65) wrote :

Fixed in Ubuntu Karmic Koala (xserver-xorg-video-openchrome 1:0.2.903+svn758-0ubuntu1)

Changed in xserver-xorg-video-openchrome (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
Lasse (lengblom) wrote :
Download full text (3.7 KiB)

The svn driver is now working the same well/bad as the one that comes
with jaunty.

The problem that was earlier in svn, that made openchrome to not work
at all is solved.

The problem with the mouse cursor inside of a GIMP image is not
solved. So, the original bug is still there.

On Wed, Sep 16, 2009 at 7:24 PM, Bartosz <email address hidden> wrote:
> Fixed in Ubuntu Karmic Koala (xserver-xorg-video-openchrome
> 1:0.2.903+svn758-0ubuntu1)
>
> ** Changed in: xserver-xorg-video-openchrome (Ubuntu)
>   Importance: Undecided => Low
>
> ** Changed in: xserver-xorg-video-openchrome (Ubuntu)
>       Status: Confirmed => Fix Released
>
> --
> [VX800]openchrome hangs when the mouse cursor is inside of a image in gimp
> https://bugs.launchpad.net/bugs/410262
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xserver-xorg-video-openchrome” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xserver-xorg-video-openchrome
>
> root@ltsp47:~# lsb_release -rd
> Description:    Ubuntu 9.04
> Release:        9.04
>
>
> root@ltsp47:~# lspci
> 00:00.0 Host bridge: VIA Technologies, Inc. VX800 Host Bridge (rev 12)
> 00:00.1 Host bridge: VIA Technologies, Inc. VX800/VX820 Error Reporting
> 00:00.2 Host bridge: VIA Technologies, Inc. VX800/VX820 Host Bus Control
> 00:00.3 Host bridge: VIA Technologies, Inc. VX800 PCI to PCI Bridge
> 00:00.4 Host bridge: VIA Technologies, Inc. VX800/VX820 Power Management Control
> 00:00.5 PIC: VIA Technologies, Inc. VX800/VX820 APIC and Central Traffic Control
> 00:00.6 Host bridge: VIA Technologies, Inc. VX800/VX820 Scratch Registers
> 00:00.7 Host bridge: VIA Technologies, Inc. VX800/VX820 North-South Module Interface Control
> 00:01.0 VGA compatible controller: VIA Technologies, Inc. Device 1122 (rev 11)
> 00:03.0 PCI bridge: VIA Technologies, Inc. VX800/VX820 PCI Express Root Port
> 00:0f.0 IDE interface: VIA Technologies, Inc. VX800 Serial ATA and EIDE Controller
> 00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
> 00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
> 00:11.0 ISA bridge: VIA Technologies, Inc. VX800/VX820 Bus Control and Power Management
> 00:11.7 Host bridge: VIA Technologies, Inc. VX800/VX820 South-North Module Interface Control
> 00:13.0 PCI bridge: VIA Technologies, Inc. Device b353
> 00:14.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 20)
> 01:00.0 Ethernet controller: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter (rev 82)
>
> The computer is a HP t5545 (a thinclient) and Jaunty is serverd to it through ltsp.
>
> It is 7:th of August 2009, the system is fully upgraded.
>
> In Jaunty:
> 1. Everything works almost perfectly until Gimp is started and a new picture is created and the mouse cursor is moved inside of it. Then the whole X.org system hangs. It is possible for some time to log in through SSH but after so...

Read more...

igorsh (ishipenkov) wrote :

Bug is still there, yes. I use latest svn build of openchrome (revision 841) and even hibernate works fine, but sometimes when I use gimp system hangs.

igorsh (ishipenkov) wrote :

oh, and when system hangs, hundreds of these lines fills Xorg.0.log:

 (II) CHROME(0): VIALoadPalette: numColors: 256
 (II) CHROME(0): VIALoadRgbLut

Bartosz Kosiorek (gang65) wrote :

Attach your /var/log/Xorg.0.log file (from svn build openchrome).
If you can from after reproducing this hang (or /var/log/Xorg.0.log.old after reboot).

Alberto Jovito (thedemon007) wrote :

Please build/install the latest openchrome driver and enable debug mode.
The detail build instruction is available at:
https://help.ubuntu.com/community/OpenChrome

Then run GIMP and hang system.

On the next reboot attach your Xorg.0.log file (and Xorg.0.log.old).
It is located at /var/log/Xorg.0.log

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Fix Released → Triaged
assignee: nobody → Bartosz (gang65)
Changed in openchrome:
status: Unknown → Fix Released
bugbot (bugbot) on 2011-05-05
tags: added: jaunty
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :

Needs both of these patches on top of what we have in oneiric:
 * http://www.openchrome.org/trac/attachment/ticket/354/vx800_xaa.patch
 * http://www.openchrome.org/trac/changeset/921

Hopefully Debian will create a new snapshot and we can pull it in automatically. If that doesn't happen before Debian Freeze, we can pull the patches manually or something.

Bryce Harrington (bryce) on 2011-11-15
Changed in xserver-xorg-video-openchrome (Ubuntu):
assignee: Bartosz (gang65) → Bryce Harrington (bryce)
Alberto Jovito (thedemon007) wrote :

I coment bug in debian http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624704 and package 1:0.2.904+svn1050-1 release in The Precise Pangolin.

Changed in xserver-xorg-video-openchrome (Debian):
status: Unknown → Confirmed
Alberto Jovito (thedemon007) wrote :
Bryce Harrington (bryce) on 2012-02-23
description: updated
Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Triaged → Fix Committed
Chris Halse Rogers (raof) wrote :

Marking as fix-released in Precise, and opening an Oneiric task. It sounds like this goes all the way back to lucid, but it's not clear to me. Bryce, are you planning on SRUing to previous releases as well?

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-openchrome (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed

Hello Lasse, or anyone else affected,

Accepted xserver-xorg-video-openchrome into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Bartosz Kosiorek (gang65) wrote :

The package from proposed solves the system hangs.
Thank you.

Changed in xserver-xorg-video-openchrome (Ubuntu Oneiric):
assignee: nobody → Bartosz Kosiorek (gang65)
importance: Undecided → Low
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-openchrome - 1:0.2.904+svn920-1ubuntu0.1

---------------
xserver-xorg-video-openchrome (1:0.2.904+svn920-1ubuntu0.1) oneiric-proposed; urgency=low

  * Add 100_fix_xaa_display_issues.patch and 101_xaa_solid.patch:
    Fix hang with mouse cursor in gimp.
    (LP: #410262)
 -- Bryce Harrington <email address hidden> Thu, 23 Feb 2012 15:12:59 -0800

Changed in xserver-xorg-video-openchrome (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Thomas Schlichter (bigboss77) wrote :

With the release of the new package I did happily see that the patch from revision 921 (which fixed the problem for me) was added.
Unfortunately I had to realize that also "xaa_solid.patch" was added what re-introduced the gimp-hang for me. I was also reporting that upstream in bug 354, and thus this second patch was not applied upstream.

  http://openchrome.org/trac/ticket/354

So please revert "101_xaa_solid.patch", as this re-introduces this bug for me!

P.S.: For me it is 100% reproducible be using the scissors-tool in gimp.

Bartosz Kosiorek (gang65) wrote :

Hi Thomas.

Please fill the new bug report and add the link here.

Thomas Schlichter (bigboss77) wrote :

Hi Bartosz,

I have created a new bug report (LP: #953344)

Kind regards,
  Thomas

tags: added: oneiric regression-update
removed: verification-done
Steve Langasek (vorlon) wrote :

Hello Lasse, or anyone else affected,

Accepted into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-openchrome (Ubuntu Oneiric):
status: Fix Released → In Progress
tags: removed: regression-update
Changed in xserver-xorg-video-openchrome (Ubuntu Oneiric):
status: In Progress → Fix Committed
Thomas Schlichter (bigboss77) wrote :

I've been testing the proposed package version 1:0.2.904+svn920-1ubuntu0.2, and it fixes the problem for me!

Thank you very much!

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-openchrome - 1:0.2.904+svn920-1ubuntu0.2

---------------
xserver-xorg-video-openchrome (1:0.2.904+svn920-1ubuntu0.2) oneiric-proposed; urgency=low

  * Drop 101_xaa_solid.patch. Patch 100 is the actual workaround to the
    problem, 101 reverts the fix in favor of a different change, and thus
    as a result leaves the original bug unfixed.
    (LP: #410262)
 -- Bryce Harrington <email address hidden> Tue, 13 Mar 2012 12:14:58 -0700

Changed in xserver-xorg-video-openchrome (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.