Kubuntu 8.10 xserver-xorg-video-openchrome causes crash with VIA chip K8M890CE/K8N890CE

Bug #299631 reported by m1fcj on 2008-11-18
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openchrome
Fix Released
Unknown
xserver-xorg-video-openchrome (Ubuntu)
High
Bartosz Kosiorek
Nominated for Intrepid by Bartosz Kosiorek
Nominated for Jaunty by Bartosz Kosiorek
Nominated for Karmic by Bartosz Kosiorek

Bug Description

As soon as the kwin start, it crashes w/o any visible errors and X restarts, returning to the kdm or grm window.
The system works perfectly fine with Ubuntu+GDM+Gnome.

Without the 3D acceleration, KDE loads and works - albeit graphical experience is not very satisfactory.

The Kubuntu 8.10 installation CD crashes at the startup when KDE gets loaded and it is not possible to start the installation.

This appears to be a bug (feature?) in xserver-xorg-video-openchrome and KDE 4.1.

I'll put in how I worked around the problem, just in case someone
googles for it.

KDE 4.1 on 8.10 tries to turn the hardware acceleration and promptly
crashes. No useful information is logged in Xorg log nor
.xsession-errors but the dmesg contains this helpful message:

[ 1557.504914] agpgart-amd64 0000:00:00.0: AGP 3.5 bridge
[ 1557.504981] agpgart-amd64 0000:00:00.0: putting AGP V3 device into 8x mode
[ 1557.505141] pci 0000:01:00.0: putting AGP V3 device into 8x mode
[ 1566.298753] [drm:via_verify_command_stream] *ERROR* Accelerated 3D is not supported on this chipset yet.

Since 3D is not supported, instead of continuing w/o bothering with
it, KDE 4.1 stops loading and promptly crashes and exists.

Gdb and valgrind weren't much help.

Solution is working around the hardware acceleration by
creating a xorg.conf and adding the following option to the device
entry:
        Option "NoAccel" "True"

The specific controller that causes the issue is:

01:00.0 VGA compatible controller: VIA Technologies, Inc. K8M890CE/K8N890CE [Chrome 9] (rev 11)
        Subsystem: ASUSTeK Computer Inc. Device 81b5
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 64 (500ns min)
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Region 1: Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
        Expansion ROM at fbdf0000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [70] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=7 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3+ Rate=x4,x8
                Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit- FW- Rate=x8

and it was an on-board graphics card on an Asus branded box.

Jonathan Thomas (echidnaman) wrote :

We should also add this card/driver combo to the compiz blacklist, whatever package it is in. (KWin uses it too in Intrepid)

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi hakan-koseoglu,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xserver-xorg-video-openchrome:
status: New → Incomplete
m1fcj (hakan-koseoglu) wrote :
m1fcj (hakan-koseoglu) wrote :

I have had removed the original xorg.conf and had replaced it with the X --configure output while I was trying to debug. It appears that I haven't saved the Ubuntu original but it didn't make a difference in the end.

Attached tarball has the Xorg logs, .xsession-errors and the Xorg configuration file.

Bartosz Kosiorek (gang65) wrote :

The X freeze and cursor problem was fixed in openchrome Revision 707.

Build instruction I described at:
https://help.ubuntu.com/community/OpenChrome

Please try to build and install, and check if it helps

Colin Kern (kernco) wrote :

Thanks for the work around, I've been trying to fix this problem for a long time. I get some occasional flickering, but at least I can get into KDE.

Bartosz, the problem still exists with the current Jaunty openchrome package, which is revision 713.

Bryce Harrington (bryce) on 2009-04-07
Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Incomplete → Confirmed
m1fcj (hakan-koseoglu) wrote :

Affecting Jaunty 9.04 release.

Toni Helenius (toni-helenius) wrote :

Any tips on this? With NoAccel I sure can get to KDE and even the resolution is right. But the performance is terrible! In Firefox scrolling a page is sluggish and irritating, videos can't be played due to the speed and glxgears gives 50FPS! It is unusable! Any ways to increase the performance?

I tried the newer OpenChrome package from Karmic Koala as well.

Bartosz Kosiorek (gang65) wrote :

Hi.
Please try to use Option "NoDRI" in the device section of xorg.conf.

Toni Helenius (toni-helenius) wrote :

I put Option "NoDRI" "True" and it has no effect. DRI is still on :(

Toni Helenius (toni-helenius) wrote :

Konqueror scrolls ok, and everything seems to work good enough in KDE. Just FireFox and videos are taking a hit. I wrote to VIA but I seriously doubt they'll provide any support.

Martin Olsson (mnemo) wrote :

There used to be an old -via driver but it's deprecated in favor or -openchrome driver (which is the one that currently in used in Ubuntu). The OpenChrome open source project has a homepage at http://www.openchrome.org/ where bugs can be filed etc.

I'm not sure if the openchrome driver has support for disabling DRI (after looking at the code I don't think it does). I think adding a xorg.conf option to disable DRI for debugging purposes would be a useful addition though (but ask the openchrome developers, I really don't know). Doing so should not be that hard actually. It's strange that they don't have this support yet, maybe I'm missing something...

The openchrome driver code says:

  #ifdef XF86DRI
      pVia->directRenderingEnabled = VIADRIScreenInit(pScreen);
  #endif

The intel driver, for comparision, supports setting "DRI" "false" and to do that it uses code like this:

   pI810->directRenderingDisabled =
     !xf86ReturnOptValBool(pI810->Options, OPTION_DRI, TRUE);

...

   pI810->directRenderingEnabled = !pI810->directRenderingDisabled;

   if (pI810->directRenderingEnabled==TRUE)
     pI810->directRenderingEnabled = I810DRIScreenInit(pScreen);

Bartosz Kosiorek (gang65) wrote :

The "no_dri.patch" patch works for me, in disabling DRI.

I haven't check this in Kubuntu 9.04.

Could You check this?

To compile from source code please see:

https://help.ubuntu.com/community/OpenChrome

Changed in openchrome:
status: Unknown → New
Toni Helenius (toni-helenius) wrote :

Ok, as you can see from the remote bug watch, the problem is fixed in the OpenChrome trunk. BUT I tried earlier the OpenChrome deb for Karmic Koala and the problem was still present. So the fix has not been applied there either.

Justin Lee (cf9404) wrote :

Thanks for the patch "no_dri.patch". I had the same problem as Toni Helenius before. After a few attempts to build the 2D driver with the patch, the performance is back again now. And the scrolling becomes much smoother. As the result, I have resolution 1280x1024 without sluggish movements under KDE 4. (but compiz is still disallowed)

The attachment is from my system just in case someone wonder.

Toni Helenius (toni-helenius) wrote :

OpenChrome guys did a good job fixing the bug in their trunk with r749. It is about time for Kubuntu/Ubuntu guys to pass on the good bug killing spirit and apply this patch! This really is a show stopper on Kubuntu Jaunty. It would be good to find the fix fast through the updates!

Changed in openchrome:
status: New → Fix Released
Toni Helenius (toni-helenius) wrote :

How about fixing this for at least Karmic? Now that there is still time? This is a showstopper bug in Kubuntu! And as so a critical one! There is a fix now, please implement it! Thanks.

Changed in xserver-xorg-video-openchrome (Ubuntu):
assignee: nobody → Bartosz (gang65)
importance: Undecided → High
status: Confirmed → Triaged
Jonathan Thomas (echidnaman) wrote :

Karmic now has svn revision r758, which includes this fix.

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.