[KM400][8.10] Wrong xorg.conf file for VIA KM400 graphic chipset

Bug #293326 reported by Clement Quaquin on 2008-11-03
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Xorg Xserver VESA
Undecided
Unassigned
openchrome
Fix Released
Unknown
xserver-xorg-video-openchrome (Ubuntu)
High
Bartosz Kosiorek
xserver-xorg-video-vesa (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

After a fresh install of the Ubuntu 8.10 alternate CD on my laptop, the xserver fails to load.

The error messages seen on screen after a startx :
(EE) CHROME(0): No valid modes found
(EE) Screen(s) found, but none have a usable configuration

Workaround : very simply, by changing the xorg.conf file by another one (in comments)
[lspci]
00:00.0 Host bridge [0600]: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge [1106:3205]
     Subsystem: Uniwill Computer Corp Device [1584:800a]
01:00.0 VGA compatible controller [0300]: VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] [1106:7205] (rev 01)
     Subsystem: Uniwill Computer Corp Device [1584:800a]

Workaround : replacing the xorg.conf file by another one, see attachment

description: updated
Bryce Harrington (bryce) wrote :

Hi clement-quaquin,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log?

Changed in xorg:
status: New → Incomplete
williamts99 (williamts99) wrote :

I also fixed it using almost the same, but only having the following in /etc/X11/xorg.conf works perfectly for me on Averatec 3200.

Section "Device"
Identifier "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
Driver "openchrome"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"

Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Bryce Harrington (bryce) on 2009-01-17
description: updated
Dimitrios Symeonidis (azimout) wrote :

I can confirm this solves the same issue also for me, with a VT8623 (Apollo CLE266) [1106:3122] graphics card...

Changed in xserver-xorg-video-openchrome:
status: Incomplete → Confirmed
Dimitrios Symeonidis (azimout) wrote :

importance=high, in accordance with https://wiki.ubuntu.com/Bugs/Importance

Changed in xserver-xorg-video-openchrome:
importance: Undecided → High
Tayroni Alves (tay-fisica) wrote :

For me, none of two xorg.conf above can solve the issue. The computer is unusable.

My video device has lspci output:

01:00.0 VGA compatible controller: Via Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] (rev 01)

Tayroni Alves (tay-fisica) wrote :

One more detail. I'm on intrepid. And compiled svn revision 735 of openchrome and nothing.

Tayroni Alves (tay-fisica) wrote :

And one more detail: using vesa startx command after logon on tty1 works.

But reboot dont works: ubuntu "low graphics mode" appears instead of GDM.

I believe it is a xorg bug instead of openchrome's.

Bartosz Kosiorek (gang65) wrote :

Please attach Xorg.0.log file, when xorg.conf file is set to default .
It's available at /var/log directory.

I had a working set up with Intrepid Ibex, but after upgrading to Jaunty beta things didn't work.
Here I post the default xorg.conf and my Xorg.0.log

My lspci is
01:00.0 VGA Compatible controller: VIA Technologies, Inc KM400/KN400/P4M800 [S3 UniChrome] (rev 01)

Boring thing is that I can't get to work with the workaround or safe graphics mode (vesa).

My Xorg.0.log file also.

QuinnHarris (ubuntu-quinnh) wrote :

In Jaunty I was able to get my VIA KM400 video working without a special xorg.conf file by modifying the xserver-xorg-video-openchrome package with the minor change described in comment 41 at https://bugzilla.redhat.com/show_bug.cgi?id=389201. I couldn't get it to work at all otherwise. This video worked in Intrepid with a modified xorg.conf file.

Bartosz Kosiorek (gang65) wrote :

Please apply patch which I attached, build and install newest Openchrome drivers.

All was described at:
https://help.ubuntu.com/community/OpenChrome

Next please add the Xorg.log (with patch)

Please also tell if this workaround works.

It's working in Jaunty for me now.

Followed the guide at https://help.ubuntu.com/community/OpenChrome for compiling 2D driver.

Got the patch with wget into openchrome/src folder and ran patch -p1 km400_panel.patch

Then ran /autogen.sh --prefix=/usr
make
sudo make install

And voila! I'm in now! Here's my Xorg.0.log for the working set up.

pinzia (pinzia) wrote :

fixed for me on jaunty with patch

Changed in openchrome:
status: Unknown → New
summary: - [8.10] Wrong xorg.conf file for VIA KM400 graphic chipset
+ [KM400][8.10] Wrong xorg.conf file for VIA KM400 graphic chipset
Bartosz Kosiorek (gang65) wrote :

Hi.
I have one small question for you:
Is screen scaling (to native panel resolution) is working.

I think it should not working.

Please build/install the latest openchrome driver and enable debug mode.
The detail build instruction is available at:
https://help.ubuntu.com/community/OpenChrome

Then replace the file src/via_panel.c
to I attached.

This patch should add panel screen scaling at CLE266 and KM400

Bartosz Kosiorek (gang65) wrote :
Bartosz Kosiorek (gang65) wrote :
Changed in xserver-xorg-driver-vesa:
status: New → Invalid
Changed in xserver-xorg-video-vesa (Ubuntu):
status: New → Invalid
Bartosz Kosiorek (gang65) wrote :

Please check if this error exists in the latest openchrome revision.

The detail build instruction is available at:
https://help.ubuntu.com/community/OpenChrome

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid
Changed in openchrome:
status: New → Fix Released
Changed in xserver-xorg-video-openchrome (Ubuntu):
assignee: nobody → Bartosz (gang65)
Bartosz Kosiorek (gang65) wrote :

This bug was resolved in the
http://www.openchrome.org/trac/changeset/785

Please build/install the latest openchrome revision and check if it works correctly.

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Incomplete → Triaged
Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Triaged → In Progress
Bartosz Kosiorek (gang65) wrote :

Fixed in Lucid Lynx

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: In Progress → Fix Released
Juan Jose Pablos (cheche) wrote :

I have a similar card, and using daily live cd still now working properly (does not crash but is not usable), I will try to report back

Maks (kolmax94) wrote :

I confirm this on 10.04. I have KM400 card:
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video (rev 01).
Ubuntu starts in low graphics mode with error just as in first post. When i press 'Cancel' screen turns black and monitor says "No signal". I can't get to console to edit xorg.conf, because 10.04 doesn't have 'safe graphics mode' and it can't boot normally in single mode.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.