VIA P4M800 graphics broken in Lubuntu/Xubuntu Saucy & 12.04.4 candidate

Bug #1205643 reported by Erick Brunzell on 2013-07-27
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-openchrome (Ubuntu)
Low
Unassigned
Declined for Precise by Maarten Lankhorst
Saucy
Low
george
Trusty
Low
Unassigned
xserver-xorg-video-openchrome-lts-saucy (Ubuntu)
Undecided
Unassigned
Declined for Precise by Maarten Lankhorst

Bug Description

* Impact:
- the driver doesn't work with the X.org version in 12.04 with the Saucy hardware enablement stack.

* Test case:
- try using 12.04 with the Saucy hardware enablement stack on a machine needing the openchrome driver.

* regression potential:
- check that xorg sessions work as they should. The patches have received testing in Debian/Trusty/Saucy and upstream, so presumably should be fairly safe. The number of people using openchrome is relatively small compared to the main X drivers, so the scope of risk is rather small here.

----------
Saucy Hardware Enablement Stack:

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

-------

Please bear with me and read all of this. Since I can't get a working display in Saucy with that graphics chip I need to use this method to file the initial bug report, but I can provide info using a chroot or replacing the "quiet splash" boot parameter with "text" which takes me to a tty interface.

I hope using the tty interface provided by using the "text" boot parameter I can use "apport-collect" to collect the info needed from an installed Lubuntu 13.10 but I won't do so until asked by a dev in case some "switch" needs to be set to collect the appropriate info.

I also want to say that I'm fully aware that graphics chip is not supported by Ubuntu/compiz itself, or even GNOME's mutter window manager, but I think it should still work with the openbox, metacity, and Xfwm window managers ...... at least I hope so :^)

So onto what actually happens. When I try to boot either Lubuntu or Xubuntu Saucy Alpha 2, either the live image or an installed version, I just get a frozen progress bar. So it's just 5 frozen dots on the screen. If I try booting through the recovery mode or otherwise trying to "startx" or "'sudo service lightdm start' I just get a blank screen. I can see the backlight is working but that's all.

This is the specific hardware:

VIA C7 CPU @ 1500MHz
VIA CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro] (rev 01)
VIA VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
1GB DDR2 RAM

I did take a pic of the live image boot process while dealing with an unrelated d-i bug during Lubuntu Alpha 2 testing process:

https://launchpadlibrarian.net/145894508/P4M800_xfreeze.JPG

Now I'm wondering what else to say ............... the same Saucy images and installs work with two other totally different sets of hardware.

I'm ready to roll up my sleeves to help gather any needed info. Thanks in advance.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1205643

tags: added: iso-testing
Jane Atkinson (irihapeti) wrote :

I'm getting the same problem with a very similar graphics chip: VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

Things have changed just a bit between the Alpha 2 images and the first of the Beta 1 testing images. I now no longer freeze while the progress bar is showing, but I still boot to a blank screen.

Erick Brunzell (lbsolost) wrote :

It had been suggested at the Lubuntu QA mailing list the following logs might be helpful:

/var/log/Xorg.0.log
/var/log/dmesg
/var/log/syslog

So I pulled the same from a lateral install in a dual boot after a blank screen boot and I'm attaching all three.

Erick Brunzell (lbsolost) wrote :

Seems I can't add more than one at a time so here's #2.

Erick Brunzell (lbsolost) wrote :

And #3.

Same problem here with standard Ubuntu:
Fujitsu Siemens Amilo Pro,
Chipset CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]

A workaround is to tell X to use the VESA driver. This will get you working graphics, but low performance:

Put the following into /usr/share/X11/xorg.conf.d/use-vesa.conf:
--------
  Section "Device"
          Identifier "Configured Video Device"
          Driver "vesa"
  EndSection
---------

Jane Atkinson (irihapeti) wrote :

The workaround works on my machine. "Low performance" seems to mean the vesa driver, which I have always used on this PC, and which is fine by me. Xorg cpu and memory usage seem to be the same as in 12.04.

Many thanks!

Erick Brunzell (lbsolost) wrote :

Well I'd prefer finding out what "broke" in the openchrome driver, otherwise I prefer sticking with 12.04 which is supported until April 2017.

Erick Brunzell (lbsolost) wrote :

Still broken in Lubuntu Trusty 20131129 i386.

tags: added: saucy trusty
Maarten Lankhorst (mlankhorst) wrote :

Does this still happen with xserver-xorg-video-openchrome 0.3.3-1?

affects: xorg (Ubuntu) → xserver-xorg-video-openchrome (Ubuntu)
Changed in xserver-xorg-video-openchrome (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Erick Brunzell (lbsolost) wrote :

@ Maarten Lankhorst,

Yes. When I boot the Lubuntu Trusty 20131129 i386 DVD to the llive DE on that VIA P4M800 box I just get a blank screen, but you can tell the backlight is on.

Booting the same image on my Intel box shows this version info:

lubuntu@lubuntu:~$ dpkg -s xserver-xorg-video-openchrome
Package: xserver-xorg-video-openchrome
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 521
Maintainer: Ubuntu Developers <email address hidden>
Architecture: i386
Version: 1:0.3.3-1
Provides: xorg-driver-video
Depends: libc6 (>= 2.4), libdrm2 (>= 2.3.1), libx11-6 (>= 2:1.4.99.1), libxext6, libxv1, libxvmc1, xorg-video-abi-14, xserver-xorg-core (>= 2:1.14.2.901-2ubuntu4~)
Description: X.Org X server -- VIA display driver
 OpenChrome is a project for the development of free and open-source drivers
 for the VIA UniChrome video chipsets.
 .
 Originally called the 'snapshot' release, since it was a snapshot of an
 experimental branch of the unichrome cvs code, this is a continued development
 of the open source unichrome driver (from http://unichrome.sf.net) which
 also incorporates support for the unichrome-pro chipsets.
 .
 Support for hardware acceleration (XvMC) for all chipsets has subsequently
 been ripped out of the unichrome.sf.net driver. Therefore your only option if
 you wish to make use of the acceleration features of your VIA chip with free
 and open-source drivers is to use this version of the driver.
Original-Maintainer: Debian X Strike Force <email address hidden>
Homepage: http://www.openchrome.org

AFAIK this broke between Saucy Alpha 1 and Saucy Alpha 2 but I could never find anything in the changelog to give me any clues.

summary: - VIA P4M800 graphics broken in Lubuntu/Xubuntu Saucy
+ VIA P4M800 graphics broken in Lubuntu/Xubuntu Saucy & Trusty

The latest update is working with the following chip:

01:00.0 VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01)

Andrea (stilnovo1) wrote :

Hallo! Same bug and same computer (Fujitsu-Siemens Amilo L7320).
I'd like to install Lubuntu 13.10 on this machine but, since I'm not able to do it, I've tried also with Ubuntu 12.04 and other 'flavours'.

Lubuntu and Xubuntu 13.10 have the same problem of this description (it freezes during installation), Ubuntu gives an unusuable interface (without pointer, strange colours etc.). The only one I was able to use on this machine has been the liveCD of Kubuntu 12.04. Once installed, also this doesn't work anymore (I had to force xorg to use vesa driver creating a xorg.conf file, but the result is a poor graphic result). The liveCD seems to have, strangely, better result.

It's the first message for me here, so excuse me if I have been redundant or OT, but I've found strange this behaviour and maybe it could be useful - or at least I hope it!

Erick Brunzell (lbsolost) wrote :

Support for P4M800 seems to be OK with Xubuntu Trusty 20131218 i386. Thanks Maarten :^)

I will follow up later.

Erick Brunzell (lbsolost) wrote :

Also just tried Edubuntu Trusty Alpha 1 and it's working fine in "flashback w/metacity" mode so I think this could be marked "fix released"???

Any thoughts Maarten?

Andrea (stilnovo1) wrote :

The problem still exists for Lubuntu Saucy i386... (Via P4M800)

Erick Brunzell (lbsolost) wrote :

Thanks for the reminder Andrea.

Andrea (stilnovo1) wrote :

Hi to Everybody!

Please, don't give up on this point. My Company has accepted my proposal to switch all computers to Lubuntu, after a test period in order to understand if all employees can use it. You can imagine, they are a little bit suspicious!

So, on a total of 21 Pcs (most of them with XP... so, it's the right moment to change), I've installed on 3 desktop Pcs Saucy, and now they are working fine from one month (after another month passed to solve a problem with another graphic card - Nvidia Riva).

7 of those computers are unluckily Fujitsu-Siemens Amilo L7320 (so with the VIA P4M800), given to our salesmen. Until now, I was able -as written above- to only install Kubuntu 12.04, forcing it to use vesa drivers so with faded colors and lower resolution (although correct settings in xorg.conf file, that I effectively find in Xorg.log, except for the screen resolution that fails to set).

Doing the same (poor) result with Lubuntu 13.10 seems more difficult, at least for me (I wasn't able to go after the beginning of the installation, since it freezes).

I've tried to force to load Unichrome setting correct values of frequency, screen resolutions etc, but the best result I have obtained in this case is a text mode.

I hope in the solution of this point, thanks in advance for your precious support!

summary: - VIA P4M800 graphics broken in Lubuntu/Xubuntu Saucy & Trusty
+ VIA P4M800 graphics broken in Lubuntu/Xubuntu Saucy & 12.04.4 candidate
Erick Brunzell (lbsolost) wrote :

I recently noticed that the Saucy Hardware Enablement Stack had been added to the Precise daily builds so I tested Ubuntu Precise i386 20140118 and not surprisingly it has the same problem as Saucy with the P4M800 chips.

I personally prefer using the archived Ubuntu 12.04.1 i386 images because the original kernel and X-stack will be supported until April 2017 at which point these graphics chips will be 9 to 10 years old:

http://old-releases.ubuntu.com/releases/precise/

And another advantage of using the Ubuntu images is that they include Unity-2D as a fallback or if you prefer more of an older desktop paradigm you can follow this procedure:

http://ubuntuforums.org/showthread.php?t=1966370

That should hopefully satisfy many of the Win XP converts :^)

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Incomplete → Confirmed
Andrea (stilnovo1) wrote :

Hi Mr. Brunzell!

First of all, thank you very much for your suggestions, that I have really appreciated!
Thanks for the links.

However, we notice that people in our Company seem to appreciate Lubuntu 13.10 for many reasons, above all for the same way of use and feeling XP has. I suppose that the passage towards other desktops, at the beginning, could be harder for us to get it accepted by all the employees. Until now, we have 4 Desktops that are running Lubuntu 13.10 and the testers seem quite accustomed in the daily use now. We see that they are learning very fast.

So, I hope that developers will consider also this chipset (VIA P4M800) because this is the problem now for us.
In the future, once all the employees will have used this OS for some time and will have accepted it, for sure we will buy hardware with more compatibility or expressely designed for (L)Ubuntu, but in this moment we have these Amilo laptops that are running XP... (and one with Kubuntu 12.04 and the horrible Vesa drivers, XP seems a Ferrari in comparison).

Thanks in advance!

Erick Brunzell (lbsolost) wrote :

@ Andrea,

I totally understand what you're saying. I should first say that I'm not a dev, just an end user/tester that also maintains a relatively large number of PC's.

Are you aware that Saucy is only supported until July 2014?

https://wiki.ubuntu.com/Releases

IMHO Precise is a much better choice for mass deployment because it does have a long life cycle :^)

But a lot of this gets off-topic here so I subscribed to this forum thread:

http://ubuntuforums.org/showthread.php?t=2174725

I'm kansasnoob there and I will try to reply as quickly as possible.

Bartosz Kosiorek (gang65) wrote :

Hi Erick.
Please attach yout /etc/X11/xorg.conf file to this ticket.

Erick Brunzell (lbsolost) wrote :

Hi Bartosz.

I assume you want those from Saucy and and the Saucy Hardware Enablement Stack in the 12.04.4 candidates. Is that correct?

I'm just preparing for Trusty Alpha 2 testing for flavors so it could be next week before I get back to this.

Timo Aaltonen (tjaalton) wrote :

bartosz: there is no xorg.conf by default

looking at the log it probably hangs at enabling EXA

Erick Brunzell (lbsolost) wrote :

Still working in Edubuntu Trusty 20140121.1 i386 :^)

Timo Aaltonen (tjaalton) wrote :

trusty works? then this can be closed..

Erick Brunzell (lbsolost) wrote :

Well, I think it should show fix released for Trusty, but a dev will have to decide if Saucy and the Saucy hardware enablement stack for 12.04.4 are going to get a won't fix or what.

Maarten Lankhorst (mlankhorst) wrote :

If you feel like doing the stablerelease update paperwork and verifications, you could get it fixed in saucy (and indirectly lts-saucy). But that would take some efford into finding out the bare minimum to make things work, which is probably too much work. :)

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-openchrome (Ubuntu Saucy):
assignee: nobody → Dmitry Shachnev (mitya57)
importance: Undecided → Low
status: New → In Progress
Changed in xserver-xorg-video-openchrome (Ubuntu Saucy):
assignee: Dmitry Shachnev (mitya57) → Erick Brunzell (lbsolost)
Erick Brunzell (lbsolost) wrote :

I think Saucy, and the 13.10 hardware enablement stack for Precise should both be marked won't fix because they're only supported through July of this year. But I'm not qualified to mark it as such.

I will continue to test Edubuntu Trusty w/Flashback (Metacity) to watch for any regressions before it's released in April. And as I mentioned in comment #21 the typical Precise end user is wise to just use the archived 12.04.1 images for fresh installs.

Changed in xserver-xorg-video-openchrome (Ubuntu Saucy):
assignee: Erick Brunzell (lbsolost) → nobody
status: In Progress → Confirmed
Dmitry Shachnev (mitya57) wrote :

> I think Saucy, and the 13.10 hardware enablement stack for Precise should both be marked won't fix because they're only supported through July of this year. But I'm not qualified to mark it as such.

Done.

Changed in xserver-xorg-video-openchrome (Ubuntu Saucy):
status: Confirmed → Won't Fix
Erick Brunzell (lbsolost) wrote :

I reported this on the QA Tracker for 12.04.4 just in case the Release Team thinks it warrants a mention in the release notes.

Andrea (stilnovo1) wrote :

Hi to all!
I've read this: http://www.omgubuntu.co.uk/2014/02/ubuntu-12-04-4-released-new-kernel

Does this affect also "our" bug?

Erick Brunzell (lbsolost) wrote :

@ Andrea,

Yes, 12.04.4 ships with the Saucy Hardware Enablement Stack:

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

So those images won't work with VIA P4M800 graphics. I prefer using the archived 12.04.1 images because I have too many computers spread out over too large of an area and the original Precise kernel and X-stack is supported until April 2017 whereas the later point releases will require either upgrading to Trusty, or to the Trusty HWE stack by August 2014.

Andrea (stilnovo1) wrote :

Thank you very much, Erick! I've read also your past posts here, so now I have "only" to learn if it's possible to 'downgrade' my X-stack....

Andrea (stilnovo1) wrote :

Hi to all.

Reinstalled Ubuntu 12.04.1 on the Amilo 7320 (see my past messages here) but the installation freezes towards the end... is the X-stack the same also for the 12.04.0?

Erick Brunzell (lbsolost) wrote :

@ Andrea,

The 12.04 and 12.04.1 images use the same basic kernel and X-stack (other than bug fixes and security updates) so I suspect you're dealing with an additional issue. You should first of all rule out a bad disc/USB (depending on which you're using to install) by entering the advanced boot options as described here:

https://help.ubuntu.com/community/BootOptions#Ubuntu_CD_Advanced_Welcome_Page_Options

Then select Check disc for defects. That will take several minutes to complete, but unless it shows no errors found then you have bad installation media.

Additionally a quick Google search shows that the hardware involved may be:

Intel Celeron M 1.70GHz
VIA/S3G UniChrome Pro IGP
512MB RAM

Have you upgraded the RAM? If you're still running with 512MB of RAM you can probably still install Ubuntu Precise but you'll once again have to enter the advanced boot options and choose Install Ubuntu from that menu. Or you may need to use the Alternate CD.

Also DO NOT choose to download updates or install 3rd party software when asked, and DO NOT choose to automatically login. Some of the reasoning behind that is based solely on personal experience and goes far beyond the scope of this bug report.

I also think that you'll likely find that Unity-2D is even quite slow on that hardware so you'll likely want to do something like this:

http://ubuntuforums.org/showthread.php?t=1966370

In fact if you have or are willing to create an Ubuntu Forums account you could post in that thread and I'll be glad to try and help you. I'm kansasnoob there :^)

Andrea (stilnovo1) wrote :
Download full text (3.2 KiB)

@ Erick: many thanks for the suggestion, I'll create an account in Ubuntu Forums as you suggested.

But I post also there the results of the last Ubuntu-based saturday, when I did many installations and all of them affected by the impossiblity to get a working x-server:

- 1st installation: Ubuntu 12.04.1 - i386 desktop version - the installation is very slow, it freezes towards the end. The Livecd session works very fine, correct maximum screen resolution, good colours. Tried to install also from the Livecd session. Grub damaged.

- 2nd installation: Ubuntu 12.04.0 - i 386 desktop version - the installation is quicker, but it freezes from livecd session (graphics ok). In the direct installation it seizes up, but you can continue if you continue to hold a key... at the end, grubs work (I can start XP session and Ubuntu recovery mode), but during the loading, after a fast appearing of the Ubuntu logo, it freezes in a dark screen... no way to enter in a terminal. In the recovery mode, I tried failsafeX session, but after a while a "window" appears: the message says that it is impossible to identify monitor and graphic card, then it returns to the recovery menu without starting a low-resolution session

- 3rd installation: Kubuntu 12.04.1 - i386 desktop version - i don't try livecd session, I directly start with the installation. Also here I have to hold an any key to keep the installation ongoing, otherwise it freezes but it is sufficient to return to hold a key and it restarts. At the end, I have a working grub and it loads the system without freezing. At the beginning, all seems ok, the screen resolution is the correct WXGA and not the XGA that I had in the previous installation when I forced Kubuntu to use vesa drivers.
After a little bit, the system begins to continuously crash, a message (I have been stupid not to literally write the contents, but I was quite tired...) appears and more or less says that 'probably a bad graphic driver is installed'. I try to reconfigure Xserver, but after about ten minutes the system becomes very slow, it's difficult to use it although the nice grapchic result... so I'm ready for...

- 4th installation: Ubuntu 12.04.0 - alternate version. Here the installation is very fast and smooth. When I restart, the Ubuntu logo appears but the loading freezes in the "usual dark" screen. Then I did the same passage of 2nd installation with failsafeX and the same message that it's impossible to determine screen and graphic card... so I have created a xorg.conf file forcing to load openchrome as this: http://www.linlap.com/fujitsu_amilo_l7320gw
The system freezes during the loading, so in the 'usual' recovery mode I've modified the xorg.conf file replacing 'openchrome' with 'vesa' (sic!).

Ok, now the system starts, with the same problems of my first post here (XGA resolution instead of WXGA, faded colours etc.)... am I correct if I say that perhaps it's a bug of openchrome driver more than X-stack?

Excuse me if I've been a little bit talkative, but I desired only to be clear... obviously now (with vesa) the system works also with 12.04.4 (after the updates).

@Erick: yes, the ram is 1gb, the cpu is that but later I'l...

Read more...

Alberto Jovito (thedemon007) wrote :

Hello Erick Brunzell, or anyone else affected,

Accepted xserver-xorg-video-openchrome into saucy-proposed. The package are available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/1:0.3.1-0ubuntu2.2 the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested.

How to start, out X.org crash:

Replacing the "quiet splash" boot parameter with "xforcevesa". After starting delete xorg.conf, "sudo rm / etc/X11/xorg.conf"

Erick Brunzell (lbsolost) wrote :

Thanks Alberto, yes it worked but it was sloppy on my end.

The vesa driver does not work well here (too much screen tearing) so I had to approach this by installing Lubuntu Saucy and then handling the rest in a chroot, but the attached apt logs should show you what I have.

I will not however give this a "verification done" until we see how it works in the Precise daily's with the Saucy hardware enablement stack:

http://cdimage.ubuntu.com/precise/daily-live/current/

Because we'll need to be sure that upgrades from the Saucy enablement stack to the Trusty enablement stack work OK in Precise when the time comes.

Erick Brunzell (lbsolost) wrote :

And the apt/term log

Erick Brunzell (lbsolost) wrote :

BTW if you can get this into the Precise daily I'll be glad to test them but remember we're on the brink of Trusty so testing could be delayed several days.

Erick Brunzell (lbsolost) wrote :

Just setting up my test suite for Trusty final testing and I see that we've moved the xserver-xorg-video-openchrome (1:0.3.1-0ubuntu2.2) saucy from saucy-proposed to saucy-main which is great. But we should now probably update the Saucy status from won't fix to fix released.

Then maybe Maarten could change the status for Precise also. I see no reason why this shouldn't be included in the Precise daily builds, and I have Precise running the Raring HWE stack on the effected box so I could even try updating to the Saucy HWE stack after I'm done with Trusty testing.

Good work, many thanks.

no longer affects: xserver-xorg-video-openchrome-lts-saucy (Ubuntu Trusty)
no longer affects: xserver-xorg-video-openchrome-lts-saucy (Ubuntu Saucy)
Changed in xserver-xorg-video-openchrome-lts-saucy (Ubuntu):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

xserver-xorg-video-openchrome 1:0.3.1-0ubuntu2.2 is now in saucy-updates.

Changed in xserver-xorg-video-openchrome (Ubuntu Saucy):
status: Won't Fix → Fix Released
Alberto Jovito (thedemon007) wrote :

Is necessary to update the package, I attach a debdiff.

Thanks Erick for the test.

Xubuntu 13.10 have other bug #1296449 not related to this.

Alberto Jovito (thedemon007) wrote :

I guess it needs SRU informations (https://wiki.ubuntu.com/StableReleaseUpdates), I'm adding some to the description, feel free to update same with more specific details.

description: updated
tags: added: patch
description: updated
george (george98-2010) on 2014-04-16
Changed in xserver-xorg-video-openchrome (Ubuntu Saucy):
assignee: nobody → george (george98-2010)
Dmitry Shachnev (mitya57) wrote :

I am not very comfortable with removing "miInitializeBackingStore(pScreen);" call. If it "causes no regression in earlier versions", that does not mean anything, as you can't cover all test cases.

Why was that line added?

Changed in xserver-xorg-video-openchrome-lts-saucy (Ubuntu):
status: Confirmed → Incomplete
Download full text (3.9 KiB)

20 cze 2014 06:23 "Alberto Jovito" <email address hidden> napisał(a):

> This function is only for source compatibility with old drivers. source:
> http://lists.x.org/archives/xorg-devel/2012-August/033405.html
>
> Not only these drivers was removed this call..
> http://lists.x.org/archives/xorg-devel/2012-November/034541.html
> https://build.opensuse.org/package/view_file/openSUSE:13.1/xf86-video-
> siliconmotion/U_Remove-miInitializeBackingStore.patch?expand=1
>
> --
> You received this bug notification because you are subscribed to
> xserver-xorg-video-openchrome in Ubuntu.
> https://bugs.launchpad.net/bugs/1205643
>
> Title:
> VIA P4M800 graphics broken in Lubuntu/Xubuntu Saucy & 12.04.4
> candidate
>
> Status in “xserver-xorg-video-openchrome” package in Ubuntu:
> Fix Released
> Status in “xserver-xorg-video-openchrome-lts-saucy” package in Ubuntu:
> Incomplete
> Status in “xserver-xorg-video-openchrome” source package in Saucy:
> Fix Released
> Status in “xserver-xorg-video-openchrome” source package in Trusty:
> Fix Released
>
> Bug description:
> * Impact:
> - the driver doesn't work with the X.org version in 12.04 with the Saucy
> hardware enablement stack.
>
> * Test case:
> - try using 12.04 with the Saucy hardware enablement stack on a machine
> needing the openchrome driver.
>
> * regression potential:
> - check that xorg sessions work as they should. The patches have
> received testing in Debian/Trusty/Saucy and upstream, so presumably should
> be fairly safe. The number of people using openchrome is relatively small
> compared to the main X drivers, so the scope of risk is rather small here.
>
> ----------
> Saucy Hardware Enablement Stack:
>
> https://wiki.ubuntu.com/Kernel/LTSEnablementStack
>
> -------
>
> Please bear with me and read all of this. Since I can't get a working
> display in Saucy with that graphics chip I need to use this method to
> file the initial bug report, but I can provide info using a chroot or
> replacing the "quiet splash" boot parameter with "text" which takes me
> to a tty interface.
>
> I hope using the tty interface provided by using the "text" boot
> parameter I can use "apport-collect" to collect the info needed from
> an installed Lubuntu 13.10 but I won't do so until asked by a dev in
> case some "switch" needs to be set to collect the appropriate info.
>
> I also want to say that I'm fully aware that graphics chip is not
> supported by Ubuntu/compiz itself, or even GNOME's mutter window
> manager, but I think it should still work with the openbox, metacity,
> and Xfwm window managers ...... at least I hope so :^)
>
> So onto what actually happens. When I try to boot either Lubuntu or
> Xubuntu Saucy Alpha 2, either the live image or an installed version,
> I just get a frozen progress bar. So it's just 5 frozen dots on the
> screen. If I try booting through the recovery mode or otherwise trying
> to "startx" or "'sudo service lightdm start' I just get a blank
> screen. I can see the backlight is working but that's all.
>
> This is the specific hardware:
>
> VIA C7 CPU @ 1500MHz
> VIA CN700/P4M800 Pro/P4M800 CE/...

Read more...

Erick Brunzell (lbsolost) wrote :

Can someone with authorization change the status in "xserver-xorg-video-openchrome-lts-saucy" from Incomplete to Won't fix?

That should end any action needed on this bug report. Thanks in advance.

Dmitry Shachnev (mitya57) wrote :

I have uploaded the patch to precise-proposed, it is waiting in the SRU queue (it's NEW instead of UNAPPROVED because of a bug in Launchpad).

Changed in xserver-xorg-video-openchrome-lts-saucy (Ubuntu):
status: Incomplete → In Progress
Iain Lane (laney) on 2014-06-30
Changed in xserver-xorg-video-openchrome-lts-saucy (Ubuntu):
status: In Progress → Won't Fix
gajdipajti (gajdipajti) wrote :

I don't want to reopen the thread, just add some new information.

@Andrea: #15 #20 #39
The freezing problems you experience on the Amilo L7320 laptops are not related to the openchrome driver, it is a bug related to the APIC (or to a BIOS bug). It started with Ubuntu 10.10 (kernel 2.6.35). The clocksources are not detected or discarded by the kernel, and to work around this problem the kernel parameters [noapic, nolapic, nomodeset] can be used during boot time. (Btw I was also able to reproduce the problem on Fedora 15 and Debian Wheezy). For the Ubuntu 12.04 the nolapic parameter worked for me, for Lubuntu 16.10 and Lubuntu 17.04 (daily snapshot) nomodeset solves the problem. At the moment I am using Lubuntu 12.04 (kernel 3.2.0-120-generic):

  cat /sys/devices/system/clocksource/clocksource0/available_clocksource
  tsc pit jiffies

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers