X not starting after install [openchrome]

Bug #1041625 reported by Lars Noodén on 2012-08-25
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
openchrome
Fix Released
Critical
xserver-xorg-video-openchrome (Ubuntu)
High
Unassigned

Bug Description

The installation runs through to completion but the system fails to boot normally.
Instead of the graphical log in, the is a screenful of fontconfig warnings.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic i686
ApportVersion: 2.5.1-0ubuntu2
Architecture: i386
Date: Sat Aug 25 22:15:43 2012
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Evaluating ubuntu 12.10 alpha on Via c7 platform. Initially worked fine using VBE mode for xorg driver and grub_gfx_payload=keep. After installing latest updates of ubuntu Xorg didn't work anymore.

Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :
summary: - Fontconfig warning in lubuntu i386
+ X not starting after install / Fontconfig warning in lubuntu i386

My gut feeling here is that the fontconfig warnings are a red herring - that's happening on quantal a lot at the moment.

So the real question is why are you at a text screen and not a GUI;
   1) On the machine that won't boot, at the prompt please try apport-cli -u 1041625 if we're lucky it might add some logs to launchpad.

   2) If the machine has a /var/log/lightdm please attach the logs in there to this report.

Dave

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Lars Noodén (larsnooden) wrote :

Trying to run 'apport-cli -u 1041625' gives this error:

ERROR: The launchpadlib Python module is not installed. This functionality is not available.

That occurs even after installing the module 'python-launchpadlib'

So attached is the lightdm.log file. Are there any other files or outputs to collect manually?

Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :

For what it's worth, I cannot forward X over ssh from that machine as it currently is.

Try the boot option:

nomodeset

The only way I have seen those chips work is with a /etc/X11/xorg.conf file

Lars Noodén (larsnooden) wrote :

Adding nomodeset to the boot options for linux in grub leaves the machine frozen at the splash screen, but the consoles are still available and I can still log in with ssh.

Dave Gilbert (ubuntu-treblig) wrote :

Looking at the Xorg.0.log we have the following; so it's an X server crash:

[ 23.755] (EE) Backtrace:
[ 23.755] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0xb77519e9]
[ 23.755] (EE) 1: /usr/bin/X (0xb75aa000+0x1ab8d6) [0xb77558d6]
[ 23.755] (EE) 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb758740c]
[ 23.755] (EE) 3: /usr/lib/xorg/modules/drivers/openchrome_drv.so (0xb6ff7000+0x14eed) [0xb700beed]
[ 23.755] (EE) 4: /usr/bin/X (0xb75aa000+0xcfa02) [0xb7679a02]
[ 23.755] (EE) 5: /usr/bin/X (0xb75aa000+0xcff5b) [0xb7679f5b]
[ 23.755] (EE) 6: /usr/bin/X (0xb75aa000+0xcffe5) [0xb7679fe5]
[ 23.756] (EE) 7: /usr/bin/X (xf86I2CProbeAddress+0x6a) [0xb767a14a]
[ 23.756] (EE) 8: /usr/lib/xorg/modules/drivers/openchrome_drv.so (0xb6ff7000+0x1b4eb) [0xb70124eb]
[ 23.756] (EE) 9: /usr/lib/xorg/modules/drivers/openchrome_drv.so (0xb6ff7000+0x11111) [0xb7008111]
[ 23.756] (EE) 10: /usr/lib/xorg/modules/drivers/openchrome_drv.so (0xb6ff7000+0x144c9) [0xb700b4c9]
[ 23.756] (EE) 11: /usr/bin/X (InitOutput+0xb36) [0xb762d676]
[ 23.756] (EE) 12: /usr/bin/X (0xb75aa000+0x29ef6) [0xb75d3ef6]
[ 23.756] (EE) 13: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0xb72094d3]
[ 23.756] (EE) 14: /usr/bin/X (0xb75aa000+0x2a4d9) [0xb75d44d9]
[ 23.756] (EE)
[ 23.756] (EE) Segmentation fault at address 0xfc
[ 23.756]
Fatal server error:
[ 23.756] Caught signal 11 (Segmentation fault). Server aborting
[ 23.756]
[ 23.756] (EE)
Please consult the The X.Org Foundation support
  at http://wiki.x.org

affects: ubiquity (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: Incomplete → New
summary: - X not starting after install / Fontconfig warning in lubuntu i386
+ X not starting after install [openchrome]
Dave Gilbert (ubuntu-treblig) wrote :

Lars, can you install the xserver-xorg-video-openchrome-dbg package (sudo apt-get install xserver-xorg-video-openchrome-dbg), then reboot and attach the new Xorg.0.log; with any luck it'll have a better backtrace in.

Dave

Lars Noodén (larsnooden) wrote :

Here is the new Xorg.0.log after xserver-xorg-video-openchrome-dbg was added and then the machine rebooted.

Dave Gilbert (ubuntu-treblig) wrote :

High->A problem with an essential hardware component (Video card)

affects: xorg (Ubuntu) → xserver-xorg-video-openchrome (Ubuntu)
Changed in xserver-xorg-video-openchrome (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

OK, thanks - doesn't look like it's added any more info there, I'll just have to hand this over to the X guys.

Erick Brunzell (lbsolost) wrote :

Lars, I'm not sure this is related but I'm unable to even boot Lubuntu i386 20120827 to the live desktop on my old VIA box:

VIA C7 CPU @ 1500MHz
VIA CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro] (rev 01)
VIA VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
1GB DDR2 RAM

I just get as far as the error displayed in the attachment.

The images have actually been this way ever since Ubuntu dropped Unity-2D.

Just thought it'd be wise to share the info ;^)

Erick Brunzell (lbsolost) wrote :

Just out of curiosity I tried installing Lubuntu QQ alpha 3 on the aforementioned hardware. All went fine other than one totally unrelated ubiquity bug.

After installing I applied the available updates, I did NOT enable "proposed", but then it's no longer able to boot into that old (circa 2007) VIA hardware. I get the errors shown in these really horrible pics.

I really wish i could grab better pics of the screen but I'm old, frail, and shaky :^(

Lars Noodén (larsnooden) wrote :

Just to note, the graphical install from the Desktop image displays just fine.

Lars Noodén (larsnooden) wrote :

Just to note, the graphical install from the Desktop image displays just fine -- during the installation itself. Afterwards, there is the same problem with X not working.

Erick Brunzell (lbsolost) wrote :

Thanks Lars. It sounds like I need to file a new bug report.

Lars Noodén (larsnooden) wrote :

Trying the Live cd, it also is unable to start a graphical mode if I choose "Try Lubuntu without installing", but if I choose "Install Lubuntu", I get the graphical installer which works well.

Can you please provide the xorg log with the crash ?
Anyway, I suspect this is already fixed by this commit : http://cgit.freedesktop.org/openchrome/xf86-video-openchrome/commit/?id=131175a7163a9189d70ed3118b45eaceb27898c0

Erick Brunzell (lbsolost) wrote :

OK, did you look at those pics in comment #16?

Lots of font config errors followed by:

Starting Mount network filesystems
Stopping Mount network filesystems

The third pic in that set is the easiest to read but it only shows about the left half of the screen.

I'm fairly well convinced that we're bitten by the same bug, me with "VIA CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro] (rev 01)" graphics and you with "VIA Technologies, Inc. CN400/PM800/PM880/PN800/PN880 [S3 UniChrome Pro] (rev 02)".

The last iso I found to work was Ubuntu i386 20120815. Shortly thereafter Ubuntu dropped Unity-2D so I wasn't surprised to see support dropped or broken for my P4M800 but I'd think that should not effect the other flavors.

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

Oops, that attachment was supposed to be accompanied by this text:

Trying to boot or even update through recovery mode after enabling networking displays these '/lib/udev/mtp-probe' errors.

Erick Brunzell (lbsolost) wrote :

After installing a fresh Lubuntu i386 alpha3 and upgrading only 'libmtp-common' and 'libmtp9' I get a very slow boot - I mean 3 to 4 minutes!

From looking at the changelogs I seriously doubt that this is actually an xserver bug but I lack the tech knowledge to proceed so any help would be appreciated.

Erick Brunzell (lbsolost) wrote :

BTW this is the box that I use for testing both ubiquity and d-i so it's really important to me. I'd really like to test all of the recent installer changes on bare metal ;^)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1041625

tags: added: iso-testing
Michael Moroni (airon90) wrote :

This is my xorg.0.log file: I have Quantal updated to the latest version and I cannot load X drivers so I have to use Ubuntu 12.04.
I hope this bug will be fixed soon

Jarosław Huba (jarhuba-p) wrote :

This bug could be related to this:
http://wiki.openchrome.org/pipermail/openchrome-devel/2012-August/000737.html
Rebuilding openchrome on new xorg could fix this issue.

Dave Gilbert (ubuntu-treblig) wrote :

I agree with Jarosław's comment #29, that this looks like http://wiki.openchrome.org/pipermail/openchrome-devel/2012-August/000737.html you can see the i2cProbeAddress call in the backtraces from both Lars and Michael.

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Confirmed → Triaged
Bartosz Kosiorek (gang65) wrote :

This bug was already fixed in following commit:
http://cgit.freedesktop.org/openchrome/xf86-video-openchrome/commit/?id=131175a7163a9189d70ed3118b45eaceb27898c0

The new version of openchrome will be released soon.

Changed in openchrome:
importance: Unknown → Critical
status: Unknown → Confirmed
Lars Noodén (larsnooden) wrote :

I'm not sure if this is the same bug, see attached Xorg.0.log. X starts but only shows the mouse, no other activities or screens are available.

openchrome 0.3.1 has been released. I believe it should fix this issue. Can you please confirm ?

Bartosz Kosiorek (gang65) wrote :

Hi Lars.

Try build the latest openchrome revision according to instruction available on website:
https://help.ubuntu.com/community/OpenChrome#Manual_Installation

To do that try to login into safemode.

The latest revision should solve your problem.

Hi Xavier,

It looks like ubuntu 12.10 doesn't have the updated version yet.
Should I build the new version from source code or I can wait for ubuntu maintainers to build it?

Thanks for support,
Sergey

It depends on how fast you want to confirm this is actually fixed or not. I'm not surprised Ubuntu doesn't have an updated package yet, I've uploaded the new release less than 24 hours ago ;-)

If you want to build from source, you might want to look at this : http://www.openchrome.org/trac/wiki/Installation#Installfromareleasetarball

Walter Lapchynski (wxl) wrote :

it seems that ppc is having a problem with X, too, but i don't think it's the same problem. furthermore, i don't think any apple computer (i realize there are other ppc machines out there but they tend to be more rare) ever had a chipset supported by openchrome. someone correct me if i'm wrong. but it sounds like lars' ppc problem needs to be made into a new bug.

Ron Mitchell (rm2892) wrote :

I'm a newbie here, and most of this is going way over my head.

However I've been having trouble with Lubuntu 12.10 (PPC desktop) for the past few days, right up to today's build (Sept 5).

1) wireless network applet on the lower task bar appears to be dead. When I click on it, nothing happens.

2) If I click on the "Install Lubuntu" CD icon, top left hand corner, the header of a window appears. It's entitled "Install:", but all I see is the header and the outline of where the dialogue box is supposed to be.

3) If I open PCManFM, the colour scheme is completely seems distorted in places particularly at the top left just under the tool bar, where the forward/back buttons are. Horizontally striped colours that make the buttons almost unreadable.

4) "If I try to Quit the Installation, there is another blank dialogue box with only a red circled exclamation point at the left top and the words "Quit the installation? " in the centre, and the usual - + X buttons at the right.

All of this with today's build running an an eMac G4 PPC running at 1.2 Ghz - 4 Gig Ram - 80 Gig hard drive.

Should I be filing bug reports, or are these issues already known?

Ron Mitchell
Sept 5 2012

Created attachment 66704
Xorg log

Hi Xavier,

I've managed to build openchrome 0.3.1 driver and now after X is started the screen gets black and I can't even get console (Ctrl+Alt+F1). I've checked Xorg.0.log(attached) but couldn't find any error message. Could it be something special with my system using VBE mode ?

Thanks,
Sergey

Created attachment 66710
Xorg crashed log with openchrome v0.3.0

Created attachment 66711
xorg.conf

Try to disable VBE mode, and attach Xorg.0.log from openchrome 0.3.1

Ron Mitchell (rm2892) wrote :

To add more to my comment above:

Greg suggested doing a particular keypress combination ( <cntl-AppleCommand-T>) while Plymouth was loading. That put us into a CLI of sorts, and eventually the live disk desktop loaded cleanly. All the problems reported above went away.

Did an install to my main internal hard drive from there.

The result was an install that worked, but is still not clean. There are still distorted background colours on the toolbars. Doesn't seem to matter what app is tried, the toolbar shows up with horizontal multi-coloured stripes.

Ron M.

Ok, so the 0.3.0 crash is gone and it was the breakage I suspected.

Now, let's address the other issue. What is your screen and how is it connected to the board ? Why do you use VBE ? What happens if you remove the X conf, which basically will just not force VBE mode ?

@Bartosz : you were quicker than me ;-) The X log from 0.3.1 with VBE is in comment 5.

Xavier,

I don't actually know how the display is connected. The PC is a monoblock.
Initially it never worked without VBE mode.

Thanks,
Sergey

What is the exact brand and model of the hardware ? Also, if you have a link to the manufacturer website, it could help.

Rather than using VBE, try to force LVDS panel detection with Option "ForcePanel"

Xavier,

PC specs are here http://www.wincomm.com.tw/product/pdf/WLP-6821-15.pdf

Besides VBE in xorg.conf I have modified grub configuration:
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=keep

This was supposed to make smooth handover from plymouth to xorg.

UPD: X now start using "ForcePanel", but Unity is so slow.

Thanks,
Sergey

Lars Noodén (larsnooden) wrote :

Bartosz, thanks. I tried building the latest openchrome revision according to the manual instructions:
https://help.ubuntu.com/community/OpenChrome#Manual_Installation

Success!

X now starts up on the i386. When will that version make it into the packages for Quantal?

Great to hear it works. The LVDS detection code is currently not as good as it could be. Please provide the xorg log, I'd like to take a look.

About 3D being slow, that is expected. The unichrome 3D driver has been dropped from Mesa because it is not yet ported to DRI2, so you are running on software rendering over LLVM pipe. Currently, the only way to improve the desktop experience would be to use another desktop manager which is not making such heavy use of 3D.

Lars Noodén (larsnooden) wrote :

Walter, I just tried building the latest openchrome for the PPC and the problem persists, so it is probably a different bug all together.

Walter Lapchynski (wxl) wrote :

Lars try adding video=ofonly. Either way please file a new bug for ppc.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-openchrome - 1:0.3.1-0ubuntu1

---------------
xserver-xorg-video-openchrome (1:0.3.1-0ubuntu1) quantal; urgency=low

  * Merge from unreleased debian git.

xserver-xorg-video-openchrome (1:0.3.1-1) UNRELEASED; urgency=low

  [ Maarten Lankhorst ]
  * Move to git.
  * Remove svn note in README.source
  * Remove README.VCS-source

  [ Timo Aaltonen ]
  * New upstream release. (LP: #1041625)
  * Remove 10-Deal-with-xserver-1.12.diff, not needed anymore.
  * control: Bump policy to 3.9.3, no changes.
 -- Timo Aaltonen <email address hidden> Thu, 06 Sep 2012 11:45:00 +0300

Changed in xserver-xorg-video-openchrome (Ubuntu):
status: Triaged → Fix Released
Bartosz Kosiorek (gang65) wrote :

The openchrome only supports the x86 and x86_64. The VIA Technologies doesn't have any PowerPC architectures.

Bartosz Kosiorek (gang65) wrote :

Here is complete list of chipset and architectures made by VIA technologies:
http://en.wikipedia.org/wiki/List_of_VIA_chipsets

Created attachment 66763
Xorg log with ForcePanel=yes

Morning Xavier,

Please find attached Xorg.0.log of a working openbox session with ForcePanel=yes.
OpenBox has no perfomance issues.

I've just updated the pc with apt-get and noticed that xserver-xorg-video-openchrome 0.3.1 was installed. That is pretty fast I guess :).

Thanks,
Sergey

Closing the bug now you're all set.

Thanks,
Xavier

Changed in openchrome:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.