Ubuntu

(NVidia only) Wrong default and maximum resolution on widescreen monitor (stretched 1024x768) on GeForce 6200

Reported by Mattias Wadenstein on 2005-12-15
66
Affects Status Importance Assigned to Milestone
X.Org X server
Won't Fix
Medium
xserver-xorg-video-nv (Ubuntu)
Wishlist
Unassigned

Bug Description

In a flight-2 install the graphical enviroment comes up at the wrong resolution. Instead of a nice and crisp 1600x1200 (native resolution on the TFT) we get a 1024x768 which is software scaled to 1280x1024, which the monitor then scales to 1600x1200.

The graphics card is a GeForce 6200 TurboCache(TM) on PCI Express16X according to nvidia-settings (after manually installing the nvidia driver instead of nv, things work fine).

I didn't manage to configure the nv driver into giving us the correct resolution, the logfiles said something about the resolution being dropped due to it being larger than the bios programmed panel size.

Changed in xorg:
assignee: nobody → daniels
Robert Entner (robertentner) wrote :

The same applies for me in Flight-3. I have a native resulotion of 1280x1024 and get 1024x768 on Flight-3-Live. No matter what resolution I choose at the boot prompt.

My TFT is connected to a NVidia card via digital connector.

I also get only 1024x768 resolution with 3004WTMi, instead of correct 1280x800.

I could bypass this problem on Dapper Flight 3 with 915resolution:
/usr/local/sbin/915resolution 38 1280 800
/usr/local/sbin/915resolution 49 1280 800
/usr/local/sbin/915resolution 58 1280 800
Using xorg.conf:
http://iki.fi/karvinen/acer_travelmate_3004wtmi_with_linux_notes.html#xorg.conf_for_1280x800_with_915resolution
Then restarting Xorg. I currently call the script from /etc/init.d/bootmisc.sh.
I have only done this on Dapper, I have not been able to fix resolution on 5.10 Breezy.

Using 915resolution breaks hibernate/suspend to disk.
https://launchpad.net/distros/ubuntu/+source/915resolution/+bug/6408

Daniel Stone (daniels) on 2006-03-10
Changed in xorg:
assignee: daniels → nobody
Manu Cornet (lmanul) wrote :

Have you tried the newest Flight CD (number 5) ?

On Fri, 17 Mar 2006, Manu Cornet wrote:

> Public bug report changed:
> https://launchpad.net/malone/bugs/5801
>
> Comment:
> Have you tried the newest Flight CD (number 5) ?

No, and I won't on this hardware. They are now in production use.

/Mattias Wadenstein

Doesn't work on Flight 5.

I tried Dapper Flight 5 on Acer Travelmate 3000 (3004WTMi). I installed Flight 5 from scratch (erasing all linux partitions) and it still did not work without 915resolution.

At least now the packaged version of 915resolution works and I did not have to compile it. Widescreen wrong resolution bypass: 'sudo apt-get install 915resolution', 'sudo nano /etc/default/915resolution', "MODE=54",
"XRESO=1280", "YRESO=800", alt-ctrl-backspace (restart X).

If widescreen support won't make it to Dapper release, I suggest that example configurations are put in comments in "/etc/default/915resolution".

can any of you please attach at least xorg.conf as it comes from the installation and a full Xorg.0.log?

Thanks
Fabio

Changed in xorg:
status: Unconfirmed → Needs Info

I notice this bug as well.

This is the xorg.conf from an flight-6 (x86) live cd session on an amd64 system with GeForce 6600GT.

The corresponding Xorg.0.log to the system described in the last comment.

It looks to me that the size of the monitor is selected correctly, but for some reason, the optimal display size, 1280x1024 in my case, is denied :(

I am using the latest development release. I upgraded from 5.10 to current development which is probably flight 7. The problem still exist. It is not setting resolution beyond 1024x768.

Matthew Lange (matthewlange) wrote :

Also happens on non-nvidia cards, reassigning to xserver-xorg in general, marking Bug #46767 as a duplicate of this bug, setting as confirmed, and marking as major because it affects presumably all widescreen laptops, widescreen desktops, and regular desktops whose native resolution are higher than 1024x768. I can confirm this happens on Dapper RC, as well as others in Bug #46767.

Changed in xserver-xorg-driver-nv:
status: Needs Info → Confirmed

Matthew: these might *appear* the same "My resolution is wrong", but actual solution and problem are different for each case, particularly each make of card.

For example:

  (a) The graphics card might not be detected and defaulting to 'vesa' (this requires PCI IDs adding to 'discover1-data').

  (b) DDC failing on the monitor and getting the wrong capabilities.

  (c) The Panelsize being wrong.

  (d) The BIOS modes to program the ideal resolution not being available.

and there are going to be others. The useful stuff we need is:

  /var/log/Xorg.0.log (X server log, which will show what driver is being used)

  $ lspci -vn (PCI-IDs to show what the card *actually is*).

  $ xresprobe ${DRIVER} (to find out if the DDC/FP size is correct).

Paul: It could be a case where these bugs are not duplicates. But if the bug
is appearing in all the cards then logically it must be locatable in some
code which is common to all the cards.

Regards,
-Pankaj

On 5/26/06, Paul Sladen <email address hidden> wrote:
>
> Matthew: these might *appear* the same "My resolution is wrong", but
> actual solution and problem are different for each case, particularly
> each make of card.
>
> For example:
>
> (a) The graphics card might not be detected and defaulting to 'vesa'
> (this requires PCI IDs adding to 'discover1-data').
>
> (b) DDC failing on the monitor and getting the wrong capabilities.
>
> (c) The Panelsize being wrong.
>
> (d) The BIOS modes to program the ideal resolution not being
> available.
>
> and there are going to be others. The useful stuff we need is:
>
> /var/log/Xorg.0.log (X server log, which will show what driver is
> being used)
>
> $ lspci -vn (PCI-IDs to show what the card *actually is*).
>
> $ xresprobe ${DRIVER} (to find out if the DDC/FP size is correct).
>
> --
> Wrong default and maximum resolution on widescreen monitor (stretched
> 1024x768)
> https://launchpad.net/bugs/5801
>

> if the bug is appearing in all the cards then logically it must be
> locatable in some code which is common to all the cards.

...Not if the monitors are all different.

>
> > if the bug is appearing in all the cards then logically it must be
> > locatable in some code which is common to all the cards.
>
> ...Not if the monitors are all different.

I understand that. But I don't know the internals of xorg codes. So if there
is come code which is common for all monitors, say code segment A and if
some code is common for graphics cards, say code segment B. Then if a bug is
reproduciable in all graphics cards then it should be somewhere in B or if
the bug is reproduciable for all monitors then it should be somewhere in A.

If there is no common code for graphics cards and monitors as explained
above then the bug is in all the respective codes for monitors and cards.

Regards,
Pankaj

Pankaj (pankaj-jangid) wrote :

Info:

dpkg-reconfigure xserver-xorg detects my card correctly as i810 (my laptop has intel 945 board, DElL E1405). And it also correctly detects the maximum resolution supported which is 1440x900. But still it is not creating this mode and switching to this mode. Not even going beyond 1024x768 (redundant last line).

Changed in xserver-xorg:
assignee: nobody → ubuntu-x-swat

Pankaj: you have Intel Graphics, not an Nvidia. Please 'sudo apt-get install 915resolution' in your case.

Robert: Please file a new bug report for your issue.

Mattias: Please can you include:

  /var/log/Xorg.0.log including the "being larger than the bios programmed panel size." bit

  sudo vbetool vbefp panelsize

  sudo ddcprobe

  sudo xresprobe nv

and details of what machine you have:

  cat /var/lib/acpi-support/*-*

Changed in xserver-xorg:
status: Confirmed → Needs Info

On Tue, 30 May 2006, Paul Sladen wrote:

> Mattias: Please can you include:

Sorry, these machines are now in production use with breezy, custom kernel
and the non-free nvidia driver (with the correct resolution). Do you still
want the output of these commands?

/Mattias Wadenstein

Paul: I couldn't find 915resolution in main so I suppose it is not supported
by core ubuntu team. Moreover I have read the description of
xserver-xorg-driver-i810, it says it support i915, i945 series chips. My
chipset is i945.

Also I have read about 915resolution script it modifies something in bios
but in few mailing lists people have reported screen hang problem after
using this script so I am a little scared to use this script on my laptop.
:)

Pankaj (pankaj-jangid) wrote :

Paul: I installed 915resolution from 'universe' and I was able to set resolution to the max that monitor supports 1440x900 but I am still not able to set resolution to any other resolution between 1440x900 and 1024x768. For example I can't set resolution to 1280x768.

Paul Sladen (sladen) wrote :

Pankaj: 915resolution is hack. It asks the panel what size it is. The panel says "1400x900", so 915resolutions goes and overwrite a BIOS mode to alter it to "1400x900". If you want a different mode, you need to overwrite something else. The configuration file is in:

  /etc/default/915resolution

but it is only used to construct a commandline that looks like:

  915resolution modenumber width height

so you can run those yourself if you need additional modes. This is fixed probably in Xorg for edgy.

Paul Sladen (sladen) wrote :

Pankaj: hold on this bug is for Nvidia. 915resolution is Intel i810 only.

This bug is about the bug that on a nvidia card, you can't set the maximum resolution to the correct one, please look for bug #41042 if you have an ati chipset and for bug #24927 if you have an intel chipset.

These are all problems of the drivers, thanks

I have the exact same problem.

I have the same on my HP dv8220ea with an Nvidia GeForce Go 7400. But a fresh install of Ubuntu 6.10 (Edgy Eft) uses the correct resolution of 1440 x 900.

In Ubuntu 7.04 (Feisty Fawn) Herd 1, Desktop CD, live session, the screen is incorrectly set to 1024 x 768.

I suspect this may be caused by bug #78315

Let me know if you want me to get some files off the machine, I won't risk an install, but I should be able to get them from the live session.

wax (ewax) wrote :

I have a nvidia GeForce 6200 card and am using the nvidia-glx package. I was having the same/similar problem on my desktop, (this problem occured after the upgrade from 6.06 to 6.10, now i have 7.04 herd 4 and the problem still exists.) The resolution was set to 1600*1200 but the actual resolution was 1024*768 witch was pretty annoying. I bumped in to the following solution

Open your /etc/X11/xorg.conf search for the section device and ad Option "useEDID" "False" and restart your xserver (ctrl+alt+backspace)

It might work in this case. I looked to the other bugs listed above and none of the offered solutions worked

wax (ewax) wrote :

my solution does not work in all cases...
I did figure out if i put my resolution to 1024*768 it switches to 800*600 but it sais 1024*768 in the screen resolution settings panel.
I looked at my xorg.conf and everything seems ok.

wax (ewax) wrote :

wax@ubuntu-desktop:~$ lspci -vn
00:00.0 0600: 1039:0661 (rev 11)
        Subsystem: 1043:8113
        Flags: bus master, medium devsel, latency 32
        Memory at d8000000 (32-bit, non-prefetchable) [size=64M]
        Capabilities: <access denied>

00:01.0 0604: 1039:0003 (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: d6000000-d7ffffff
        Prefetchable memory behind bridge: dff00000-febfffff

00:02.0 0601: 1039:0963 (rev 25)
        Flags: bus master, medium devsel, latency 0

00:02.1 0c05: 1039:0016
        Flags: medium devsel
        I/O ports at e600 [size=32]

00:02.5 0101: 1039:5513 (prog-if 80 [Master])
        Subsystem: 1043:8087
        Flags: bus master, medium devsel, latency 128, IRQ 16
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
        I/O ports at b400 [size=16]

00:02.7 0401: 1039:7012 (rev a0)
        Subsystem: 1043:810d
        Flags: bus master, medium devsel, latency 32, IRQ 21
        I/O ports at a400 [size=256]
        I/O ports at a000 [size=128]
        Capabilities: <access denied>

00:03.0 0c03: 1039:7001 (rev 0f) (prog-if 10 [OHCI])
        Subsystem: 1043:8087
        Flags: bus master, medium devsel, latency 32, IRQ 20
        Memory at d5800000 (32-bit, non-prefetchable) [size=4K]

00:03.1 0c03: 1039:7001 (rev 0f) (prog-if 10 [OHCI])
        Subsystem: 1043:8087
        Flags: bus master, medium devsel, latency 32, IRQ 17
        Memory at d5000000 (32-bit, non-prefetchable) [size=4K]

00:03.3 0c03: 1039:7002 (prog-if 20 [EHCI])
        Subsystem: 1043:8087
        Flags: bus master, medium devsel, latency 32, IRQ 18
        Memory at d4800000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>

00:04.0 0200: 1039:0900 (rev 91)
        Subsystem: 1043:80ff
        Flags: bus master, medium devsel, latency 32, IRQ 19
        I/O ports at 9800 [size=256]
        Memory at d4000000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at dfee0000 [disabled] [size=128K]
        Capabilities: <access denied>

01:00.0 0300: 10de:0221 (rev a1) (prog-if 00 [VGA])
        Subsystem: 1043:81e1
        Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 16
        Memory at d7000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (32-bit, prefetchable) [size=256M]
        Memory at d6000000 (32-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at dffe0000 [disabled] [size=128K]
        Capabilities: <access denied>

It works fine for me now on my 1440x900 GeForce 7200. Is anyone still having this problem in the current Feisty? If not this bug will be marked as 'Fix Released'.

Sitsofe Wheeler (sitsofe) wrote :

Nobody replied to Mattias question about whether the logs were needed. Putting this back into the Confirmed state.

Changed in xserver-xorg-video-nv:
status: Needs Info → Confirmed
Barry Shilliday (teppic74) wrote :

This is a problem for me still in Feisty - using an Nvidia 6600GT card and a Samsung 710T monitor. The resolution is set to 1024x768 despite the native resolution being 1280x1024 and cannot be set higher without hacking the xorg.conf file. Other distributions (Fedora, Suse, etc) pick the correct resolution.

Fredrik Schön (fredrikschon) wrote :

Still open for me, see comment in duplicate bug #24861

Marked as "won't fix" upstream:
"G80-based cards should be able to program the correct resolution on flat panels
with xf86-video-nv 1.99.1 and higher. This is not something we can implement
for earlier GPUs, so marking WONTFIX."

Doesn't make much sense, since the nvidia driver can do it, but that's how it is for the time being.

@ Barry: I think you have a different bug than the one reported here if it "works in Fedora". If you are able to select the right resolution using the 'nv' driver in another distro w/ the same card and monitor, then you have a different bug.

Changed in xorg-server:
status: Unknown → Rejected
Changed in xorg-server:
status: Invalid → Won't Fix
Timo Aaltonen (tjaalton) on 2008-01-28
Changed in xserver-xorg-video-nv:
assignee: ubuntu-x-swat → nobody
MichalR (rehak-michal) wrote :

I think this is a high importance problem. I was many times a witness of disappointment when potentially new user decides to try out Ubuntu Live CD and it was unable to put correct resolution on the screen.

Timo Aaltonen (tjaalton) wrote :

Michal: read the last comment on the upstream bug report; there's nothing we can do about it, only hope that the "nouveau" driver will support proper modesetting in time. That's why this bug is worth keeping open. Hopefully there'll be a stable release for Hardy+1.

MichalR (rehak-michal) wrote :

Timo: Yes, I am aware of that. I just thought that Importance should be raised from Medium to High.

Timo Aaltonen (tjaalton) wrote :

Why? I'd rather drop it to wishlist since there's nothing we can do about it.

Hi Timo,

I don't know if this will reach you, but I just had to reply to this.

What do you mean "there's nothing we can do about it"? Can't you use
Windows' detection method? Yes, there are failings in Windows that make me
itch to get started with Ubuntu, but it does a great job at detecting my
monitor's optimal resolution.

Kind regards,

Bert Visscher

----- Original Message -----
From: "Timo Aaltonen" <email address hidden>
To: <email address hidden>
Sent: Wednesday, January 30, 2008 8:38 AM
Subject: [Bug 5801] Re: (NVidia only) Wrong default and maximum resolution
onwidescreen monitor (stretched 1024x768) on GeForce 6200

> Why? I'd rather drop it to wishlist since there's nothing we can do
> about it.
>
> --
> (NVidia only) Wrong default and maximum resolution on widescreen monitor
> (stretched 1024x768) on GeForce 6200
> https://bugs.launchpad.net/bugs/5801
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
>

MrVulcan (bfv) wrote :

I completely agree. If there's 1 thing an operating system should be able to
do, it's deliver support for all necessary resolutions.
----- Original Message -----
From: "Michal" <email address hidden>
To: <email address hidden>
Sent: Tuesday, January 29, 2008 11:26 PM
Subject: [Bug 5801] Re: (NVidia only) Wrong default and maximum resolution
onwidescreen monitor (stretched 1024x768) on GeForce 6200

> Timo: Yes, I am aware of that. I just thought that Importance should be
> raised from Medium to High.
>
> --
> (NVidia only) Wrong default and maximum resolution on widescreen monitor
> (stretched 1024x768) on GeForce 6200
> https://bugs.launchpad.net/bugs/5801
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
>

Timo Aaltonen (tjaalton) wrote :

Again.. read the upstream bug report. Aaronp quite clearly points out that "this is not something we can implement
for earlier GPUs, so marking WONTFIX". It doesn't matter what you put in your xorg.conf. The driver is not able to drive those chips with widescreen resolutions. Not now, not ever. Place your bets on nouveau, which will get in Ubuntu in 8.10 at the earliest.

Bryce Harrington (bryce) wrote :

Setting to wishlist as per upstream's comments.

Changed in xserver-xorg-video-nv:
importance: Medium → Wishlist

This xorg.conf is problematic for the following reason:
An EndSection is in the wrong place.

Bryce Harrington (bryce) wrote :

wax, btw you probably know this already but the xorg.conf you posted has an error - one of your 'Section' labels is commented out.

Brian Murray (brian-murray) wrote :

The xorg.conf at http://launchpadlibrarian.net/6805148/xorg.conf and attached to this bug is problematic for the following reason:
An EndSection is in the wrong place.

Bryce Harrington (bryce) wrote :

Thank you for reporting this issue about xserver-xorg-video-nv. Starting
with Lucid, Ubuntu is transitioning to using the -nouveau video driver
by default instead of -nv. The reason for this change is because
upstream development for the -nv driver has been quite slow. We are
quite pleased with the upstream development speed for -nouveau, and hope
this will translate into swifter bug fixes as well.

Because of this, I'm closing this bug report at this time. I'm marking
it wontfix because what you describe is probably a valid issue, but we
do not have further plans to work on it in Ubuntu. If you would still like
to see this issue investigated, I would encourage you to file it
upstream at http://bugs.freedesktop.org/.

Changed in xserver-xorg-video-nv (Ubuntu):
status: Confirmed → Won't Fix
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.