wrong resolutions autodetected with Hanns.G HW194DJ monitor + NVidia GeForce 6600

Bug #474816 reported by Csipak Attila on 2009-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I just installed Karmic, but I'm getting this problem since Gutsy AFAIK. Earlier I used to found a workaround for it, mostly by hand-editing the xorg.conf, but I didn't succeed with that in Karmic so far.

The following resolutions: 1280x1024, 1024x768, 800x600, 640x480
The right resolution for this widescreen LCD would be 1440x900

As I could understand ddcprobe and get-edid both find the right resolutions, but somehow xrandr sticks to the above four.

I also tried to play with xrandr for a while (mostly following these instructions: https://wiki.ubuntu.com/X/Config/Resolution), but it didn't work. After adding a 1440x900 as a new mode, I couldn't switch to that mode with xrandr --output default --mode "1440x900", it returned the error "xrandr: Configure crtc failed".

I also tried creating an xorg.conf by hand, and also copying the xorg.conf from my previous Ubuntu install (a Jaunty), but that worked neither. At some point, startx wouldn't start wtih that xorg.conf, so I decided to give it up.

xorg package version: 1:7.4+3ubuntu7

If you need any other info I can provide, please ask, and I shall post it soon.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: fd778d863162464ea68c452803a8af6b
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Wed Nov 4 22:56:34 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
NonfreeKernelModules: nvidia
Package: xorg 1:7.4+3ubuntu7
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic-pae root=UUID=b3f31ced-d132-41c7-835e-ca5bece2cfac ro quiet splash
ProcEnviron:
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xorg
Uname: Linux 2.6.31-14-generic-pae i686
XorgConf: Error: [Errno 2] Nincs ilyen fájl vagy könyvtár: '/etc/X11/xorg.conf'
dmi.bios.date: 10/01/2004
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080009
dmi.board.name: P4P800SE
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: Rev 2.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080009:bd10/01/2004:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASUSTeKComputerInc.:rnP4P800SE:rvrRev2.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic-pae

Csipak Attila (corphicks) wrote :
Csipak Attila (corphicks) wrote :

Huh, ubuntu-bug didn't attach the output of "sudo ddcprobe", so here we go:

vbe: VESA 3.0 detected.
oem: NVIDIA
vendor: NVIDIA Corporation
product: nv43 Board - p229h3 Chip Rev
memory: 131072kb
mode: 640x400x256
mode: 640x480x256
mode: 800x600x16
mode: 800x600x256
mode: 1024x768x16
mode: 1024x768x256
mode: 1280x1024x16
mode: 1280x1024x256
mode: 320x200x64k
mode: 320x200x16m
mode: 640x480x64k
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
edid:
edid: 1 3
id: 8991
eisa: HSD8991
serial: 01010101
manufacture: 6 2007
input: composite sync, sync on green, analog signal.
screensize: 41 26
gamma: 2.200000
dpms: RGB, active off, no suspend, no standby
timing: 720x400@70 Hz (VGA 640x400, IBM)
timing: 720x400@88 Hz (XGA2)
timing: 640x480@60 Hz (VGA)
timing: 640x480@67 Hz (Mac II, Apple)
timing: 640x480@72 Hz (VESA)
timing: 640x480@75 Hz (VESA)
timing: 800x600@60 Hz (VESA)
timing: 800x600@72 Hz (VESA)
timing: 800x600@75 Hz (VESA)
timing: 832x624@75 Hz (Mac II)
timing: 1024x768@87 Hz Interlaced (8514A)
timing: 1024x768@70 Hz (VESA)
timing: 1024x768@75 Hz (VESA)
timing: 1280x1024@75 (VESA)
ctiming: 640x480@66
ctiming: 1024x768@66
ctiming: 1152x864@75
ctiming: 1280x960@60
ctiming: 1280x1024@60
ctiming: 1440x1440@60
ctiming: 1440x1440@75
dtiming: 1440x900@69
monitorrange: 30-80, 49-75
monitorname: Hanns.G HW19
monitorserial: 706HP3CY0486

Also, here's the output of "sudo get-edid|parse-edid":

parse-edid: parse-edid version 2.0.0
get-edid: get-edid version 2.0.0

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
 Function supported
 Call successful

 VBE version 300
 VBE string at 0x2110 "NVIDIA"

VBE/DDC service about to be called
 Report DDC capabilities

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
 Function supported
 Call successful

 Monitor and video card combination does not support DDC1 transfers
 Monitor and video card combination supports DDC2 transfers
 0 seconds per 128 byte EDID block transfer
 Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
 Read EDID

 Performing real mode VBE call
 Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
 Function supported
 Call successful

parse-edid: EDID checksum passed.

 # EDID version 1 revision 3
Section "Monitor"
 # Block type: 2:0 3:fd
 # Block type: 2:0 3:fc
 Identifier "Hanns.G HW194"
 VendorName "HSD"
 ModelName "Hanns.G HW194"
 # Block type: 2:0 3:fd
 HorizSync 30-80
 VertRefresh 49-75
 # Max dot clock (video bandwidth) 140 MHz
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:ff
 # DPMS capabilities: Active off:yes Suspend:no Standby:no

 Mode "1440x900" # vfreq 59.887Hz, hfreq 55.935kHz
  DotClock 106.500000
  HTimings 1440 1520 1672 1904
  VTimings 900 903 909 934
  Flags "+HSync" "-VSync"
 EndMode
 # Block type: 2:0 3:fd
 # Block type: 2:0 3:fc
 # Block type: 2:0 3:ff
EndSection

Bryce Harrington (bryce) on 2009-11-05
affects: xorg (Ubuntu) → xserver-xorg-video-nv (Ubuntu)
Bryce Harrington (bryce) on 2009-11-05
Changed in xserver-xorg-video-nv (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Thank you for reporting this issue about xserver-xorg-video-nv. Starting
with Lucid, Ubuntu is transitioning to using the -nouveau video driver
by default instead of -nv. The reason for this change is because
upstream development for the -nv driver has been quite slow. We are
quite pleased with the upstream development speed for -nouveau, and hope
this will translate into swifter bug fixes as well.

Because of this, I'm closing this bug report at this time. I'm marking
it wontfix because what you describe is probably a valid issue, but we
do not have further plans to work on it in Ubuntu. If you would still like
to see this issue investigated, I would encourage you to file it
upstream at http://bugs.freedesktop.org/.

Changed in xserver-xorg-video-nv (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers