Driver Bug for nVidia 6800 series Cards

Bug #43252 reported by Spencer Duncan on 2006-05-06
14
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nv (Ubuntu)
Medium
Unassigned

Bug Description

The nv driver used with the live cd doesn't work on 6800 series cards when acceleration is enabled. Either setting the live cd to use either the nv driver with acceleration disabled or the official nVidia drver should fix this. I don't know how to implent this, but KNOPPIX-based live cds run nv without acceleration correctly.

Matthew Lange (matthewlange) wrote :

To run nvidia cards with acceleration, you need the 'nvidia' driver instead of the 'nv'. I think it's marked as restricted, and is why it's not shipped normally. Can someone confirm this?

Spencer Duncan (whoknows43) wrote :

The reason its not shipped normally is because it would violate the GPL(IMNAL). Atleast, thats what happend to Kororaa. I found that out after I first posted this. The real issue though is that by standard the nv driver has acceleration enabled, which starts X and just has a bunch of random colors on the screen, and most new users wouldn't have the first clue on how to do this. So, I think, by standard, that the nv driver should have acceleration disabled, and if possible, prompt the user if he would like to use the closed source 'nvidia' driver as opposed to the open source 'nv' driver and tell them why.

treadstonepro (treadstonepro) wrote :

This is a nasty bug. I have not recommended Ubuntu to many of my friends because of this install/liveCD bug. Many other distro's also have this problem. The only one that I have used lately that doesn't is SuSe 10.1. Trying safe graphics doesn't help. The only way to install is in text mode.

Matthew Lange (matthewlange) wrote :

True. I installed Ubuntu fine with my 6800, just no accelleration. I really didn't notice the lack of accelleration until I tried some OpenGL screensavers. I agree there should be some kind of note, but other than that, politics wins this one... We can always provide the nvidia driver in the repositories, but shipping with the CDs would violate stuff.

Matthew Lange (matthewlange) wrote :

Perhaps if we added a "how to" to that Ubuntu How-To site, wherever it is. I dont' think it's a Canonical site, but it's very useful. Contents are under the GPL.

http://ubuntuguide.org/wiki/Dapper

Matthew Lange (matthewlange) wrote :

Marked as confirmed, but I can't seem to chance Importance to "Can't/Won't fix"

Quentin Buisan (quentin-buisan) wrote :

I ran into this problem while installing Kubuntu, and I have no idea how to disable acceleration. Can you explain how, please?

I thought Linux didn't support my card yet, and was going to give up until someone helped me out. I think many people hitting this problem will be like me, and will just think that Ubuntu is broken, or that Linux doesn't support my hardware yet. It would be a good idea to have a lowest common denominator for the installation.

Thanks.

Alfred (alfred-s-nexicom) wrote :

Hi:
Thank you for making Ubuntu available to People! My On Mother Board Video is SIS Based, but my AGP x 8 Card is an NVidia 6200. I've tried many many times to install it into Ubuntu, but each time I run into a ton of errors, I don't know the meanings of. Then the Nvidia Drivers cause problems for the SIS Drivers when I remove the AGP Card. The older GLX NVidia driver does not work for the 6200 NVidia Card. Please include this under bug 43252. The Mother board is a ASROCK K7S41 GX/.... It is as though the Hardware Detection at boot up does not work. It keeps on trying to download upgrades with the NVidia Drivers, instead of the SIS Video Drivers, now that the Nvidia 6200 card is not in the Computer. The video Works, but the driver is the wrong one! Tia Alfred!

Roberto Sarrionandia (rbs-tito) wrote :

My graphics card (XFX Nvidia 6600GT) Experiences this bug, I have to install in text mode and then install the proprietary drivers.

Marco Rodrigues (gothicx) wrote :

Still a problem on Feisty ?

Yes, still a problem on Feisty and Gutsy beta.

If any developers would like the card in question (I have now upgraded) contact me,

Timo Aaltonen (tjaalton) wrote :

Please try Hardy alpha3 to see if the issue is fixed.

Changed in xserver-xorg-video-nv:
status: Confirmed → Incomplete
Timo Aaltonen (tjaalton) wrote :

No reply, closing the bug.

Changed in xserver-xorg-video-nv:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers