Xorg does not load in karmic using Zotac ion board A series

Bug #404577 reported by Mark Cariaga on 2009-07-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nv (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by bubba_169

Bug Description

I'm regularly testing the Karmic daily build. The liveCD was unable to load properly and did not load Xorg.

I'm using this board: ZOTAC ION ITX A Series

Again, it does not proceed to the live desktop, instead loads CLI and ask for login (development branch). I hope that this gets fixed even before alpha 6.

Mark Cariaga (mzc) wrote :

It looks like the gdm does not load properly. I'll try to boot live using "safe drivers"

same result even if "safe graphics mode" was selected.

On Sat, 2009-07-25 at 15:56 +0000, mzc wrote:
> It looks like the gdm does not load properly. I'll try to boot live
> using "safe drivers"
>
> ** Attachment added: "screenshot"
> http://launchpadlibrarian.net/29517316/dsc04362.jpg
>

affects: ubuntu → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Incomplete
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hi mzcariaga-shaw,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in xorg-server (Ubuntu):
status: New → Incomplete
Mark Cariaga (mzc) wrote :
Download full text (14.1 KiB)

The issue is 9.10 does not load, this is 9.04 using 185.18 driver (my
current system) from NVIDIA:

mark@mark-desktop:~$ lspci -vvnn
00:00.0 Host bridge [0600]: nVidia Corporation MCP79 Host Bridge
[10de:0a82] (rev b1)
 Subsystem: nVidia Corporation Device [10de:cb79]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
 Latency: 0

00:00.1 RAM memory [0500]: nVidia Corporation MCP79 Memory Controller
[10de:0a88] (rev b1)
 Subsystem: nVidia Corporation Device [10de:cb79]
 Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
 Latency: 0

00:03.0 ISA bridge [0601]: nVidia Corporation MCP79 LPC Bridge
[10de:0aad] (rev b2)
 Subsystem: ZOTAC International (MCO) Ltd. Device [19da:a108]
 Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Region 0: I/O ports at 4f00 [size=256]

00:03.1 RAM memory [0500]: nVidia Corporation MCP79 Memory Controller
[10de:0aa4] (rev b1)
 Subsystem: ZOTAC International (MCO) Ltd. Device [19da:a108]
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx+
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-

00:03.2 SMBus [0c05]: nVidia Corporation MCP79 SMBus [10de:0aa2] (rev
b1)
 Subsystem: ZOTAC International (MCO) Ltd. Device [19da:a108]
 Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at 4900 [size=64]
 Region 4: I/O ports at 4d00 [size=64]
 Region 5: I/O ports at 4e00 [size=64]
 Capabilities: <access denied>

00:03.3 RAM memory [0500]: nVidia Corporation MCP79 Memory Controller
[10de:0a89] (rev b1)
 Subsystem: nVidia Corporation Device [10de:cb79]
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-

00:03.5 Co-processor [0b40]: nVidia Corporation MCP79 Co-processor
[10de:0aa3] (rev b1)
 Subsystem: ZOTAC International (MCO) Ltd. Device [19da:a108]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
 Latency: 0 (750ns min, 250ns max)
 Interrupt: pin B routed to IRQ 9
 Region 0: Memory at fae80000 (32-bit, non-prefetchable) [size=512K]

00:04.0 USB Controller [0c03]: nVidia Corporation MCP79 OHCI USB 1.1
Controller [10de:0aa5] (rev b1) (prog-if 10)
 Subsystem: ZOTAC International (MCO) Ltd. Device [19da:a108]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV...

Mark Cariaga (mzc) wrote :
Mark Cariaga (mzc) wrote :

I hope this issue with Nvidia ION will be fixed on karmic.

Mark Cariaga (mzc) wrote :

I reinstalled the driver a few days ago. let me know if this is want you want..

Mark Cariaga (mzc) wrote :
Mark Cariaga (mzc) wrote :

Hi Guys,

Out of curiosity, I tried the 9.04 livecd which was able to load but
with vesa drivers only and does not detect proprietary drivers (nvidia).
The 9.10 livecd still does not work(current build).

:)

On Mon, 2009-07-27 at 17:39 +0000, Bryce Harrington wrote:
> Hi mzcariaga-shaw,
>
>
> Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.
>
> [This is an automated message. Apologies if it has reached you
> inappropriately; please just reply to this message indicating so.]
>
>
> ** Tags added: needs-xorglog
>
> ** Changed in: xorg-server (Ubuntu)
> Status: New => Incomplete
>

Timo Aaltonen (tjaalton) wrote :

The driver does not support your chipset. Try to get a logfile from the 9.10 livecd so the failure there could be triaged.

affects: xorg-server (Ubuntu) → xserver-xorg-video-nv (Ubuntu)
Mark Cariaga (mzc) wrote :

how do i get a log file i cant login to cli (development branch its
asking for a password. as side from i dont know how to extract / create
the log file of interest. I'm willing to know how to do this, please
advise.

On Wed, 2009-08-05 at 11:23 +0000, Timo Aaltonen wrote:
> The driver does not support your chipset. Try to get a logfile from the
> 9.10 livecd so the failure there could be triaged.
>
> ** Package changed: xorg-server (Ubuntu) => xserver-xorg-video-nv
> (Ubuntu)
>

bubba_169 (simonsos) wrote :

On the live CD the username is ubuntu and there is no password just press enter when it asks for one. Im having the same problem. Below is the lspci -vvnn from my graphics card in 9.04 if it helps fix this bug.

02:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8200M G [10de:0845] (rev a2)
 Subsystem: Hewlett-Packard Company Device [103c:360a]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 20
 Region 0: Memory at c1000000 (32-bit, non-prefetchable) [size=16M]
 Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 3: Memory at c4000000 (64-bit, prefetchable) [size=32M]
 Region 5: I/O ports at 4000 [size=128]
 [virtual] Expansion ROM at c6000000 [disabled] [size=128K]
 Capabilities: [60] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Kernel driver in use: nvidia
 Kernel modules: nvidia, nvidiafb

bubba_169 (simonsos) wrote :

This is my Xorg log from attempting to startx in the ubuntu karmic daily live cd I downloaded a couple of days ago...

bubba_169 (simonsos) on 2009-08-07
Changed in xserver-xorg-video-nv (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) on 2009-08-13
tags: added: karmic
bubba_169 (simonsos) wrote :

I've found you can boot to GUI if you install the Nvidia driver. The way I did this was download and save to usb drive the driver from ftp://download.nvidia.com and then log in as the user ubuntu, mount the drive and then install. I think this bug for me has something to do with the fact nv doesnt support my graphics card which is a geforce 8200 integrated card. Perhaps you just need to set vesa as the default for those nv doesnt support?

Karmic Live CD will still not work but forcing it to install immediately
with the vesa driver and manually install the 185 driver should work.
I'm using 9.04 with this driver and everything is fine. This workaround
would be recommended if the 185 driver will not be integrated in the
9.10 release.

bubba_169 wrote:
> I've found you can boot to GUI if you install the Nvidia driver. The way
> I did this was download and save to usb drive the driver from
> ftp://download.nvidia.com and then log in as the user ubuntu, mount the
> drive and then install. I think this bug for me has something to do with
> the fact nv doesnt support my graphics card which is a geforce 8200
> integrated card. Perhaps you just need to set vesa as the default for
> those nv doesnt support?
>
>
> ------------------------------------------------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.409 / Virus Database: 270.13.65/2324 - Release Date: 08/24/09 12:55:00
>
>

Mario Limonciello (superm1) wrote :

Added regression-potential tag because for Jaunty, VESA was being picked in these scenarios.

tags: added: regression-potential
tags: removed: needs-xorglog
Changed in xserver-xorg-video-nv (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions