nv driver doesn't include the pci-id of my GeForce 7300 GT

Bug #320671 reported by Alberto Milone on 2009-01-23
8
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nv (Ubuntu)
Undecided
Bryce Harrington

Bug Description

The driver doesn't include the id reported by lspci, therefore if no driver is specified in the Device section of the xorg.conf, the "nv" driver is not used by default. The "nv" driver works well with my card though.

Affected version: 1:2.1.10-1ubuntu4

:~$ lspci -n | grep 300
01:00.0 0300: 10de:02e2 (rev a2)

The attached patch solves the problem.

Alberto Milone (albertomilone) wrote :
Gaetan Nadon (memsize) wrote :

It is still missing from 1:2.1.12-1ubuntu3 in jaunty.
The id is valid, it's in http://pciids.sourceforge.net/pci.ids and in the nvidia list of device ids.
It's for the AGP version of the 7300 GT.
I'll move the bug report to Confirm for development to handle
Thanks for taking the time to make Ubuntu better!
BugSquad

Changed in xserver-xorg-video-nv:
status: New → Confirmed
Gaetan Nadon (memsize) wrote :

Mark,
The bug reports are not duplicates, but they are related to the different behaviour that happen when a card isn't supported. I'll add a comment to bug 333040 so as not to confused this bug report.

Marc Kaplan (marc-kaplan) wrote :

add support for GeForce 7300 GT in Jaunty

Changed in xserver-xorg-video-nv:
assignee: nobody → bryceharrington
Bryce Harrington (bryce) wrote :

Patch queued to go in post-beta.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-nv - 1:2.1.12-1ubuntu4

---------------
xserver-xorg-video-nv (1:2.1.12-1ubuntu4) jaunty; urgency=low

  * Add 102_geforce_7300_gt.patch: Adds pci id for GeForce 7300 GT
    (LP: #320671)

 -- Bryce Harrington <email address hidden> Tue, 24 Mar 2009 19:06:42 -0700

Changed in xserver-xorg-video-nv:
status: Confirmed → Fix Released
Bojan Vitnik (bvitnik) wrote :

This bug still exists for a number of other GeForce 7xxx cards. The video cards affected are AGP versions of 7xxx family of cards. Both "/usr/share/xserver-xorg/pci/nv.ids" and driver sources (nv_driver.c) are missing PCI-IDs. Affected video cards are AGP versions of GeForce 7600 GT (10de:02e0), GeForce 7600 GS (10de:02e1), GeForce 7300 GT (10de:02e2) (this one is fixed), GeForce 7900 GS (10de:02e3) and GeForce 7950 GT (10de:02e4). PCI-E versions of these cards are NOT affected (PCI-IDs are present).

Just booted Jauntu LiveCD yesterday for the first time and X server failed to detect my video card (AGP version of GeForce 7600 GS - 10de:02e1). VESA driver was used instead of nv driver. By manualy adding appropriate PCI-ID to "/usr/share/xserver-xorg/pci/nv.ids" and restarting X server, autodetection worked like a charm and I didn't have any problems with nv driver - changing resolution and refresh rate worked.

References used:

/usr/share/xserver-xorg/pci/nv.ids
http://pciids.sourceforge.net/pci.ids
http://cgit.freedesktop.org/xorg/driver/xf86-video-nv/tree/src/nv_driver.c

Gaetan Nadon (memsize) wrote :

Bojan,
It is best to open a new bug report asking for added support for your card. I had to do that myself a while ago and it worked very well.

Current list of GeForce Series 7 missing support as of 1:2.1.12-1ubuntu5
GeForce 7800 GS (00f5)
GeForce 7900 GX2 (0293)
GeForce 7950 GX2 (0294)
GeForce 7950 GT (0295)
GeForce 7600 GT (02E0)
GeForce 7600 GS (02e1)
GeForce 7900 GS (02e3)
GeForce 7950 GT (02e4)
GeForce Go 7950 GTX (0297)

Bojan Vitnik (bvitnik) wrote :

Gaetan,
Sorry for answering this late, I've been very busy.

I thought of opening a new bug report but since it's related to this one, infact it's basicaly the same bug, I didn't want to make another "duplicated bug" but, if it's necessary, I'll make a new bug report. Thank's for finding more video cards missing PCI-IDs, I didn't have time to closely look at http://pciids.sourceforge.net/pci.ids. Thou, nv driver maybe doesn't realy work with some of those cards - should be tested.

As soon as I get some free time, I'll make a new bug report and maybe find some volunteers that own those cards (I know a few people) to test if nv driver is realy working with them by just adding proper PCI-IDs.

Bryce Harrington (bryce) wrote :

Bojan, don't worry about creating duplicate bugs. With launchpad it is really cheap and easy to mark bugs as dupes, so you should always file a NEW bug unless you're absolutely 100% sure it's the same bug.

Gaetan is right - file a new bug with your comment #8 and I will add support for the card you've tested to Karmic. I think I will hold off on adding the other chipsets until someone has tested them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers