Ubuntu

hardy 64bit live cd GFX issues

Reported by Dave Morley on 2007-11-30
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nv (Ubuntu)
Medium
Unassigned

Bug Description

I get the following trying to run edubuntu live 64 bit. http://picasaweb.google.com/davmor2/UbuntuScreenshots/photo#5138745957617176562

This is not good at all.

Video card from lspci attachment:

nVidia Corporation GeForce 8400M GS [10de:0427]

Dave Morley (davmor2) wrote :

Testing Alpha 1

Henrik Nilsen Omma (henrik) wrote :

Hi Dave, Please confirm that this only happens on edubuntu 64 bit, but ubuntu.

Could you please follow the instructions on https://wiki.ubuntu.com/X/Debugging and attach the appropriate debugging info. See under "Screen display corruption"

Dave Morley (davmor2) wrote :

Yes this bug is only on edubuntu Live. On the alternative cd the install was flawless and on Ubuntu, Xubuntu there was no error.

I shall add the Debugging info shortly.

Dave Morley (davmor2) wrote :

Enclosed is the X0rg log file.

Please let me know if there is any other info you require.

Dave Morley (davmor2) wrote :

I've been playing with various settings all evening and I have found a solution.

Once the first menu appears hitting F4 then selecting 1024x768 (my max res on this monitor) the process of get the desktop up is slower but I get a viewable screen. I can then install also.

Timo Aaltonen (tjaalton) wrote :

Please try hardy alpha2.

Dave Morley (davmor2) wrote :

Same thing in Alpha 2/3. The issue also affects Ubuntu and Xubuntu but not Kubuntu. So we believe it may be an issue with gdm itself.

Please let me know if there is anything else I can help you with.

Dave Morley (davmor2) wrote :

Just been doing some tests on my laptop using Ubuntu. (Laptop is a HP Pavillion DV9657EM) This has real problems in 64bit but works flawlessly in 32bit.

In 64bit I forever get no slpash screen and I always get the Xserver is in low res mode box appear. Also I notice that it isn't detecting the Nvidia GFX card that is on board.

In 32bit I get the correct resolution imediately and the screen is at 1440x900 which is correct. In this instance the nv module was correctly used.

I am therefore under the impression that it is the detection system used by 64bit that is at fault. (please fault my logic if you can :) )

Steve Langasek (vorlon) on 2008-01-25
Changed in xserver-xorg-video-nv:
status: Incomplete → Triaged
Dave Morley (davmor2) wrote :

This bug is still apparent in Alpha 4 candidate cds.

Steve Langasek (vorlon) wrote :

Dave,

Up until this point this bug has only been reported as affecting Edubuntu 64-bit, but in your latest ISO testing report (http://iso.qa.ubuntu.com/qatracker/result/1279/195) you've marked it as applying to Ubuntu alternate. Can you please clarify?

Steve Langasek (vorlon) wrote :

sorry, I see now that in mid-January you reported this as affecting Ubuntu/Xubuntu as well. Ignore me then...

Dave Morley (davmor2) wrote :

Steve I've altered the title to make it a bit more obvious hope that helps.

Dave Morley (davmor2) wrote :

bdmurray this is the laptop that is the worst.

description: updated
Dave Morley (davmor2) wrote :

This is my test machine that I took the photo of at the top of the bug report.

Dave Morley (davmor2) wrote :

This is the lspci -vvnn on my main machine. This is the one that is pretty much okay running the nv driver only plays up when I install Nvidia Driver New via jockey.

Roger E Critchlow Jr (rec) wrote :

I think this is a variant of https://bugs.launchpad.net/ubuntu/+source/usplash/+bug/147623.

There are several mentions of unusable livecd installs there dating back to feisty all involving nvidia 8xxx.

Dave Morley (davmor2) wrote :

Roger This also effects the other 2 type of nvidia cards I have to differing levels.

Roger E Critchlow Jr (rec) wrote :

Ah, I see. They're listed in the attached Xorg.log.0 and lspci outputs.

In the first Xorg.log.0 you attached, the NV xserver says:

(--) Chipset Unknown NVIDIA chip found

and the chip detected by PCI probe:

(--) PCI:*(1:0:0) nVidia Corporation GeForce 7100 GS rev 161, Mem @ 0xd0000000/24, 0xc0000000/28, 0xd1000000/24, BIOS @ 0xd2000000/17

isn't listed as supported by the NV server startup list.

The other two Nvidia chips you list:

01:00.0 VGA compatible controller [0300]: nVidia Corporation NV35 [GeForce FX 5900] [10de:0331] (rev a1) (prog-if 00 [VGA controller])
05:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400M GS [10de:0427] (rev a1) (prog-if 00 [VGA controller])

are both listed as supported by the NV xserver.

I wonder if that affects the differences in behavior you're seeing?

I also wonder why you're not seeing the problems reported in https://bugs.launchpad.net/ubuntu/+source/usplash/+bug/147623 with your GeForce 8400M machine.

-- rec --

Dave Morley (davmor2) wrote :

On my laptop which is the 8400M machine if I run in 64bit I get no splash which is why I run 32bit on it.

In 32 bit there is no problems everything displays fine. It is only in 64 bit land where I get those issues.

Dave Morley (davmor2) wrote :

My 64bit main pc's issue of black screen when the nvidia drivers were installed has been resolved (I bought a new monitor). This is the one that I have attached the log for above.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers