8-core Mac pro: problems in 7.04 and 7.10rc

Bug #152701 reported by j10 on 2007-10-14
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nv (Ubuntu)
Undecided
Unassigned

Bug Description

In the forums, it has been reported that it is possible to install 7.04 or various 7.10 development versions on intel macs, especially macbook pro. I am new to ubuntu.

I have tried to install both 7.04 and 7.10rc on a new 8-core mac pro (not macbook pro) and have failed. I have a Geforce7300 GT, pioneer drive

1. Both LIveCDs work fine on the latest pioneer drives. For me at least, there is no longer the issue of sony vs pionner drives as highlighted in the forums.

2. Screen gets garbled or turns black. I use an apple cinema display and is connected via dvi.
For 7.04, if I switch away from VGA (F4), then it loads fine. Install completes fine, GRUB starts fine (I wiped out Mac OS X), but only recovery mode can be loaded. Any other option results in a black screen with a flickering underscore (no response from CTRL-ALT-F2 etc).
For 7.10rc, clicking on install, I get a garbled screen and I'm able to call up a terminal, but this too is garbled.Only using safe graphics mode can I enter the GUI. The orange progress bar immediately after that tends to get garbled, but ubuntu will load. If I connect another monitor via the apple dvi-to-vga connection, the orange progress bar looks fine, but after that, there is no longer any signal to my monitor.

3. Ethernet is not working on both 7.04 and 7.10rc. I have 2 intel ethernet cards installed as per the mac pro configuration.
During the LiveCD bootup, I set my static IP, netmask, gateway and proxy server, but I still cannot cannot connect to the web. I have checked /etc/networks/interface and tried ifup/down and setting a resolv.conf file with my gateway address. Network tools say that my card is active and detected, is able to send and receive packets, but just cannot connect to the web.
I can connect with either ethernet card in Mac os x.

I am not sure if these are 'real' bugs, but would just like to highlight the problems encountered on a mac pro.

unggnu (unggnu) wrote :

I guess you need the nvidia-glx driver for your card.
Please poste your xorg.conf and lspci output.

j10 (jamieno10) wrote :

Thanks.

I will try to get the xorg.conf and lspci output asap, how do I get the lspci output (sorry, linux noob)

I heard about the nvidia drivers and there have been reports of workarounds involving vesa or nv drivers. In 7.04, it was set to vesa.

In anycase, the ethernet is not working and I'm not sure how I can download drivers to fix them and I need to connect to the web for work purposes as well

unggnu (unggnu) wrote :

Just insert "lspci > lspci" in Terminal. After hat there should be a file called lspci in your home directory which you can upload here. You find xorg.conf in directory /etc/X11 .

j10 (jamieno10) wrote :

Somehow I no longer have this problem in 7.10rc; I'm now able to install it and boot it up.

Ethernet was somewhat of a 'non-problem'. In 6.10 on my laptop, I just needed to set my static IP, netmask and gateway (just tested today). In 7.10rc and 7.04 I need to set the nameserver (resolv.conf) as well.

All that was done was to install rEFIt and not touch the rEFIt partition when installing. From reading the fourms, I was under the impression that one could wipe out the entire Hard-disk and just use GRUB. What is strange however, is that I no longer have garbled screens.

Graphics seem to work well - at least in the 3-4hours that I was using it - and I could lock the terminal and it prompts me for the password when I move the mouse (test this a few times.)

unggnu (unggnu) on 2007-10-15
Changed in xserver-xorg-video-nv:
status: Incomplete → Fix Released
nikita (miklos-kozary) wrote :

I had the black screen problem on a similiar configuration as well. 8-core Mac Pro, Apple Cinema Display, 7.10 final installed on the hard drive.

The solution is to remove the "splash" boot option from whatever kernel image your booting from (press "e" on top of the image in grub, remove the word "splash", press ESC and then "b" to boot - this is from the top of my head, hope it's right).

Also, check out http://macprolinux.blogspot.com/ , there's a few more articles about Ubuntu on the Mac Pro.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers