Ubuntu

Laptop screen displays only half after switching consoles with Fn+F8

Reported by rez on 2007-04-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
Won't Fix
Medium
xserver-xorg-video-nv (Ubuntu)
Wishlist
Unassigned

Bug Description

When connecting the Inspirion 1505 to an external monitor, I press Fn+F8 to cycle the display to the external monitor. Then, when I press Fn+F8 again to display the GNOME window manager on the laptop screen, it is displayed only in half of the laptop screen, the rest of the screen is dark. The only way to recover is by re-starting the window manager (Ctrl+Alt+Backspace) or by switching to one of the virtual consoles and switch back.

dell@dell:~$ sudo dpkg -l | grep xserver-xorg-video-nv
i xserver-xorg-video-nv 2.0.0-0ubuntu3 X.Org X server -- NV display driver

dell@dell:~$ lspci -v | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 110M / GeForce Go 7300 (rev a1) (prog-if 00 [VGA])

rez (rezwanul-kabir) wrote :

When connecting the Inspirion 1505 to an external monitor, I press Fn+F8 to cycle the display to the external monitor. Then, when I press Fn+F8 again to display the GNOME window manager on the laptop screen, it is displayed only in half of the laptop screen, the rest of the screen is dark. The only way to recover is by re-starting the window manager (Ctrl+Alt+Backspace) or by switching to one of the virtual consoles and switch back.

dell@dell:~$ sudo dpkg -l | grep xserver-xorg-video-nv
i xserver-xorg-video-nv 2.0.0-0ubuntu3 X.Org X server -- NV display driver

dell@dell:~$ lspci -v | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 110M / GeForce Go 7300 (rev a1) (prog-if 00 [VGA])

rez (rezwanul-kabir) wrote :
Bryce Harrington (bryce) on 2007-04-27
Changed in xserver-xorg-video-nv:
importance: Undecided → Medium
Changed in xorg-server:
status: Unknown → Confirmed

The nv driver can't support VBIOS-controlled hotkey switching, sorry.

Bryce Harrington (bryce) on 2007-05-01
Changed in xserver-xorg-video-nv:
importance: Medium → Wishlist
status: Unconfirmed → Confirmed
Bryce Harrington (bryce) wrote :

Upstream reports that the nv driver doesn't currently support VBIOS-controlled hotkey switching.
Moving to 'Wishlist'.

Changed in xorg-server:
status: Confirmed → Rejected
Bryce Harrington (bryce) wrote :

Some additional info from Alex Deucher:

the xorg driver actually has nothing to do with the hotkey stuff.
Basically one of two things happens when you press a bios hotkey
(depend on your acpi setup):
1. the bios runs some pre-defined bios command
2. an acpi event is generated

(1.) is usually the default unless you have some sort of system
specific apci module (like toshiba_acpi or thinkpad_acpi) that changes
the behavior to produce (2.).

When the bios runs a predefined command, it calls into the video bios
which bangs the hardware directly behind X's back. In the case of
your bug, I suspect the mode X sets and the one the bios sets are very
different (perhaps one is widescreen and one is not? different
timings? hard to say exactly) which results in the weird behavior. A
VT switch might help as that re-programs the mode. Video bioses also
have other limitations like sometimes they won't enable the vga port
if the LCD is active if the LCD has some weird res like 1400x1040 or
some widescreen thing.

Ideally, what we want is (2.) from above and then have a script which
listens for the event and then calls xrandr to enable/disable the
output.

Unfortunately, until then, it's always going to be hit or miss. I
hope that helps. Let me know if you need any more info.

Alex

Bryce Harrington (bryce) wrote :

More info from Aaron:

Hi Bryce,

The nv driver doesn't get any notification when the hotkey is pressed.
The VBIOS just changes the display settings out from under it, pretty
much guaranteeing that they'll be messed up.

-- Aaron

So it sounds like this is an issue with the hardware's BIOS attempting to
handle the display setting changes, and thus interfering with X's handling.
So to fix it, what will be needed is something to detect that BIOS
operation and generate an apci call for X to handle.

Changed in xorg-server:
status: Invalid → Won't Fix

Changing state per Bryce's last comment on 5/17/07

Changed in dell:
importance: Undecided → Medium
status: New → Won't Fix
Bryce Harrington (bryce) wrote :

Thank you for reporting this issue about xserver-xorg-video-nv. Starting
with Lucid, Ubuntu is transitioning to using the -nouveau video driver
by default instead of -nv. The reason for this change is because
upstream development for the -nv driver has been quite slow. We are
quite pleased with the upstream development speed for -nouveau, and hope
this will translate into swifter bug fixes as well.

Because of this, I'm closing this bug report at this time. I'm marking
it wontfix because what you describe is probably a valid issue, but we
do not have further plans to work on it in Ubuntu. If you would still like
to see this issue investigated, I would encourage you to file it
upstream at http://bugs.freedesktop.org/.

Changed in xserver-xorg-video-nv (Ubuntu):
status: Confirmed → Won't Fix
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
Changed in somerville:
importance: Undecided → Medium
status: New → Won't Fix
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306151

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.