Ubuntu

black screen on sonyvaio vpccw1 with kernel 3.4rcX

Reported by DeBø on 2012-04-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Low
Unassigned

Bug Description

My system worked fine with all the latest kernel, but with all the kernel 3.4rc (and drm-next) from "kernel.ubuntu.com/~kernel-ppa/mainline/" I get a black screen few instant after grub, the monitor seems switched off, and remains in this state.
I think it's an upstream kernel bug, but i don't know how to report it.

my system is a vaio pc cw (vpccw1) with nvidia gt230m and nouveau driver from xorg-edgers ppa (always used w/o any problem)

I tried to take a look at the logs and i found a little difference in kern.log (i removed some useless lines):

with kernel 3.4 drm-next 8 may 2012:

http://ubuntuone.com/0AeRDa3oiHZv3JPeNwdbN4

with kernel 3.3.4:

http://ubuntuone.com/3JhbiyFGmNm3O71U7TPwUi

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
Uname: Linux 3.3.1-030301-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Apr 18 14:56:18 2012
DistUpgraded: 2011-12-01 23:22:27,859 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GlAlternative: lrwxrwxrwx 1 root root 24 Apr 2 2011 /etc/alternatives/gl_conf -> /usr/lib/mesa/ld.so.conf
GraphicsCard:
 NVIDIA Corporation GT216 [GeForce GT 230M] [10de:0a2a] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Sony Corporation Device [104d:905e]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
MachineType: Sony Corporation VPCCW1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.3.1-030301-generic root=UUID=dae2cd55-c92d-4caa-9be0-3fc25592be8a ro quiet splash pcie_aspm=force vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to precise on 2011-12-01 (138 days ago)
dmi.bios.date: 09/22/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0190Y5
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y5:bd09/22/2009:svnSonyCorporation:pnVPCCW1:pvrC60385RS:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCCW1
dmi.product.version: C60385RS
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.33+git20120403.43704256-0ubuntu0ricotz
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2+git20120412+8.0.9f150ffe-0ubuntu0sarvatt
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 8.0.2+git20120412+8.0.9f150ffe-0ubuntu0sarvatt
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2+git20120412+8.0.9f150ffe-0ubuntu0sarvatt
version.xserver-xorg-core: xserver-xorg-core 2:1.12.0.901+git20120406+server-1.12-branch.259aa5a6-0ubuntu0ricotz2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0+git20120328.99340147-0ubuntu0sarvatt
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99+git20120412.d282719a-0ubuntu0sarvatt
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.18.0+git20120416.a1661620-0ubuntu0sarvatt
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20120328.ab7291d3-0ubuntu0sarvatt

DeBø (black-painkiller) wrote :
affects: ubuntu → xorg (Ubuntu)
bugbot (bugbot) on 2012-04-19
tags: added: edgers
bugbot (bugbot) on 2012-04-19
affects: xorg (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
DeBø (black-painkiller) on 2012-05-08
description: updated

DeBø, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
DeBø (black-painkiller) wrote :

Hi Christopher,
this bug seems solved since quite a few kernel (or other component) release.

DeBø, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/984866/comments/3 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers