Ubuntu

Ubuntu 12.04 beta 1 won't boot off USB key with NVidia GTX 560

Reported by David Barri on 2012-03-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Low
Unassigned

Bug Description

Hello.
So, booting off a USB of the 12.04 beta 1 image, it simply fails to load with my new graphics card (GTX 560). What happens is that both my monitors are completely blank; one is off completely, the other is on but the whole screen is black there is a single cursor that just blinks forever.

After much googling, I discovered that I could get it to boot if I hit f6 on startup and select nomodeset.
There's still a problem though. If I boot with nomodeset, one of my monitors work but the resolution is at 1280 instead of 1920. Going to the Display screen there's no option to make it higher or enable my second monitor. If I go to Control Panel -> Details -> Graphics it says the video driver is "VESA: GF104B Board - 10410050". I would've expected something with NVidia or Nouveau in it.

I'm reporting this via the ubuntu-bug tool so plenty of debug info should be attached. Let me know if there's anything else I can do.

(Also I tried another setting intel_iommu=off as well as reported in another bug but it had no effect.)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
.tmp.unity.support.test.1:

ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CasperVersion: 1.305
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Sun Mar 11 21:48:02 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 NVIDIA Corporation GF114 [GeForce GTX 560] [10de:1201] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:83b5]
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: Gigabyte Technology Co., Ltd. EP45-UD3P
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- nomodeset
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/28/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F11d
dmi.board.name: EP45-UD3P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF11d:bd10/28/2010:svnGigabyteTechnologyCo.,Ltd.:pnEP45-UD3P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnEP45-UD3P:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: EP45-UD3P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

David Barri (japgolly) wrote :
bugbot (bugbot) on 2012-03-15
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Bryce Harrington (bryce) on 2012-03-17
summary: - Ubuntu 12.04 beta 1 won't boot with NVidia GTX 560
+ Ubuntu 12.04 beta 1 won't boot off USB key with NVidia GTX 560
Bryce Harrington (bryce) wrote :

The reason it says your driver is VESA and your resolutions are capped to 1280 is because you're running the -vesa video driver. It doesn't do RANDR either, so that likely is why you see only one monitor enabled. It may be running -vesa because of nomodeset being specified.

So really the question is why is it not loading -nouveau.

affects: nvidia-graphics-drivers (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Vadim Peretokin (vperetokin) wrote :

I stumbled across the same issue with a GTX560. I get a blinking cursor and then the screen goes black. That's using an image downloaded on Jan 26th - which really means the issue was introduced earlier than beta1.

Vadim Peretokin (vperetokin) wrote :

Oh, and USB key as well, yes.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Vadim Peretokin (vperetokin) wrote :

For the record, 11.10 didn't work either. I've managed to install Ubuntu, and then boot it in recovery mode - then install the proptietary drivers and it worked almost fine. Didn't see any loading screen until the login screen came up, however.

David Barri (japgolly) wrote :

Still haven't got this working but here is some more information I've discovered.

GeForce GTX 560 code name = NVCE (GF114)

NVC0 family: These cards are generally working with the latest kernel and Mesa but may still have power management issues. It is recommended to use the Linux 3.1 kernel or newer (or a backported driver from this kernel).

NVC0 is supposed to be currently working with nouveau drivers. (http://nouveau.freedesktop.org/wiki/FeatureMatrix)

It seems that a firmware file (?) might be required but from Linux 3.1 onwards it can be generated automatically.
http://www.h-online.com/open/features/What-s-new-in-Linux-3-1-1347364.html

jintermeister (jintermeister) wrote :

Having the similar issues here. Basically, using the nouveau drivers, one HAS to boot with "nomodeset" otherwise you'll hang on a blank screen or in my case a screen with a couple of colored lines. BUT, nomodeset practically de-activates the driver and you'll fail DRM and end up with VESA capabilities. So this represents an un-usable system for many people (not sure which cards are affected). So what, no more nouveau? or is there some other workaround I've missed?

And for me, for some silly reason the proprietary drivers fail to properly recognize my monitor resolutions and I'm stuck with 600x400 which is unusable. I think this is an unrelated issue though.

Background:
http://ubuntuforums.org/showthread.php?t=1613132
http://nouveau.freedesktop.org/wiki/TroubleShooting#Xorg_fails_to_start_with_.22.28EE.29_.5Bdrm.5D_failed_to_open_device.22

Michelle Mark (topaz1968) wrote :

I would like to confirm that this problem also has affected me with my Nvidia GTX 460 card since Ubuntu 11.04 as well as just a couple weeks ago with 12.04 desktop 64 bit. I've come to accept that there are certain loops and hoops I have to jump through to complete an installation, however I"m afraid that this problem alone is going to be a huge hurdle in your accomplishing a resolution to your stated issue #1 as many people have Nvidia cards and if I weren't a quite advanced developer type user, along with quite stubborn, I would never have even installed the product at all.

I can confirm that when starting up with an installation disk on a system with an Nvidia GTX card the screen goes to black with a blinking cursor top left. If you quickly hit the F6 key then this avoids the black cursor blinking issue and allows you to see the menu with installation options. If you then also, after choosing English, press F6 and select nomodeset you can get the installation to complete, however upon system load the screen is just the pretty pink tones and then nothing, no log in, nothing. Choosing the safe mode option from grub to log into will allow a person to many error messages referring to nouveau. The only way I could find that can then successfully get you in to make changes is to:

Choose the option to go to a command prompt then
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current
startx

Then, opening the additional drivers interface ensure I am using the nvidia driver and restart. I am not sure if I forgot anything in that last list of steps, its been a couple of weeks, but I believe that is it. I found that combination of answers by reading solutions posted on many places on the internet and taking some notes and trying things. I don't think you'll get alot of people reporting this problem though as most people who are able to solve it are likely going to be people like me who are good problem solvers and enjoy the challenge and have used ubuntu before. Anyone new and without that deeper understanding is likely to just throw the disk in the trash and wonder why anyone would every use that because it is just a black screen with a blinking cursor.

Michelle Mark (topaz1968) wrote :

Additionally, if you get a solution and want a tester I am available to help test it and have an extra one terrabytes of a second partition on this 3Gb/s sata disk to play with and another 1T 6 Gb/s sata disk to test installing to as well... though I've never successfully installed to one of my 6g/s disks, I'm not sure if it was this issue on that or another as I settled in on my 3 G/s disk for ubuntu long ago.

David Barri, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
David Barri (japgolly) wrote :

New ISO worked fine out-of-the-box. Cheers.

David Barri, would you need a backport to a release prior to Trusty, or may this be closed as Status Invalid?

David Barri (japgolly) wrote :

Hello. No, I'm fine for this to be closed now. Thank you.

David Barri, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/952574/comments/12 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers