Ubuntu 11.10 won't boot with nvidia driver enabled

Bug #888373 reported by Alex on 2011-11-10
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Low
Unassigned

Bug Description

Hi!

I have a problem when I try to start Ubuntu 11.10. Ubuntu 11.04 worked fine.

When I try to start Ubuntu this pops up:
http://i.stack.imgur.com/qJJxX.jpg
"[4.629137] phy0 -> rt2800pci_mcu_status: Error - mcu request failed, no response from hardware" usually pops up there too.

I have no problems if I start Ubuntu in safe mode, or disable the nvidia driver. Everything works in safe mode(i think).

First I tried to upgrade 11.04 to 11.10, then I got this error. Then I removed the broken 11.10 installation and installed 11.10. I still can't boot without using safe mode. I have no problems on my laptop.

I've tried the suggestions posted here:
http://askubuntu.com/questions/68220/ubuntu-11-10-wont-boot-with-nvidia-driver-enabled?answertab=active#tab-top
https://answers.launchpad.net/ubuntu/+source/xorg/+question/174632

Same problem:
http://ubuntuforums.org/showthread.php?p=11390581

System specs:
CPU: i7-2600k
Memory: Corsair vengeance 16GB
Motherboard: Asus P8P67 PRO REV 3.0
GPU: Gigabyte GeForce GTX 560 Ti SOC
Disks: Corsair Force GT and two 1 TB drives for storage.
Dualbooting with Windows 7 Ultimate.

I'm not sure if Xorg is the right package for this, please correct me if I'm wrong.

Any ideas?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Er en filkatalog: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,place,regex,move,vpswitch,animation,grid,imgpng,snap,session,resize,mousepoll,wall,expo,workarounds,fade,unitymtgrabhandles,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Thu Nov 10 02:32:52 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 280.13, 3.0.0-12-generic, x86_64: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 nVidia Corporation GF110 [GeForce GTX 560 Ti] [10de:1200] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:351d]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
JockeyStatus:
 kmod:nvidia_current - nvidia_current (Merkebeskyttet, Aktiv, Ikke i bruk)
 kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Merkebeskyttet, Deaktivert, Ikke i bruk)
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 PATH=(custom, no user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=494cdbd6-1721-4b93-9745-b78bd92f01b2 ro recovery nomodeset
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/02/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1502
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8P67 PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1502:bd03/02/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8P67PRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Alex (alex-1992) wrote :
bugbot (bugbot) on 2011-11-10
affects: xorg (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
bugbot (bugbot) on 2011-11-10
tags: added: kubuntu
Alex (alex-1992) on 2011-11-10
description: updated
Alex (alex-1992) on 2011-11-13
summary: - Ubuntu 11.10 won't boot without safe mode
+ Ubuntu 11.10 won't boot with nvidia driver enabled
description: updated
Alex (alex-1992) on 2011-11-13
description: updated
Alex (alex-1992) wrote :

All drivers works, but i am not able to boot if i do not use safe mode.

Tested drivers:
- Default drivers.
- Drivers from ppa:ubuntu-x-swat/x-updates.
- Drivers form Nvidia.com.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Alex (alex-1992) wrote :

In Ubuntu 12.04 I sometimes get the "System is running in low-graphics mode" and "error: invalid environment block." message. After rebooting 1-5 times this message dissapears and I'm able to log in.

I think this is the same thing, but with the new "System is running in low-graphics mode"-message.

no longer affects: xserver-xorg-video-nouveau (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Alex, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-nouveau REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
affects: nouveau → xserver-xorg-video-nouveau (Ubuntu)
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Alex (alex-1992) on 2014-01-28
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Fix Released
Alex (alex-1992) wrote :

I'm now running 13.10 and this is no longer an issue. (Tested with GT 8400M, GT 650m, GTX 560 Ti and GTX 770 cards)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers