Ubuntu

Xorg freeze during boot after upgrading driver

Reported by WindyWeather on 2011-05-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

When installing natty on this hardware [zotac geforce 9300 motherboard] with onboard nvidia chipset, the [recommended] driver causes the system to hang during boot. It goes to a purple screen with no logo, and the HD continues activity as if the boot occurred, but the screen never comes alive to login. [auto login was selected, not stop in login screen].
The 173.14.30 drivers continue to work fine, but an upgrade to the recommended driver version [whatever that is because it is not reported in the dialog] causes the freeze on boot.
This condition occurred on 10.04, but cleared itself with an additional reboot.

I will attach the "additional drivers" screenshot.

- ww

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 173.14.30 Sat Apr 16 21:49:29 PDT 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Tue May 31 10:58:58 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-173, 173.14.30, 2.6.38-8-generic, x86_64: installed
 nvidia-current, 270.41.06, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation C79 [GeForce 9300 / nForce 730i] [10de:086c] (rev b1) (prog-if 00 [VGA controller])
   Subsystem: nVidia Corporation Device [10de:cb79]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Enabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
MachineType: NVIDIA MCP7A
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=06bee02f-8d93-477e-8a49-6a54590a6e78 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 01/06/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MCP7A
dmi.board.vendor: NVIDIA
dmi.board.version: 2
dmi.chassis.type: 3
dmi.chassis.vendor: NVIDIA
dmi.chassis.version: MCP7A
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd01/06/2009:svnNVIDIA:pnMCP7A:pvr2:rvnNVIDIA:rnMCP7A:rvr2:cvnNVIDIA:ct3:cvrMCP7A:
dmi.product.name: MCP7A
dmi.product.version: 2
dmi.sys.vendor: NVIDIA
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

WindyWeather (windyweather) wrote :
WindyWeather (windyweather) wrote :

I note that the log says that the nvidia drivers are not in use.
Not sure how that can be. Not sure how to find out what drivers are in use.
I note when running nvidia setttings that it appears the drivers are in use.

- ww

bugbot (bugbot) on 2011-06-01
affects: xorg (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Bryce Harrington (bryce) wrote :

Hey windyweather,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.