[natty] Video corruption on kernel 2.6.38-1-generic (and on -3) and nVidia Corporation GT216 [GeForce GT 230M] (rev a2)

Bug #713781 reported by Alex Mayorga on 2011-02-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Invalid
Medium
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xorg

Latest kernel update rendered X unusable.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6~3ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Sat Feb 5 13:52:32 2011
DistUpgraded: Yes, recently upgraded Log time: 2010-11-25 14:33:02.550411
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard: Subsystem: Sony Corporation Device [104d:905e]
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MachineType: Sony Corporation VPCCW1FFX
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=f415c990-a34d-451b-b69c-2070c5d53e47 ro nouveau.noaccel=1 quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
dmi.bios.date: 09/22/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0190Y5
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y5:bd09/22/2009:svnSonyCorporation:pnVPCCW1FFX:pvrR5785054:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCCW1FFX
dmi.product.version: R5785054
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Alex Mayorga (alex-mayorga) wrote :
Alex Mayorga (alex-mayorga) wrote :

The message reads:
[ 24.424978] fb: conflicting fb hw usage nouveaufv vx VESA VGA - removing generic driver

bugbot (bugbot) on 2011-02-06
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Philip Muškovac (yofel) wrote :

Reassigning to the right driver being used.

affects: nvidia-graphics-drivers (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Bryce Harrington (bryce) wrote :

Try booting with the vesafb.anything=1 kernel parameter.

This wiki page has details about how to add a kernel boot parameter for testing:

https://wiki.ubuntu.com/Kernel/KernelBootParameters

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Incomplete
Alex Mayorga (alex-mayorga) wrote :

Bryce,

I tried with the parameter on both 2.6.38-2 and 2.6.38-1 kernels but it didn't help. It still shows the progressive line of pixels.
gdm and the desktop actually load as I can hear the Ubuntu tune if I type my password and hit enter but the video is garbled and only a line of pixels towards the top of the screen can be seen.

2.6.37-12 works fine with no parameters and even some degree of video acceleration.

Bryce Harrington (bryce) wrote :

Interesting; the error message on the screen about nouveaufb conflicting with VESA VGA seems to indicate a conflict with a framebuffer driver (vesafb seems likely - we're seeing a lot of bugs related to that such as bug #702090)

Yeah, give the -3 kernel a try.

RAOF, any ideas? Is next action for this to forward upstream or is there more debugging that can be done on this end?

Chris Halse Rogers (raof) wrote :

The interesting part of the kernel log contains:
[ 12.178607] No connectors reported connected with modes
[ 12.178614] [drm] Cannot find any crtc or sizes - going 1024x768

It looks like nouveau is failing to find any acceptable modes. Since this is a laptop, that probably means that it's unable to find an LVDS mode, either in the VBIOS, by ACPI, or via EDID.

Upstream will probably want a vbios dump - you can get that with “sudo cat /sys/kernel/debug/dri/0/vbios.rom > ~/vbios.rom”

It would also be nice to get dmesg a boot with drm.debug=0xe, to have the most possible useful debugging info.

Once we've got those things this should be sent upstream.

I think the vesafb thing is not a part of the problem, although upstream will probably complain about it :(.

Bryce Harrington (bryce) on 2011-02-11
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Forwarding this bug from Ubuntu reporter Alex Mayorga Adame:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/713781

[Problem]
Starting with 2.6.38-1, user reports X on -nouveau becomes corrupt (see attached screenshot). This is a regression since 2.6.37-12

We had the reporter disable vesafb in case it was conflicting, but issue persisted.

Our guess is it looks like nouveau is failing to find any acceptable modes.

[Original Description]
Latest kernel update rendered X unusable.

I tried both 2.6.38-2 and 2.6.38-1 kernels but it didn't help. It still shows the progressive line of pixels. gdm and the desktop actually load as I can hear the Ubuntu tune if I type my password and hit enter but the video is garbled and only a line of pixels towards the top of the screen can be seen.

2.6.37-12 works fine with no parameters and even some degree of video acceleration.

DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6~3ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Sat Feb 5 13:52:32 2011
DistUpgraded: Yes, recently upgraded Log time: 2010-11-25 14:33:02.550411
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard: Subsystem: Sony Corporation Device [104d:905e]
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MachineType: Sony Corporation VPCCW1FFX
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=f415c990-a34d-451b-b69c-2070c5d53e47 ro nouveau.noaccel=1 quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
dmi.bios.date: 09/22/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0190Y5
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y5:bd09/22/2009:svnSonyCorporation:pnVPCCW1FFX:pvrR5785054:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCCW1FFX
dmi.product.version: R5785054
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Created attachment 43465
BootDmesg.txt

The interesting part of the kernel log contains:
[ 12.178607] No connectors reported connected with modes
[ 12.178614] [drm] Cannot find any crtc or sizes - going 1024x768

Created attachment 43466
CurrentDmesg.txt

Created attachment 43467
XorgLog.txt

Created attachment 43468
XorgLogOld.txt

Created attachment 43469
vbios.rom

Created attachment 43470
dmesg.txt

Alex Mayorga (alex-mayorga) wrote :

vbios.rom requested.

Alex Mayorga (alex-mayorga) wrote :

dmesg with drm.debug=0xe

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) on 2011-02-17
summary: - [natty] Video corruption on kernel 2.6.38-1-generic and nVidia
- Corporation GT216 [GeForce GT 230M] (rev a2)
+ [natty] Video corruption on kernel 2.6.38-1-generic (and on -3) and
+ nVidia Corporation GT216 [GeForce GT 230M] (rev a2)
Bryce Harrington (bryce) wrote :

Alex Mayorga Adame - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=34371 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in nouveau:
importance: Unknown → Medium
status: Unknown → Confirmed
Alex Mayorga (alex-mayorga) wrote :

Seems like the latest kernel at least allows me to get to a working desktop.

$ uname -a
Linux VPCCW1FFXL 2.6.38-4-generic #31-Ubuntu SMP Wed Feb 16 23:49:38 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

X still locks up randomly as described on bug 696104

Jeremy Foshee (jeremyfoshee) wrote :

Hi Alex,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Alright, as per comment #11 it sounds like the original issue is gone (and probably was a kernel drm issue). The user is still experiencing gpu lockups, but this is already covered by bug #553789.

Fwiw, we will need to get better GPU hang tools for -nouveau in place before we can effectively diagnose GPU lockups with that driver. Meanwhile, work directly with upstream or with the Ubuntu kernel team on them (since GPU hangs are almost always due to issues in kernel drm).

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Fix Released
Alex Mayorga (alex-mayorga) wrote :

I've now updated this laptop to Oneiric and haven't had video issues ever since.
Anything I should do to get this closed?

It appears that this bug report has laid dormant for quite a while. Sorry we haven't gotten to it. Since we fix bugs all the time, chances are pretty good that your issue has been fixed with the latest software. Please give it a shot. (Linux kernel 3.10.7, xf86-video-nouveau 1.0.9, mesa 9.1.6, or their git versions.) If upgrading to the latest isn't an option for you, your distro's bugzilla is probably the right destination for your bug report.

In an effort to clean up our bug list, we're pre-emptively closing all bugs that haven't seen updates since 2011. If the original issue remains, please make sure to provide fresh info, see http://nouveau.freedesktop.org/wiki/Bugs/ for what we need to see, and re-open this one.

Thanks,

The Nouveau Team

Changed in nouveau:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.