Ubuntu

External monitor connected via displayport is not recognized

Reported by Fabián Rodríguez on 2010-10-06
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
New
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-nouveau

After booting into Ubuntu without the cable plugged in, inserting the cable and going to System > Preferences > Monitors and choosing "detect monitors" does not detect the external monitor.

The same external monitor works properly if using the VGA connector.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
Architecture: i386
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
 edid-base64: AP///////wBMo0FUAAAAAAASAQOQHRJ4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEB0RkAUFAgDDAoGDYAHrMQAAAa0RkAUFAgDDAoGDYAHrMQAAAaAAAA/gBOODM1Q4AxMzNBVAogAAAA/gAAAAAAAAAAAAEBCiAgAOo=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Oct 6 11:46:23 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100927)
MachineType: Dell Inc. Studio XPS 1340
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic-pae root=UUID=f4337ac8-bed4-48ce-bdf6-f1d1a18ea237 ro quiet splash
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-nouveau
dmi.bios.date: 06/19/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X54
dmi.board.name: 0JE4M2
dmi.board.vendor: Dell Inc.
dmi.board.version: X54
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: X54
dmi.modalias: dmi:bvnDellInc.:bvrX54:bd06/19/2009:svnDellInc.:pnStudioXPS1340:pvrX54:rvnDellInc.:rn0JE4M2:rvrX54:cvnDellInc.:ct8:cvrX54:
dmi.product.name: Studio XPS 1340
dmi.product.version: X54
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-22-generic-pae

Fabián Rodríguez (magicfab) wrote :
Fabián Rodríguez (magicfab) wrote :

Switching back and forth between VGA and displaport configuration on the monitor later let Monitors recognize the monitor with proper resolution but when appying the setting the external monitor remains black. After the settings confirmation times out, the default setup is brought back.

Fabián Rodríguez (magicfab) wrote :

After installing the Nvidia binary drivers (recommended, current version), the nvidia-settings utility still doesn't see the external display unless the cable is removed and inserted again. Once this is done, the display can be configured with the proper resolution as expected.

Jonathan Davies (jpds) on 2010-10-06
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in ubuntu-release-notes:
status: New → In Progress
Changed in ubuntu-release-notes:
status: In Progress → Fix Released
bugbot (bugbot) wrote :

Hey Fabián,

Thanks for testing maverick during its development period. Unfortunately it looks like this bug report didn't get attention during the maverick development period. But I see there's not been more comments on the bug since the release, which makes me wonder if this is still an issue for you?

If you've not seen this issue since maverick's release yourself, it may have been solved by kernel or X or other updates that occurred late in the release; if so, would you mind please closing the bug for us? Go to the URL mentioned in this bug report, click the yellow icon(s) in the status column and set to 'Fix Released'.

If you no longer have the hardware needed to reproduce the problem, or otherwise feel the bug no longer needs tracked in Launchpad, you can set the status to 'Invalid'.

If you are the original reporter and still have this issue, just reply to this email saying so. (Or set the bug status to Confirmed.) If you are able to re-test this against 11.04 Natty Narwhal (our current development focus) and find the issue still affects Natty, please also run 'apport-collect <bug-number>' while running natty, which will add fresh logs and debug data, and flag it for the Ubuntu-X development team to look at.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Incomplete
Fabián Rodríguez (magicfab) wrote :

I no longer have access to this hardware.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Invalid
Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
status: Confirmed → Invalid
arno_b (arno.b) wrote :

I have the same problem on Natty using an nvidia card and the Nouveau drivers. See the following logs.

arno_b (arno.b) wrote :

apport-collect 655800 does not want to add my logs. Tell me how to do or if I have to open another report.

alapidas (alapidas) wrote :

This is still a bug in Oneiric

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers