Ubuntu

When displayport cable is in, system doesn't finish booting

Reported by Fabián Rodríguez on 2010-10-06
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Fix Released
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-nouveau

When a displayport cable is in, attached to a monitor, Ubuntu will boot only partially, ending up a in a black screen. The familiar Ubuntu sound is heard only partially, switching to consoles doesn't show anything except when coming back to console 7 where a corrupt frozen text login screen is shown.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
Architecture: i386
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
 edid-base64: AP///////wBMo0FUAAAAAAASAQOQHRJ4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEB0RkAUFAgDDAoGDYAHrMQAAAa0RkAUFAgDDAoGDYAHrMQAAAaAAAA/gBOODM1Q4AxMzNBVAogAAAA/gAAAAAAAAAAAAEBCiAgAOo=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Oct 6 11:41:37 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100927)
MachineType: Dell Inc. Studio XPS 1340
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic-pae root=UUID=f4337ac8-bed4-48ce-bdf6-f1d1a18ea237 ro quiet splash
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-nouveau
dmi.bios.date: 06/19/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X54
dmi.board.name: 0JE4M2
dmi.board.vendor: Dell Inc.
dmi.board.version: X54
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: X54
dmi.modalias: dmi:bvnDellInc.:bvrX54:bd06/19/2009:svnDellInc.:pnStudioXPS1340:pvrX54:rvnDellInc.:rn0JE4M2:rvrX54:cvnDellInc.:ct8:cvrX54:
dmi.product.name: Studio XPS 1340
dmi.product.version: X54
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-22-generic-pae

Fabián Rodríguez (magicfab) wrote :
Fabián Rodríguez (magicfab) wrote :

After installing the Nvidia binary drivers (recommended, current version), the system boots normally.

Jonathan Davies (jpds) on 2010-10-06
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in ubuntu-release-notes:
status: New → In Progress
Changed in ubuntu-release-notes:
status: In Progress → Fix Released

compiz not function why and what solution

Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
assignee: nobody → Heru Herdianto (herdiantoheru-yahoo)
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Fix Committed
Changed in nouveau:
status: New → Confirmed
status: Confirmed → Fix Committed

why the solution

Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
status: Confirmed → Fix Committed
Vittorio G (VittGam) (vittgam) wrote :

@ Heru Herdianto :

Please, don't play with the form options, and open another bug report for another topic.
Thanks.

Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
status: Fix Committed → Confirmed
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Fix Committed → Confirmed
Changed in nouveau:
status: Fix Committed → Confirmed
papukaija (papukaija) on 2011-06-27
Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
assignee: Heru Herdianto (herdiantoheru-yahoo) → papukaija (papukaija)
assignee: papukaija (papukaija) → nobody
Changed in nouveau:
status: Confirmed → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers