fail center screen

Bug #529130 reported by Cristian Aravena Romero on 2010-02-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nouveau Xorg driver
Fix Released
Medium
xserver-xorg-video-nouveau (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-nouveau

Not center screen
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: IXP [ATI IXP], device 0: ATI IXP AC97 [ATI IXP AC97]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: caravena 1259 F.... pulseaudio
CRDA: Error: [Errno 2] No existe el fichero ó directorio
Card0.Amixer.info:
 Card hw:0 'IXP'/'ATI IXP rev 1 with ALC655 at 0xfe029000, irq 17'
   Mixer name : 'Realtek ALC655 rev 0'
   Components : 'AC97a:414c4760'
   Controls : 41
   Simple ctrls : 26
DistroRelease: Ubuntu 10.04
Frequency: Once a day.
HibernationDevice: RESUME=UUID=f5725c47-4c8f-4d23-83e7-b10e7def5b82
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Lsusb:
 Bus 003 Device 002: ID 04f2:0403 Chicony Electronics Co., Ltd KU-0420 keyboard
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 0bda:0116 Realtek Semiconductor Corp. Mass Storage Device
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-14-generic root=UUID=badbc2ab-39df-4692-be48-c34502803b74 ro quiet splash
ProcEnviron:
 LANG=es_CL.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
Regression: No
RelatedPackageVersions: linux-firmware 1.31
Reproducible: No
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: lucid
TestedUpstream: Yes
Uname: Linux 2.6.32-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/04/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: RS/RX480SB400
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd11/04/2005:svn:pn:pvr:rvn:rnRS/RX480SB400:rvr:cvn:ct3:cvr:

Your monitor is connected through a VGA cable, right? Doesn't it have h/v position controls?

(In reply to comment #1)
> Your monitor is connected through a VGA cable, right?

Yes, See:
http://traepaca.files.wordpress.com/2008/08/vga-plug.jpg

> Doesn't it have h/v
> position controls?

Yes, have position controls.

Problem:

== Use Case ==
1) Start Ubuntu with driver nouveau and click button adjust automatic possition.
2) Reboot
3) Start Windows and click button adjust automatic possition
4) Reboot
5) Start Ubuntu with driver nouveau and click button adjust automatic possition.
6) Reboot

Problem change manuality poss

Driver Private work fine with Ubuntu and Windows, not necesary press button adjust automatic possition.

(In reply to comment #2)
> (In reply to comment #1)
> > Your monitor is connected through a VGA cable, right?
>
> Yes, See:
> http://traepaca.files.wordpress.com/2008/08/vga-plug.jpg
>
> > Doesn't it have h/v
> > position controls?
>
> Yes, have position controls.
>
> Problem:
>
> == Use Case ==
> 1) Start Ubuntu with driver nouveau and click button adjust automatic
> possition.
> 2) Reboot
> 3) Start Windows and click button adjust automatic possition
> 4) Reboot
> 5) Start Ubuntu with driver nouveau and click button adjust automatic
> possition.
> 6) Reboot
>
> Problem change manuality poss
>
> Driver Private work fine with Ubuntu and Windows, not necesary press button
> adjust automatic possition.
>

Most likely the blob defaults to a mode different from ours, could you attach Xorg logs from both nouveau and nvidia?

IIRC the blob usually doesn't print out any timings, so you'll have to run your X server with some high verbosity level, like:
# Xorg -logverbose 7

Created an attachment (id=33632)
DriverPropietary-Xorg.0.log

Created an attachment (id=33633)
DriverNouveau-Xorg.0.log

Binary package hint: xserver-xorg-video-nouveau

Not center screen

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in nouveau:
status: Unknown → Confirmed

For more information, just ask. Thanks for you work.

Chris Halse Rogers (raof) wrote :

This has been determined to be due to a difference in the default mode between nvidia and nouveau, and is being pursued on the upstream bugtracker.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

This should be fixed on latest git.

Changed in nouveau:
status: Confirmed → Fix Released

(In reply to comment #7)
> This should be fixed on latest git.

Thanks Francisco Jerez, commit in git?

(In reply to comment #8)
> (In reply to comment #7)
> > This should be fixed on latest git.
>
> Thanks Francisco Jerez, commit in git?
>

http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?id=7d5f4d048686915fd89201a4b75df9ff93ab3e81

Bryce Harrington (bryce) on 2010-03-18
tags: added: lucid

Please add patch to lucid. Thanks

Bryce Harrington (bryce) wrote :

The upstream kernel patch looks pretty safe to me. Probably should get this proposed to the kernel team.
http://cgit.freedesktop.org/nouveau/linux-2.6/patch/?id=7d5f4d048686915fd89201a4b75df9ff93ab3e81

tags: added: xorg-needs-kernel-fix
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Confirmed → Triaged

Thanks, in kernel 2.6.32-19 work fine.

$ dpkg -l | grep linux-image-2.6.32-19-generic
ii linux-image-2.6.32-19-generic 2.6.32-19.28 Linux kernel image for version 2.6.32 on x86

Changed in xserver-xorg-video-nouveau (Ubuntu Lucid):
status: Triaged → Fix Released
Changed in nouveau:
importance: Unknown → Medium
Changed in nouveau:
importance: Medium → Unknown
Changed in nouveau:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.